summaryrefslogtreecommitdiff
path: root/dev-python/aioresponses/aioresponses-0.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-20 23:10:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-20 23:10:12 +0000
commit3efb3c04b80206d986b51767e6b879119d219e42 (patch)
tree1dc83a1d5ba52b1e6b3e792ea1dae4f9e7353186 /dev-python/aioresponses/aioresponses-0.7.6.ebuild
parentbe675f929577458bd306c90ed78b62054197c0b1 (diff)
gentoo auto-resync : 20:11:2023 - 23:10:12
Diffstat (limited to 'dev-python/aioresponses/aioresponses-0.7.6.ebuild')
-rw-r--r--dev-python/aioresponses/aioresponses-0.7.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aioresponses/aioresponses-0.7.6.ebuild b/dev-python/aioresponses/aioresponses-0.7.6.ebuild
new file mode 100644
index 000000000000..67587e7c3e2e
--- /dev/null
+++ b/dev-python/aioresponses/aioresponses-0.7.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Helper to mock/fake web requests in Python's aiohttp package"
+HOMEPAGE="
+ https://github.com/pnuckowski/aioresponses/
+ https://pypi.org/project/aioresponses/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These tests require Internet access
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_address_as_instance_of_url_combined_with_pass_through
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_pass_through_with_origin_params
+)