summaryrefslogtreecommitdiff
path: root/dev-python/aioresponses/aioresponses-0.7.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
commit05a3b7c2189f095dfc46fbb03d4b3e801d3dc13a (patch)
tree46ab17fba7d43e3132d97ee97ebd604dea996018 /dev-python/aioresponses/aioresponses-0.7.4.ebuild
parentc73b611d606bc14760bad8592f5bfec28c9b1079 (diff)
gentoo auto-resync : 14:12:2022 - 09:29:38
Diffstat (limited to 'dev-python/aioresponses/aioresponses-0.7.4.ebuild')
-rw-r--r--dev-python/aioresponses/aioresponses-0.7.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/aioresponses/aioresponses-0.7.4.ebuild b/dev-python/aioresponses/aioresponses-0.7.4.ebuild
new file mode 100644
index 000000000000..92347ad7285d
--- /dev/null
+++ b/dev-python/aioresponses/aioresponses-0.7.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helper to mock/fake web requests in Python's aiohttp package"
+HOMEPAGE="
+ https://github.com/pnuckowski/aioresponses/
+ https://pypi.org/project/aioresponses/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These tests require Internet access
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_address_as_instance_of_url_combined_with_pass_through
+ tests/test_aioresponses.py::AIOResponsesTestCase::test_pass_through_with_origin_params
+)