summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 02:38:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 02:38:08 +0100
commite30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (patch)
tree52a6fb418c3c24a068b82cfac791df09ebf7e91f /dev-python/aiohttp
parent12795ed0561fe52503d6aa3a1c60888553a03bd2 (diff)
gentoo auto-resync : 27:10:2023 - 02:38:08
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest2
-rw-r--r--dev-python/aiohttp/aiohttp-3.8.6-r1.ebuild111
-rw-r--r--dev-python/aiohttp/files/aiohttp-3.8.6-brotlicffi.patch46
3 files changed, 159 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 364d5d657cdc..dab923513e55 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,5 +1,7 @@
+AUX aiohttp-3.8.6-brotlicffi.patch 1187 BLAKE2B fa565cea0a3a6ad118c1e1af7677cc393199e671a8a87d856b217b31024368248cb2df0515702867ea72f581c795658a70151a3004a718b3dffb9e16baf45269 SHA512 b3b4dc632ef0aa2045c90120c6110675e7df898bd858201eaba1b07c5551d32b37bfabb3685b7a31792e1b3b0dcb9c6d258ac4c6a8bfbbf65a8beeea96bf08fd
DIST aiohttp-3.8.5.tar.gz 7358303 BLAKE2B e1a7df12380cded655a57735527607cc95661da99fe4a5c1aec40a2586deecee97592c9ea5e9bd43621bf069fe87f00d7bef712fab2b84783e14ff229495a7c6 SHA512 613dfe836c511832c68eadbd0a76882ec362ff956937aa913fc7567b7e3e1ac2085a70a1eca42fb016f38c076a131b506b22f26879ad06b077cb4a85e9dcd8db
DIST aiohttp-3.8.6.tar.gz 7352172 BLAKE2B 4dc602abb4f9bd7c65bda7d11cde3e703bbc7786fb3f8ef36922caef42912b2c10a198ebdcecd3fcd022c3a9a729766a2023636f756a8fa10663bf988554f967 SHA512 43f1dd6670d90aefee7f0f30411b13c643ea684815b493cc4437e5f1981f4fdf4b718a40543d7c3c8c70d8b27470b8f3bf1609e46146362e0490ce0990a057f5
EBUILD aiohttp-3.8.5.ebuild 2832 BLAKE2B 1d9b5196e844fd201e1d28217e39554f627a2035119edab7e809e65ede573353c047fd2b4f94309e190a7f82044901439bdc935f817f878938c10c522736035e SHA512 bf3f241e24f65dfbefe3c2be95dd0d471e8c048b9534964613659456f913f1cf0afa2b5c20b7f11e61b84aff43608e1b1a47004b4cd65b9fc8bbafbc4563c787
+EBUILD aiohttp-3.8.6-r1.ebuild 2891 BLAKE2B 2783e0c384163b6e01dd0b62a22dee97bcfa9e6a30f1d962a41136ca5591049685c2c103dc8ff7662cf1b0671de7a8c48d226e7ffe2887166e5c2c7798953d3b SHA512 c3bf74f79fa4793d71252d25f0e1e6fdc97600e91a0ae04ff086e3d1fc8c478f55162a69fc40d5fd62e2699b1ffab25f0b1912e76c5536ed5e5072a1e2b81fc6
EBUILD aiohttp-3.8.6.ebuild 2876 BLAKE2B 0a9abc97eb9f7c067d01b6856871593ba95b4a221b0f1542b66da6ff3cc6bae2be09fa4975e70032cef6e2c734ec958a8098a63766ce8c2247abb60b563b578b SHA512 1e7c9d2d009700af9c9fbb71e8b687414ff5f603db7916c2b58fb18f740411c8d3e5854dca398d1502eb43ac34f069caf60de25298a3d22f94750f03b7a83295
MISC metadata.xml 490 BLAKE2B 5233af0b5e2668b1eb62278b05b62f24f1ab90f6d05b20dd9f1c5b54b846919c3fa28b843df28f5bfa320996d46de0e74c7a28bd0bef02aaaca14b1cec52baba SHA512 9b701c5c5a22b6aa94977a67bc40f3dc9df8337556952658a2a17ecaaa471cd7f7b5b8bf3a0088208087677555f0cbb8760c091b03b96ee70affe3e2b84cf6d5
diff --git a/dev-python/aiohttp/aiohttp-3.8.6-r1.ebuild b/dev-python/aiohttp/aiohttp-3.8.6-r1.ebuild
new file mode 100644
index 000000000000..626addcde05a
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.8.6-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="HTTP client/server for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/aiohttp/
+ https://pypi.org/project/aiohttp/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/aiosignal-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0.0_alpha3[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ <dev-python/charset-normalizer-4[${PYTHON_USEDEP}]
+ >=dev-python/charset-normalizer-2.0[${PYTHON_USEDEP}]
+ >=dev-python/frozenlist-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-brotlicffi.patch"
+ )
+
+ # increase the timeout a little
+ sed -e '/abs_tol=/s/0.001/0.01/' -i tests/test_helpers.py || die
+
+ # xfail_strict fails on py3.10
+ sed -i -e '/--cov/d' -e '/xfail_strict/d' setup.cfg || die
+
+ # which(1)... also -Werror, sigh
+ sed -i -e 's:which:command -v:' -e 's:-Werror::' Makefile || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ # workaround missing files
+ mkdir requirements tools || die
+ > requirements/cython.txt || die
+ > tools/gen.py || die
+ chmod +x tools/gen.py || die
+ # force rehashing first
+ emake requirements/.hash/cython.txt.hash
+ > .update-pip || die
+ > .install-cython || die
+ emake cythonize
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # proxy is not packaged
+ tests/test_proxy_functional.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_client_session.py::test_client_session_timeout_zero
+ # broken by irrelevant deprecation warnings
+ tests/test_circular_imports.py::test_no_warnings
+ # TODO
+ tests/test_client_session.py::test_request_tracing_url_params
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ # upstream unconditionally blocks building C extensions
+ # on PyPy3 but the test suite needs an explicit switch,
+ # sigh
+ local -x AIOHTTP_NO_EXTENSIONS=1
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,xdist.plugin,pytest_forked
+ rm -rf aiohttp || die
+ epytest -n "$(makeopts_jobs)" --forked
+}
diff --git a/dev-python/aiohttp/files/aiohttp-3.8.6-brotlicffi.patch b/dev-python/aiohttp/files/aiohttp-3.8.6-brotlicffi.patch
new file mode 100644
index 000000000000..20e3c7ea0e5d
--- /dev/null
+++ b/dev-python/aiohttp/files/aiohttp-3.8.6-brotlicffi.patch
@@ -0,0 +1,46 @@
+From 4d60891531637aed2fdc50a5dff4809d7d9b3f32 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 20 Sep 2023 15:28:37 +0200
+Subject: [PATCH] [3.9] Support brotlicffi alternatively to brotli (#7611)
+ (#7620)
+
+---
+ aiohttp/http_parser.py | 5 ++++-
+ tests/test_http_parser.py | 5 ++++-
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/aiohttp/http_parser.py b/aiohttp/http_parser.py
+index 91e01f43..521ff5db 100644
+--- a/aiohttp/http_parser.py
++++ b/aiohttp/http_parser.py
+@@ -49,7 +49,10 @@ else:
+ from typing_extensions import Literal
+
+ try:
+- import brotli
++ try:
++ import brotlicffi as brotli
++ except ImportError:
++ import brotli
+
+ HAS_BROTLI = True
+ except ImportError: # pragma: no cover
+diff --git a/tests/test_http_parser.py b/tests/test_http_parser.py
+index 4b185c9e..dc373ea8 100644
+--- a/tests/test_http_parser.py
++++ b/tests/test_http_parser.py
+@@ -21,7 +21,10 @@ from aiohttp.http_parser import (
+ )
+
+ try:
+- import brotli
++ try:
++ import brotlicffi as brotli
++ except ImportError:
++ import brotli
+ except ImportError:
+ brotli = None
+
+--
+2.42.0
+