summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/aiohttp
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest4
-rw-r--r--dev-python/aiohttp/aiohttp-3.6.1.ebuild80
-rw-r--r--dev-python/aiohttp/aiohttp-3.6.2.ebuild15
3 files changed, 14 insertions, 85 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 6e797c2d1f17..04ac86d81f29 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,5 +1,3 @@
-DIST aiohttp-3.6.1.tar.gz 1113678 BLAKE2B cfdf1c650ec52c7b6423f7afd40060ccd1631a407f126bf64c2a353c51f09c31bae3912b8ce9397c0c8350a2e82a98724ae58335998d1ab08ae46a49abce0251 SHA512 4939b89d45abcd655ef212ff87f66a83882fb12dffb87d62ae57afcd9517725af61f46f9b7428112e2dcd72d3a4027524967461270ede34348ff3ead47d14c9b
DIST aiohttp-3.6.2.tar.gz 1076923 BLAKE2B 14327a0bc5b5fffdf436a4c3525e4c25d80100aa464ed652316f7724c2bea6de4ace6c27e8a2a8cf9d895673ed63ed52e8c958ad611636e1e524a4e40efa4735 SHA512 49bd3089158c05ff6312420190ccd7fed95efb4a18b8aff7497d5507c71c692080d6949801edabdcd95379ca8e6614398408118d72ff1e782399e059e2cfc1a8
-EBUILD aiohttp-3.6.1.ebuild 2179 BLAKE2B 956ae3f0a7439a67cda6bf44834fa28f5e2db93725fed02f4841f207f7dc3eac68e4a81a78df42e2f5cfebe53dbe1dc10d1012962e57fe8961dc4df985310e1a SHA512 c1e631f18adf1e21a4a901bb6074aee8dc4635a6cae6f2d74ec6e8a00e3f08d9bd494d92c85f3699035e6ed322c709a5f8e3ea2161c0447b3412b9f1e527b74d
-EBUILD aiohttp-3.6.2.ebuild 6359 BLAKE2B 36dd3377a17cef08b98cf1b8db6e9e9d2dfb13c31dfbdc7728efc4db797fada894b036b064a328a4c3c12e44b431de347b040265188bb83891e9abbb3c71acdd SHA512 89559ca6aef2a70245bf0bbf3b6132bea7355def36e36a1025a24a84ebed1dc685de3f2a89b44a478e8e72d0518cc96b1fba87ad12a9fd5bc0c34782269edd5e
+EBUILD aiohttp-3.6.2.ebuild 6735 BLAKE2B 00434ce6c8b45397f0889f5197ca10e0ce3de1c2f7eb5741028a1b615376f8105666b0778614e6131c10d628a97d7c9287345b5fa6b536800c9d5cd5fab4686d SHA512 f5bdf64d06cbb164664b0acc7996eb3bf3f0d6917c16072eeb7d345e3b0b469eaad1360226264610349b6f8317222d7254a6cdd89224e9d5a886eadbb51a371c
MISC metadata.xml 489 BLAKE2B beb80da34848dfe7b81ed65d75923480644ecf42e2c5ce04a7f66f3e729651fdc6035054482aff966ec9f03cfbb812d3be0afd783af69e37f1002182e4885473 SHA512 d8c9e2edb8a57a3b6b02bb5314aef77dc266af6e80fd0300eb0652c59790232017d0062f5b7361b059c382d1c904f0f46cd0e672d1963e9595f3d4dc7514f182
diff --git a/dev-python/aiohttp/aiohttp-3.6.1.ebuild b/dev-python/aiohttp/aiohttp-3.6.1.ebuild
deleted file mode 100644
index ce4a47d87b07..000000000000
--- a/dev-python/aiohttp/aiohttp-3.6.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="http client/server for asyncio"
-HOMEPAGE="https://pypi.org/project/aiohttp/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- >=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
- >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
- dev-python/idna-ssl[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/typing-extensions[${PYTHON_USEDEP}]' \
- python3_{5,6})
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-blockdiag[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-aiohttp-theme[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/brotlipy[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.4.0[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-DOCS=( CHANGES.rst CONTRIBUTING.rst CONTRIBUTORS.txt HISTORY.rst README.rst )
-
-python_prepare_all() {
- # FIXME
- rm tests/test_pytest_plugin.py || die
- sed -i -e 's:test_testcase_no_app:_&:' tests/test_test_utils.py || die
-
- # remove pointless dep on pytest-cov
- sed -i -e '/addopts/s/--cov=aiohttp//' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/aiohttp/aiohttp-3.6.2.ebuild b/dev-python/aiohttp/aiohttp-3.6.2.ebuild
index cd2cfb9da4fe..2633950f67a7 100644
--- a/dev-python/aiohttp/aiohttp-3.6.2.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.6.2.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
@@ -29,6 +29,7 @@ DEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
${COMMON_DEPEND}
+ !!dev-python/pytest-aiohttp
dev-python/async_generator[${PYTHON_USEDEP}]
dev-python/brotlipy[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
@@ -111,6 +112,9 @@ python_prepare_all() {
sed -e 's|^def test_aiohttp_plugin_async_fixture(|@pytest.mark.xfail\n\0|' \
-i tests/test_pytest_plugin.py || die
+ sed -e 's|^def test_static(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_route_def.py || die
+
sed -e 's|^async def test_mixed_middleware(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_new_style_middleware_class(|@pytest.mark.xfail\n\0|' \
-e 's|^async def test_new_style_middleware_method(|@pytest.mark.xfail\n\0|' \
@@ -121,6 +125,9 @@ python_prepare_all() {
sed -e 's|^async def test_client_disconnect(|@pytest.mark.xfail\n\0|' \
-i tests/test_web_protocol.py || die
+ sed -e 's|^async def test_static_file_range(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_web_sendfile_functional.py || die
+
sed -e 's|^async def test_partially_applied_handler(|@pytest.mark.xfail\n\0|' \
-i tests/test_web_urldispatcher.py || die
@@ -134,5 +141,9 @@ python_prepare_all() {
}
python_test() {
- pytest -vv "${S}/tests" || die "Tests fail with ${EPYTHON}"
+ pushd "${BUILD_DIR}/lib" >/dev/null || die
+ ln -snf "${S}/tests" tests || die
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+ rm -rf .pytest_cache tests || die
+ popd >/dev/null || die
}