summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/aiohttp
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 06224691be9c..648235b8c993 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,3 +1,4 @@
DIST aiohttp-3.8.1.tar.gz 7324180 BLAKE2B 99f85b8510782a31de2d2f6c8efa65ef5c5cde600a5c5f49d6362d5833a0443b9adcaed9beb27c5d8502aca37af154b06017f48836b73d4c61d78204b62b7f05 SHA512 3611549393e50c8d30426aee9ddd23794a71ddefe4384eb549049b93e452fafb38de7ad900737213b61fbe717bd85035a780c1622593eae250328f17d484a0a7
+EBUILD aiohttp-3.8.1-r1.ebuild 3655 BLAKE2B da35da9b2fad5c2d5460f1f0aacfbd025bf3bcc44c92c0a9065bb56cf03dac0a5d625ffdedf93336fbe17c4fd9ad128079a1d6a1283db312d57d3fa88c2fe501 SHA512 f9584dc24e952c3754f1e58297538fcb06e0befb096281673d377acb2208bf05a6701fab2a1162c00806b584072f8fedac7d90b1084448cfe67aebb6a8ff40b4
EBUILD aiohttp-3.8.1.ebuild 2650 BLAKE2B 248a67aa42970a04d65b82bb7a75934ee97a75e401280ee1daca08f6b7d63a003d9cb2cb10e5d89474c065f030d5bf7770380b41f99d9a731c75215622cee805 SHA512 54c8399221adfae897b72d077a1f973a8f808daa24c744cb836b2cb3801c4805da34f28d52a9258f4b03e44174ac69ee6064c0651978a5810153336c1bcf44d6
MISC metadata.xml 490 BLAKE2B 5233af0b5e2668b1eb62278b05b62f24f1ab90f6d05b20dd9f1c5b54b846919c3fa28b843df28f5bfa320996d46de0e74c7a28bd0bef02aaaca14b1cec52baba SHA512 9b701c5c5a22b6aa94977a67bc40f3dc9df8337556952658a2a17ecaaa471cd7f7b5b8bf3a0088208087677555f0cbb8760c091b03b96ee70affe3e2b84cf6d5
diff --git a/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild b/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild
new file mode 100644
index 000000000000..e0d71889aa44
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 multiprocessing
+
+LLHTTP_COMMIT=69d6db2008508489d19267a0dcab30602b16fc5b
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/aiohttp/
+ https://pypi.org/project/aiohttp/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ >=dev-python/aiosignal-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/async_timeout-4.0.0_alpha3[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/charset_normalizer-2.0[${PYTHON_USEDEP}]
+ >=dev-python/frozenlist-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ !hppa? ( !ia64? (
+ dev-python/trustme[${PYTHON_USEDEP}]
+ ) )
+ )
+"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/alabaster-0.6.2' \
+ 'dev-python/sphinxcontrib-asyncio' \
+ 'dev-python/sphinxcontrib-blockdiag' \
+ 'dev-python/sphinxcontrib-newsfeed' \
+ 'dev-python/sphinxcontrib-spelling' \
+ 'dev-python/sphinx' \
+ 'dev-python/sphinx-aiohttp-theme'
+
+src_prepare() {
+ # increase the timeout a little
+ sed -e '/abs_tol=/s/0.001/0.01/' -i tests/test_helpers.py || die
+
+ # xfail_strict fails on py3.10
+ sed -i -e '/--cov/d' -e '/xfail_strict/d' setup.cfg || die
+
+ # which(1)...
+ sed -i -e 's:which:command -v:' Makefile || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ # workaround missing files
+ mkdir requirements tools || die
+ > requirements/cython.txt || die
+ > tools/gen.py || die
+ chmod +x tools/gen.py || die
+ # force rehashing first
+ emake requirements/.hash/cython.txt.hash
+ > .update-pip || die
+ > .install-cython || die
+ emake cythonize
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # proxy is not packaged
+ tests/test_proxy_functional.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # runtime warnings
+ 'tests/test_client_functional.py::test_aiohttp_request_coroutine[pyloop]'
+ # Internet
+ tests/test_client_session.py::test_client_session_timeout_zero
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # C extensions are not used on PyPy3
+ tests/test_http_parser.py::test_c_parser_loaded
+ )
+ ;;
+ python3.11)
+ EPYTEST_DESELECT+=(
+ # known problem with tests, not code itself
+ 'tests/test_client_functional.py::test_timeout_on_reading_headers[pyloop]'
+ 'tests/test_client_functional.py::test_timeout_on_conn_reading_headers[pyloop]'
+ 'tests/test_client_request.py::test_data_stream_exc_chain[pyloop]'
+ tests/test_test_utils.py::TestAioHTTPTestCase::test_example_with_loop
+ tests/test_test_utils.py::TestAioHTTPTestCase::test_example_without_explicit_loop
+ tests/test_test_utils.py::TestAioHTTPTestCase::test_inner_example_without_explicit_loop
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,xdist.plugin,pytest_forked
+ rm -rf aiohttp || die
+ epytest -n "$(makeopts_jobs)" --forked
+}