summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild')
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
deleted file mode 100644
index 9b27fc1c0416..000000000000
--- a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="SOCKS proxy connector for aiohttp"
-HOMEPAGE="https://pypi.org/project/aiohttp-socks/"
-SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-# Tests require Internet access
-RESTRICT="test"
-
-RDEPEND=">=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- net-proxy/3proxy
- )"
-
-python_configure_all() {
- rm tests/3proxy/bin/*/* || die
- if use test; then
- ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}