summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-cors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-python/aiohttp-cors
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/Manifest4
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild2
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild41
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
index 9d469be24a49..3ccd7bb2d49b 100644
--- a/dev-python/aiohttp-cors/Manifest
+++ b/dev-python/aiohttp-cors/Manifest
@@ -1,3 +1,5 @@
DIST aiohttp-cors-0.6.0.tar.gz 42507 BLAKE2B 7b63916b983d3dc208058c8b04445a30762eebc4999135ae802d1ceeeccc476a335eae66126bb3fd16f938af3649e8b9096433c2df09e82bf4e5d4ba8e38c42c SHA512 75453ebbc074d5f25cc8efc46ffdb76fc90b0a96a9e6fce0eee5a5f28dba31cb50301289cac3b36c70ccdbc10c8f4ba9e362d8e9f350ba7f9dfacd06e6f5e699
-EBUILD aiohttp-cors-0.6.0.ebuild 1112 BLAKE2B 009f09b9520da6d5b72e968be95e1463d1ef4e90137a3f4ead73d402f0c712b29729fc66ff410e63e5ac25d9fddf94817922d73eba0aaefc910d5edc42503057 SHA512 9c60033bcfaca86e7329acbd6ca9cc2fddae953ee3570b29865b733102e53067df1f252ccbd4a634d2ffbba6a22d530b422ea33a045891c03a0b587101ceec12
+DIST aiohttp-cors-0.7.0.tar.gz 39728 BLAKE2B 747499856272f551cf8e2e0911ff7cbb2c7cb8a1f3159327dd8f0d40cabbbd9713a1a9e30ef9c99f3f9642567c99025e049db837c89f907d6698a27005ac2632 SHA512 72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b
+EBUILD aiohttp-cors-0.6.0.ebuild 1114 BLAKE2B 3f1f254f99f6d408fca471c99bcb5326f85a65c125110a22f1810cbdc52109f6b0a93cd82be0af8df5f44f2e12b91edaa2367adddb47956643449b4e1052664a SHA512 a99d07dcad0374b244b7dc3713dc6d9d9b69aa98ed1767f2b735d2e9575f2dcf2de97c3f71d0f96f0c8b8e523a8eb270948ca9f4c465b9d6349e2682fa559f98
+EBUILD aiohttp-cors-0.7.0.ebuild 1114 BLAKE2B d52a42162c78dc524ffce2389311335a1c4a6ea0147434571382d1bd3a6078f348984103081ce6b82b5a1a7431e66f79b8a8dd1fa01cc88d61982dff52f9e8a8 SHA512 64993361f2f3ef2de3d46803e1519665281c667b44322dd2ef2b381db1552c793ca94358c9796fe535ececcdc4ab7e0747c91754642f90fa8759c0217cc5eb37
MISC metadata.xml 253 BLAKE2B 0311910d10e4b501d39c01678bb1e58bed2e6e3252e6c3195d3284cf2e9652081b10a83f045689a56c69a4d318b209bfdac0a63ff6dab2a8fbb0160ac9c7e2e2 SHA512 bf75301ff2098e846a7d6dc9166d1c8b6e77b4f92327e5c5aad0edcde6274e6aa224d89c2c5ed7efc6fb7fcc7258a2a01a24591a43688679c4109f8cc89fd9b1
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
index 2ef943a0aea3..e5b671ad5b8e 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
new file mode 100644
index 000000000000..6bd3345141ef
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}