summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-cors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/aiohttp-cors
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/aiohttp-cors')
-rw-r--r--dev-python/aiohttp-cors/Manifest3
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild6
-rw-r--r--dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch27
3 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/aiohttp-cors/Manifest b/dev-python/aiohttp-cors/Manifest
index e08046aeedb4..cc8682c37890 100644
--- a/dev-python/aiohttp-cors/Manifest
+++ b/dev-python/aiohttp-cors/Manifest
@@ -1,5 +1,6 @@
+AUX aiohttp-cors-0.7.0-py3_11.patch 845 BLAKE2B 896c500c515b2eaea059ad9c071701062a06c26ae7b7907d9e34060bd5574c5b9a94e1d3c3e36e5e8e6548bad0af2001a12cf360c39524d03623c1ee69542583 SHA512 45562ff9471412c9ba2b5f0af51ba7d0535ffd05227a71edfd2864ff92766757fe186b0f2d68021d624c82177f18e723c248be917e4b4676ae8255896cd1309c
AUX aiohttp-cors-0.7.0-py3_7.patch 991 BLAKE2B e2a08dab701bd31e4a9008c8f89ae97508fb6b99b89db69a05b731849e09c6f04e8b148d82d38f2093e00bb9bee03e45f230cfc8eff4b71ca7797a95524732e2 SHA512 efe7c488d9f30da7eebbe355d86c603657bddc75c88f5cd1bb4b0e76b17f26f5827cc2f42ab8766767a4ad16c08fa636a4f61e50a8c478e7f32eb2567e26427c
AUX aiohttp-cors-0.7.0-tests.patch 2422 BLAKE2B 4660be793987dd0cd5c945703aa4d6d4b499ba0ab1c305b80e26bac9cc87d811131f6ab179e402821740f193bbfc86a384b58e35aaa453fdfd5d4db3bcc44b23 SHA512 b3fa463b87a112529443f516fe1c37ffda092e8a0133a6d37f407519e32842f65773c87e939082591edb969ee243170be3a4828896ec5ffc1150c3f43aedd9d5
DIST aiohttp-cors-0.7.0.tar.gz 39728 BLAKE2B 747499856272f551cf8e2e0911ff7cbb2c7cb8a1f3159327dd8f0d40cabbbd9713a1a9e30ef9c99f3f9642567c99025e049db837c89f907d6698a27005ac2632 SHA512 72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b
-EBUILD aiohttp-cors-0.7.0-r2.ebuild 959 BLAKE2B c6f3f46f7cb5a45710d19782f8cf363f6436074b22537ffc658dba28ae73e51c1dceac39beda032d543eb7e5c6d415639ba14f3188a6c1d1a9fc3db1dda71169 SHA512 32e07eb8f5fee418518a9dbfba7556908ca9e9500e80e47f61acd1b1a05efebdace9e88965ac2a2c8910d441a0deebdc72a7ed08f7d4e29d704d59488823b1cf
+EBUILD aiohttp-cors-0.7.0-r2.ebuild 1046 BLAKE2B c0bfd45b370d59fde44a9eb71a2cd725705e79b1c34bc88b22d0194ab5ac06d15cac002a859d7a04452459e300a8472b02b09d3e4cf62595931e60bea403b485 SHA512 e47ac631459f1e44e07fba8bd3f5ff9281d143198405c8f0535224cdd69d251f9d0f2ee73c91cc207f7e2970e729fa1ec2907d11658ab07605dc659388da508c
MISC metadata.xml 558 BLAKE2B db98935b061e7553213d771c0293892bdb2db6209715121a775dec9eee3df6498addbdc64a5c8c9174e8ae7ebac0be3785645a97de238e4320f5724280a406b8 SHA512 4a97a4bb76eef1ce332b6df9d6d2dead19dfce48bbd9705a5ee8ad50c1e66a98b24f7d40425b81acf82347afb1e809d0b7ddd67419c039c3dd1e0a4d2c358de5
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
index 329aec1efb4f..b502e01bf456 100644
--- a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -28,10 +28,12 @@ BDEPEND="
distutils_enable_tests pytest
-# https://github.com/aio-libs/aiohttp-cors/pull/278
PATCHES=(
+ # https://github.com/aio-libs/aiohttp-cors/pull/278
"${FILESDIR}/${P}-tests.patch"
"${FILESDIR}/${P}-py3_7.patch"
+ # https://github.com/aio-libs/aiohttp-cors/pull/412
+ "${FILESDIR}/${P}-py3_11.patch"
)
src_prepare() {
diff --git a/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch b/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch
new file mode 100644
index 000000000000..2dd0df4b61e2
--- /dev/null
+++ b/dev-python/aiohttp-cors/files/aiohttp-cors-0.7.0-py3_11.patch
@@ -0,0 +1,27 @@
+From 1eb2226aaf664d0be746753a32f82ee2e04c2f0b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
+Date: Tue, 1 Mar 2022 15:31:54 +0100
+Subject: [PATCH] Replace @asyncio.coroutine decorator with async def
+
+In Python 3.11 @asyncio.coroutine decorator was removed and it should
+be replaced with async def call.
+
+Fixes: #280
+---
+ tests/unit/test_cors_config.py | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/tests/unit/test_cors_config.py b/tests/unit/test_cors_config.py
+index 817410e..9fe1052 100644
+--- a/tests/unit/test_cors_config.py
++++ b/tests/unit/test_cors_config.py
+@@ -29,8 +29,7 @@ async def _handler(request):
+
+ class _View(web.View, CorsViewMixin):
+
+- @asyncio.coroutine
+- def get(self):
++ async def get(self):
+ return web.Response(text="Done")
+
+