summaryrefslogtreecommitdiff
path: root/dev-python/aiodns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/aiodns
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest3
-rw-r--r--dev-python/aiodns/aiodns-1.1.1.ebuild29
-rw-r--r--dev-python/aiodns/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
new file mode 100644
index 000000000000..7ca72a2db9d0
--- /dev/null
+++ b/dev-python/aiodns/Manifest
@@ -0,0 +1,3 @@
+DIST aiodns-1.1.1.tar.gz 6084 BLAKE2B 8e58cedcf288f87ca9cc8d5f067bdf182f220979aba3d2aa53eb998ae877dcaa7c2a7419a50719ba150fdf17271d025668b28a3212fc5a819bf13129b4fb25a2 SHA512 4bd8b80a10f84b82b13ba4ff6abbb1afd13ba6cfececc4db7c4bd303569473316f1c0e083f1017a450875fc8994a70c30c9a1b3fb2278fee5e27158973bc3810
+EBUILD aiodns-1.1.1.ebuild 713 BLAKE2B 79e55c89c2e26376be7dae85545add40ac091b414b6651dc323dec7b85782d73c226ea4d363f660c3a2588bb931a759ba3747ebe345553563538291fdf1be839 SHA512 11f0dc70e18db198c934400d47e74d8e9183b248ba4f81e7aa85a1d5ecf5969628bf6a183298b2de66f82076a10a22e1b5f8a4a5bc3e800a3acd3c7f5647a8d6
+MISC metadata.xml 340 BLAKE2B e607777274ea754605542b7ade5ba3d118ff366ae3bc57f586031450dd54e43189e0e1b3fd8305e351380bda96289e0cd95e074fdebaa7816da757329203775f SHA512 b77ba4eb56072b4801832400361bcc80e73c2f0f1507e9abfd8c9beaa255594554b4a2555e3304307af6c515bea097311c70f515f875a7a98cc197e5cf538ce3
diff --git a/dev-python/aiodns/aiodns-1.1.1.ebuild b/dev-python/aiodns/aiodns-1.1.1.ebuild
new file mode 100644
index 000000000000..bee1a51b31d0
--- /dev/null
+++ b/dev-python/aiodns/aiodns-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/trollius[python_targets_python2_7]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON:-python}" tests.py || die
+}
diff --git a/dev-python/aiodns/metadata.xml b/dev-python/aiodns/metadata.xml
new file mode 100644
index 000000000000..8d8dfc10de75
--- /dev/null
+++ b/dev-python/aiodns/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">aiodns</remote-id>
+ <remote-id type="github">saghul/aiodns</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>