summaryrefslogtreecommitdiff
path: root/dev-python/aiodns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
commit496936ff0f7db69d1f7317341230acb866e3c330 (patch)
tree1541e919cd45c0ab5bdee8f1ac1344508da3b3af /dev-python/aiodns
parentc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (diff)
gentoo auto-resync : 29:07:2022 - 21:08:17
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest3
-rw-r--r--dev-python/aiodns/aiodns-3.0.0-r1.ebuild31
-rw-r--r--dev-python/aiodns/metadata.xml1
3 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index eab8fe813e44..173709b11403 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1,4 +1,5 @@
AUX aiodns-3.0.0-py3.10-tests.patch 757 BLAKE2B 1b5040841b3ced3b83b330e0033f54ee6ee97a8d025f22d87674f5fca9858e48febbf25c6b3441ba5b27ef9cb15f841e65f25ed999b9f536559ec50e1f010bbc SHA512 85219c885ee70871fb43f53e2ec52c164b08b63e120ee5ca5bc4531ea71155b6d81f5a813f056eabf7f4da2b425b12df6b5649cc7a9ba98d0ca9473043ee1829
DIST aiodns-3.0.0.tar.gz 6743 BLAKE2B 2a3c61156069fa598df58191b35383da3e054396cdeb1bc8916cc0414bb6efc89d45789883a5b4f33e3a08a6ee544356b02d6c697c096deae3398f0ff4d3c316 SHA512 8c1016f3b0cb461e70e9a55034f9ad3b3db705a845bf20bb6503c7a5d592b4c5d2e8ddc60b375c5fafdc559dc4566736f4c93f26710be2dcbd181284ef039825
+EBUILD aiodns-3.0.0-r1.ebuild 762 BLAKE2B 6859d0c7e611679135f461e4e8d1ca3d2f7b809f9a14fb25f6c03e4dafd5c7ff8d9eabc5ac12590bc491ec44f36008c5f0176ccf7657cbce961a6016a552a071 SHA512 55ea509800684fb7d38c0e9387c82020b064a3149e4d4583772b7833a07408e3096798dffe61c340e09c53a33bb9c3b41205e4e490f40757fe437f1cd4d9a551
EBUILD aiodns-3.0.0.ebuild 754 BLAKE2B 033e9b64c372f9de617da381d0fd005f5d5074dba184c0d1a20a293ba8972639c2501968411ed80aed6c4c48e07c67fdcc43ccab3bfaa0a02f3317e83aefa487 SHA512 38b21e170aa27d72b54f9ab84a91185231016d02bfab6f1b270c3f6cbe92eedaddc9ce3ff5d8b63adf64e84d942556b98d7cb2d21e038ae18c53dae739131fa5
-MISC metadata.xml 442 BLAKE2B 077b8bbddaed2aefc1b3f94e2339a9b226c5c5e7c61bf3fafe890eb0432b87556312833236908c1dd1da1cc8344db63d5a8764f4487df4179a94d23bf9a34287 SHA512 0228d78702c35d00f1ffdfdab987492e2cf1be67c0eee92b62c62a483623d7a2e8580a6e3714a5cd581722bf297c3ee9c53843565090b1a138c55dd3afda081c
+MISC metadata.xml 466 BLAKE2B 6f6f9859ea69490be57bf7c6581e3b51b8b0f3563cc013e072bcc221a81eaf7ade938e935a730c125452c0c6c8ac45d8c91ce1748cfa3ea1df3db55fa4c59d31 SHA512 101ea2c67fcd9b0c9496892422f7eac07d1c381f1fead1706c96fafdf5c2bb48f3c3b6912a166ee20a8b54be12e2989367674813c98aba0fd896f63110c8ee1c
diff --git a/dev-python/aiodns/aiodns-3.0.0-r1.ebuild b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..3b55866582f3
--- /dev/null
+++ b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ # https://github.com/saghul/aiodns/commit/146286601fe80eb4ede8126769e79b5d5e63f64e
+ "${FILESDIR}/${P}-py3.10-tests.patch"
+)
diff --git a/dev-python/aiodns/metadata.xml b/dev-python/aiodns/metadata.xml
index 038171b90df8..96a9f345bdbc 100644
--- a/dev-python/aiodns/metadata.xml
+++ b/dev-python/aiodns/metadata.xml
@@ -8,6 +8,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">aiodns</remote-id>
<remote-id type="github">saghul/aiodns</remote-id>