summaryrefslogtreecommitdiff
path: root/dev-python/aiodns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/aiodns
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest4
-rw-r--r--dev-python/aiodns/aiodns-1.2.0.ebuild27
-rw-r--r--dev-python/aiodns/aiodns-2.0.0.ebuild26
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index 417e3a0a3f9d..190b05bd65e4 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1,3 +1,7 @@
DIST aiodns-1.1.1.tar.gz 6084 BLAKE2B 8e58cedcf288f87ca9cc8d5f067bdf182f220979aba3d2aa53eb998ae877dcaa7c2a7419a50719ba150fdf17271d025668b28a3212fc5a819bf13129b4fb25a2 SHA512 4bd8b80a10f84b82b13ba4ff6abbb1afd13ba6cfececc4db7c4bd303569473316f1c0e083f1017a450875fc8994a70c30c9a1b3fb2278fee5e27158973bc3810
+DIST aiodns-1.2.0.tar.gz 6457 BLAKE2B c1035e5a31b179665be1c7c75e3e8f6665e04c43d5f2bada7e0d7ef76f17d99d2d86c2bd5063fbda2d2947c7a4aa1e21e66cef070019da6bf56e94d716edc0ea SHA512 2e80c275d98f54378b121cafe4680221f29eb57346976b3c476c7110fcb215892744982de25736193663ab4ac3f3cf516fa38b664e3303e6c67180ed6c31e21b
+DIST aiodns-2.0.0.tar.gz 5948 BLAKE2B 70944ffbfa3fa1c591c5aab6ce2c4c59564a7665fd2eda1b544616a4481e58464f918081dfb21f74db08ebe4c7e43eebd17e0dc314cf79423835a182a257cd11 SHA512 d80b8f7641234c4d367e4554b10c5a66265e75ee82c58adf2a36f9e369bb1dbf4341dd6459f10540b771de3f102454511ca81eddf3082733e88c09bbdf125fe0
EBUILD aiodns-1.1.1.ebuild 708 BLAKE2B 11ae61d4a66ea3fb1c940417e21cbdb209d6b40bb3d3831b289ddac551b1d9e0d1aabb7de8ccd4147042532d7589eecf38bce138cf482bcf7217159943256f85 SHA512 fb5abb7d904d927e81af9123cf40f3d2b1c21599ff8342bc9734dca2b214eeb246e2c457ea17dc9ada619feb686198f0dda912236b33e0566c44b3e7adc6df9c
+EBUILD aiodns-1.2.0.ebuild 692 BLAKE2B 978d98048ffc0d239493730dedab4e580dcb411885110597494ad8390e09d9e31ab3b5ab888c32a922dc854bf6dc1321230c5fac8d47db567aa05e40bb4d85df SHA512 6a6f8802e5e0e5778a98ecd5be89a408fd731a4b430603170c09163044da5bdf8b778ad00b3f8e11ea6210edf17d82e29dbcd97b82f5f793eed82249a91df846
+EBUILD aiodns-2.0.0.ebuild 620 BLAKE2B 888cb9792f90ba164b9b91566427b99e5ad53f19cadac04ad8eec09fd8624cd260ae1426d3c4acf2f3188c0ec4563cff96de387d5a845fb8ac6197f47c8e2a61 SHA512 57dddd8c913582912c15245133832dbf7b7480093ffa815f44ccc7e2e1fa12f4d1f68402687301c920ef35e4c48daa044881e64cc411d2d429d769d55508a4a7
MISC metadata.xml 340 BLAKE2B e607777274ea754605542b7ade5ba3d118ff366ae3bc57f586031450dd54e43189e0e1b3fd8305e351380bda96289e0cd95e074fdebaa7816da757329203775f SHA512 b77ba4eb56072b4801832400361bcc80e73c2f0f1507e9abfd8c9beaa255594554b4a2555e3304307af6c515bea097311c70f515f875a7a98cc197e5cf538ce3
diff --git a/dev-python/aiodns/aiodns-1.2.0.ebuild b/dev-python/aiodns/aiodns-1.2.0.ebuild
new file mode 100644
index 000000000000..3f3766200b23
--- /dev/null
+++ b/dev-python/aiodns/aiodns-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+$(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' -2)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}
diff --git a/dev-python/aiodns/aiodns-2.0.0.ebuild b/dev-python/aiodns/aiodns-2.0.0.ebuild
new file mode 100644
index 000000000000..7763f5b57eb9
--- /dev/null
+++ b/dev-python/aiodns/aiodns-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}