summaryrefslogtreecommitdiff
path: root/dev-python/aiocache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
commitfa77846c708f4d0541b610846a5f2ed14b4b20c1 (patch)
tree35860ca9d75749380daddffe86bbd70d3c5866a9 /dev-python/aiocache
parent640c4638f1e12a2c71f539ee18564a0c82d19947 (diff)
gentoo auto-resync : 07:08:2023 - 09:24:28
Diffstat (limited to 'dev-python/aiocache')
-rw-r--r--dev-python/aiocache/Manifest2
-rw-r--r--dev-python/aiocache/aiocache-0.12.2.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/aiocache/Manifest b/dev-python/aiocache/Manifest
index fd22b89f5983..82d948a228bc 100644
--- a/dev-python/aiocache/Manifest
+++ b/dev-python/aiocache/Manifest
@@ -1,4 +1,6 @@
AUX aiocache-0.12.0-fix-test-installation.patch 477 BLAKE2B 1e6592046299ecdea9d7afa08d7018dfc80d3eebebe4ba4190cdda24dfeee84fd10a12ef6d153c958ad2e117f4f5907505117d602a9d3c4f65988f0b8e5cd9e6 SHA512 d03d38f77767afecc4d2d2ae3c65fb4f06db2341cffba12c78e02b472bad90b63c0a0cf451ef58627da1e89310e9e16b60d875330cbab4da80fe328d3b0eac6f
DIST aiocache-0.12.0.tar.gz 127002 BLAKE2B efb07ff146d777e99154c839d01665d35fbba410e1a1ca80d4c71f639e69abf43509d79398679027f0a94eb24cfdf933f5762418bd3f43dd441281cc1b1b5236 SHA512 8437c148cc2d40737c0352b0a2fa19636124b71bc03f206066e5c7b8910aa0f0bddfa40587d50a4acd86abd88e8db595a92e267d4b25234f20ccba94e5a63e7e
+DIST aiocache-0.12.2.tar.gz 131851 BLAKE2B a8467ec12321248f7673245c427567d2c8ef345a6a34694618fce0969e186de47097d64c3b94cbf047a281a1ed09889075862d9770f7787daaf9469f245b2493 SHA512 ce57e3fdbd428e8a8a94a45e5196e339d40f4fffa49851c3486b264e6344d72fe39407bd958a97baa7af06433c08a0e9d6a7ae44eff515dfc40012804ac876f2
EBUILD aiocache-0.12.0.ebuild 680 BLAKE2B 66209b269d7ac9ed4ceba5ff63d4c1274c3e37cd2b5eb92a7f4cfb5c6e5b5bdd6168387a7ecf3c67ab0aaf7c052c28cded5f20150ea39a7e2a9874396e78367b SHA512 bd895d359ed9d385af738a890e9b5fbf856702ed989510c76f564623a10458c72643f53f1ce2b97644cdaf73907bbbf6fe0f2b7cdf842c4ab7253529ca7573c2
+EBUILD aiocache-0.12.2.ebuild 1228 BLAKE2B 4a836d2a9c42be0fa6b15d87c5fccfcacc4bb8ba31de03b50f4d2cf3366cc86c09555134e6972b1533cdfa55798a40b5eb22645b3e7e8dc46e8c136959df2556 SHA512 69180b43e801ee5216a0bdfd3ec2f85a245962488ff15430adfbef57a0eacf7e8e10979582adce9cb7369066f6324ddbea476bfd3d8cbb5f1313f41fa81018db
MISC metadata.xml 500 BLAKE2B f74a5803ae517ae0b4ed0a9d20093403c5366dead8cc2f77fe5655ffbb1022e4837aa7020bda5f6df75bced1a84adbbfdd2260310944c4874ef2862f261d7a27 SHA512 4d94698017e3953641cfd3687b2ba1bceffe25e47875aa34da0db5ce73a225aa3f58a72d33534d2e683162bc2cb5b74b2c2705b6a7956a3f76b918b6d1ad8923
diff --git a/dev-python/aiocache/aiocache-0.12.2.ebuild b/dev-python/aiocache/aiocache-0.12.2.ebuild
new file mode 100644
index 000000000000..654d767ca7eb
--- /dev/null
+++ b/dev-python/aiocache/aiocache-0.12.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Asyncio cache manager"
+HOMEPAGE="
+ https://github.com/aio-libs/aiocache/
+ https://pypi.org/project/aiocache/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ >=dev-python/msgpack-0.5.5[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # benchmarks
+ tests/performance
+ # requires aiomcache
+ tests/ut/backends/test_memcached.py
+ )
+
+ epytest -o addopts= -m "not memcached"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ # Spawn Redis for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}