summaryrefslogtreecommitdiff
path: root/dev-python/aiocache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/aiocache
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/aiocache')
-rw-r--r--dev-python/aiocache/Manifest4
-rw-r--r--dev-python/aiocache/aiocache-0.12.0.ebuild35
-rw-r--r--dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch12
-rw-r--r--dev-python/aiocache/metadata.xml16
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/aiocache/Manifest b/dev-python/aiocache/Manifest
new file mode 100644
index 000000000000..bee295cb8d9c
--- /dev/null
+++ b/dev-python/aiocache/Manifest
@@ -0,0 +1,4 @@
+AUX aiocache-0.12.0-fix-test-installation.patch 477 BLAKE2B 1e6592046299ecdea9d7afa08d7018dfc80d3eebebe4ba4190cdda24dfeee84fd10a12ef6d153c958ad2e117f4f5907505117d602a9d3c4f65988f0b8e5cd9e6 SHA512 d03d38f77767afecc4d2d2ae3c65fb4f06db2341cffba12c78e02b472bad90b63c0a0cf451ef58627da1e89310e9e16b60d875330cbab4da80fe328d3b0eac6f
+DIST aiocache-0.12.0.tar.gz 127002 BLAKE2B efb07ff146d777e99154c839d01665d35fbba410e1a1ca80d4c71f639e69abf43509d79398679027f0a94eb24cfdf933f5762418bd3f43dd441281cc1b1b5236 SHA512 8437c148cc2d40737c0352b0a2fa19636124b71bc03f206066e5c7b8910aa0f0bddfa40587d50a4acd86abd88e8db595a92e267d4b25234f20ccba94e5a63e7e
+EBUILD aiocache-0.12.0.ebuild 726 BLAKE2B 1002aacc95100e550eec348fc5d37dcf26bebf856c52e1dc83e4ee474331455c6dc0145d789dd5998489be488429850f8b55566cab2524fc84f495978076c161 SHA512 435ebcc52d569a650fc72180ef6f4402ec48c71db63cf0a0e7d1fd8b0456070f24792fe94aeff181b6c75294f669f130a468bb28b3f93d1c710fd260839eed6b
+MISC metadata.xml 500 BLAKE2B f74a5803ae517ae0b4ed0a9d20093403c5366dead8cc2f77fe5655ffbb1022e4837aa7020bda5f6df75bced1a84adbbfdd2260310944c4874ef2862f261d7a27 SHA512 4d94698017e3953641cfd3687b2ba1bceffe25e47875aa34da0db5ce73a225aa3f58a72d33534d2e683162bc2cb5b74b2c2705b6a7956a3f76b918b6d1ad8923
diff --git a/dev-python/aiocache/aiocache-0.12.0.ebuild b/dev-python/aiocache/aiocache-0.12.0.ebuild
new file mode 100644
index 000000000000..ac1baf19bf02
--- /dev/null
+++ b/dev-python/aiocache/aiocache-0.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio cache manager"
+HOMEPAGE="https://github.com/aio-libs/aiocache/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# TODO add optional cache systems deps (and new package aiomcache)
+# Tests require all backends
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-fix-test-installation.patch" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}
diff --git a/dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch b/dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch
new file mode 100644
index 000000000000..a64f618931ed
--- /dev/null
+++ b/dev-python/aiocache/files/aiocache-0.12.0-fix-test-installation.patch
@@ -0,0 +1,12 @@
+diff -Naur aiocache-0.12.0.orig/setup.py aiocache-0.12.0/setup.py
+--- aiocache-0.12.0.orig/setup.py 2023-01-13 21:54:07.000000000 +0100
++++ aiocache-0.12.0/setup.py 2023-02-09 22:45:48.004077571 +0100
+@@ -29,7 +29,7 @@
+ "Programming Language :: Python :: 3.11",
+ "Framework :: AsyncIO",
+ ],
+- packages=find_packages(),
++ packages=find_packages(exclude=['tests*']),
+ install_requires=None,
+ extras_require={
+ "redis": ["redis>=4.2.0"],
diff --git a/dev-python/aiocache/metadata.xml b/dev-python/aiocache/metadata.xml
new file mode 100644
index 000000000000..a54e1b0a7be8
--- /dev/null
+++ b/dev-python/aiocache/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">aiocache</remote-id>
+ <remote-id type="github">aio-libs/aiocache</remote-id>
+ </upstream>
+</pkgmetadata>