summaryrefslogtreecommitdiff
path: root/dev-python/aiocache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-27 01:25:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-27 01:25:47 +0100
commitabc3bfc07d931f667a0f50cf607f1c8a49af879f (patch)
treee1955376c90c745c2b110a9abf62eb2d5c209a2b /dev-python/aiocache
parent21dea977c89ba487b57c7856a4924950e667f209 (diff)
gentoo auto-resync : 27:09:2024 - 01:25:47
Diffstat (limited to 'dev-python/aiocache')
-rw-r--r--dev-python/aiocache/Manifest2
-rw-r--r--dev-python/aiocache/aiocache-0.12.3.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/aiocache/Manifest b/dev-python/aiocache/Manifest
index 4d3bdaadc4d4..b673aa6e86fd 100644
--- a/dev-python/aiocache/Manifest
+++ b/dev-python/aiocache/Manifest
@@ -1,3 +1,5 @@
DIST aiocache-0.12.2.tar.gz 131851 BLAKE2B a8467ec12321248f7673245c427567d2c8ef345a6a34694618fce0969e186de47097d64c3b94cbf047a281a1ed09889075862d9770f7787daaf9469f245b2493 SHA512 ce57e3fdbd428e8a8a94a45e5196e339d40f4fffa49851c3486b264e6344d72fe39407bd958a97baa7af06433c08a0e9d6a7ae44eff515dfc40012804ac876f2
+DIST aiocache-0.12.3.tar.gz 132196 BLAKE2B 281c3d107f6a925ee80f49004c908d982829f4609a0bea8cff5932f76b908b11db7feb969daa2b92da6483cb5cf1d60c79fb0c9fd67d379a1e2f77e609a48b39 SHA512 f1caabcc994564255dcef7db31b337c487b4f6add1f9c3256a49e43a1d35210e72e3fcc6ca5e535c92a5d9ea7fed0dfca55d495b0dafae5fa68ffea8e1d9ebc3
EBUILD aiocache-0.12.2.ebuild 1593 BLAKE2B f8b0de8dfcc942f400ebaa5434a37d7022a3b31e33a77ac554e009afcd4e955cca1873d90541a932de54e2eb0cbbc3c4d4e1afc47c371dccacad9bd838a35096 SHA512 430f02fb73a669d9884b729d8e1495db19801ad40c76c3937b15bf7a8c4fe5c9628d7e8ebac75dd154da959eb7a2e0e0a0fbb3fd758ae0806492e6e60fded6d6
+EBUILD aiocache-0.12.3.ebuild 1593 BLAKE2B f8b0de8dfcc942f400ebaa5434a37d7022a3b31e33a77ac554e009afcd4e955cca1873d90541a932de54e2eb0cbbc3c4d4e1afc47c371dccacad9bd838a35096 SHA512 430f02fb73a669d9884b729d8e1495db19801ad40c76c3937b15bf7a8c4fe5c9628d7e8ebac75dd154da959eb7a2e0e0a0fbb3fd758ae0806492e6e60fded6d6
MISC metadata.xml 500 BLAKE2B f74a5803ae517ae0b4ed0a9d20093403c5366dead8cc2f77fe5655ffbb1022e4837aa7020bda5f6df75bced1a84adbbfdd2260310944c4874ef2862f261d7a27 SHA512 4d94698017e3953641cfd3687b2ba1bceffe25e47875aa34da0db5ce73a225aa3f58a72d33534d2e683162bc2cb5b74b2c2705b6a7956a3f76b918b6d1ad8923
diff --git a/dev-python/aiocache/aiocache-0.12.3.ebuild b/dev-python/aiocache/aiocache-0.12.3.ebuild
new file mode 100644
index 000000000000..dd4566086e0c
--- /dev/null
+++ b/dev-python/aiocache/aiocache-0.12.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# py3.13: https://github.com/aio-libs/aiocache/issues/863
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Asyncio cache manager"
+HOMEPAGE="
+ https://github.com/aio-libs/aiocache/
+ https://pypi.org/project/aiocache/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/marshmallow[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.5.5[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by newer dev-python/redis (?), removed upstream
+ tests/ut/backends/test_redis.py::TestRedisBackend::test_close
+ )
+ local EPYTEST_IGNORE=(
+ # benchmarks
+ tests/performance
+ # requires aiomcache
+ tests/ut/backends/test_memcached.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not memcached" -p asyncio -p pytest_mock
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ # Spawn Redis for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}