summaryrefslogtreecommitdiff
path: root/dev-python/agate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/agate
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest2
-rw-r--r--dev-python/agate/agate-1.7.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index 77db88922d39..4d3f0854ac79 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,3 +1,5 @@
DIST agate-1.6.3.tar.gz 202102 BLAKE2B b1a5624b4744b8f3ed266470da580cef2f2e1cf6159e1b33fcd461e4abd235c5e3fe0da35408a42c92fd4abf14a1f841a1ab9eb6cd31545d826a5223e85b4904 SHA512 e83a03c5a3e4b7fa9997030ce0d33e7b59b397e2ae07ee6a723eb7fb708a7fa8b8c4322dd034f42bf664bf2911d89731fd060e4ff33a237f83114a83312ac5ed
+DIST agate-1.7.0.tar.gz 201944 BLAKE2B 4d3ac4cd0fc9f7e11175524652ba1bc13ee2b07e30115f807745387cde4ae9f49be3885dce93a2c3738d1fd4f6c005cb6db1103068510fe6caef635c04dd03e3 SHA512 75781ed3e46dbe5dd9a541bb3d968081b9776721b1518f232d551cbba8d792c43cab7ffccd9dfebd6303f167132808ccab409d8b92b3fc0c48a6314aec0b8c9d
EBUILD agate-1.6.3-r2.ebuild 1282 BLAKE2B b1d322cde533e572fca11731bb6aa1597cc98010cf95317a26be049c1dd6862c32391ffcc0fc1f8c3b08ea78c29d362b1fc73acfc9110ed26daa251b942cb83b SHA512 c22457637c75799021b2309806ca274a6ce355da9328b0290df3627cffde3c4c39bea351a5cb67fd26b6f9e231453a120b2ceff736cec7eab2a3ab78dbffe892
+EBUILD agate-1.7.0.ebuild 1281 BLAKE2B 2422ed2315912d81357b72a9016010664e898eccf51a5f908824185af27002d377634d8f608d6c4e9748c3076d298fa8c62b4612dca979d31bd62129668da2cf SHA512 903e8f3d4ac79ea8e82d382958bdbc871e909cfdd4c94ff53e17ba1dcd538f4f7fff675ce5811248057e644393ec36b74ab646cb42d943d63547bf2872c88646
MISC metadata.xml 611 BLAKE2B a288b63c7859d99467f9304b4d8b007b9df6b4345157e3b7363f23757797fa7f84420b8a515f754775de14893c2fba1ddd62fc3757f5b96f791f65b524db41f7 SHA512 3101db1d600b60da2704dd732b898db6d932ef2305a28dbfdc8b221fc7938a72309e1fd27af4567b4930a20f00490ad8d65bd962978df44cf401ddd058442f02
diff --git a/dev-python/agate/agate-1.7.0.ebuild b/dev-python/agate/agate-1.7.0.ebuild
new file mode 100644
index 000000000000..06a2044936d2
--- /dev/null
+++ b/dev-python/agate/agate-1.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)
+
+python_prepare_all() {
+ sed -i -e "s:\\(parsedatetime>=2.1\\),[^']*:\1:" setup.py || die
+ distutils-r1_python_prepare_all
+}