summaryrefslogtreecommitdiff
path: root/dev-python/agate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/agate
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest2
-rw-r--r--dev-python/agate/agate-1.6.3.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index 2749f7ae899b..bd8ecd7c8cc8 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,3 +1,5 @@
DIST agate-1.6.2.tar.gz 191216 BLAKE2B 63e89f6815a36dea956e8a919aeb926291eaf1f4d5eaac7f96dab97c6958dfee4788e18a4c1325a5b8cebf15df27b32e75409ddeab1289c1e8e548088fdc0ea7 SHA512 34d9e45d162bce69d28ad0ec07f5b410b2cdac831e5bd986ca8cb8902fd0ca1ec67663b2f956f42acaf18b8ca0fa169d5236aa4cee7457765e4e86d837e7794e
+DIST agate-1.6.3.tar.gz 202102 BLAKE2B b1a5624b4744b8f3ed266470da580cef2f2e1cf6159e1b33fcd461e4abd235c5e3fe0da35408a42c92fd4abf14a1f841a1ab9eb6cd31545d826a5223e85b4904 SHA512 e83a03c5a3e4b7fa9997030ce0d33e7b59b397e2ae07ee6a723eb7fb708a7fa8b8c4322dd034f42bf664bf2911d89731fd060e4ff33a237f83114a83312ac5ed
EBUILD agate-1.6.2-r1.ebuild 2753 BLAKE2B 4c80f6ab093d11f85d96215ee86d929fc788ad7714e61632886f1806bd8909c677e5e65887919ab6514c88d08f6697fd37c0d657876e000f86a56c9b13db3fc3 SHA512 7b2bffbdf6dba030b97a6213e7d47c43a24e0f02d25b3420b313a5bd73d465a74c532680ffc8ec1a5d4cade29c6de6a299df251c4ca8fc3764c24eb129dc61ec
+EBUILD agate-1.6.3.ebuild 1375 BLAKE2B c6409f7f677ea26fa8dc305aa6b7664db636cc26a974ea760d2ea701008a9c8684e408c339ad317a5722e424b7bf48195bfa729a943e70c7176cf7f79b2850b7 SHA512 671f40e651ade42d04571c413df6beefbe7748162fd889b66ec99a41dd7b7699008b0e05735489dc6ce3c818af754da5f78d6dd552ddaff84b31316e86ece01a
MISC metadata.xml 485 BLAKE2B 32cfa1d6bc9582bfe411d79e541837d48019eb8a3bcb956634f3a72f5c41ec30568cab69348e5c7419210b77263a93dd042bb88a1376706888a0e13b2553f456 SHA512 30edf8ea75b16bd491372ca7d72b953fb9d3d27c88b10829b7d90108e952fb3a8489541958621a34d288d9dfb5378063fe6973a15d71700bc1745d20093f7b87
diff --git a/dev-python/agate/agate-1.6.3.ebuild b/dev-python/agate/agate-1.6.3.ebuild
new file mode 100644
index 000000000000..52a588ad921a
--- /dev/null
+++ b/dev-python/agate/agate-1.6.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="https://github.com/wireservice/agate https://pypi.org/project/agate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+xml"
+
+# Other packages have BDEPEND="test? ( dev-python/agate[xml] )"
+LEATHER_VERSION_DEP=">=dev-python/leather-0.3.3-r2"
+TEST_AGAINST_RDEPEND="xml? ( ${LEATHER_VERSION_DEP}[xml,${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ ${LEATHER_VERSION_DEP}[${PYTHON_USEDEP}]
+
+ ${TEST_AGAINST_RDEPEND}
+"
+BDEPEND="test? ( ${LEATHER_VERSION_DEP}[xml,${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+ )
+ epytest ${deselect[@]/#/--deselect }
+}