summaryrefslogtreecommitdiff
path: root/dev-python/aesara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 08:44:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 08:44:00 +0100
commit1e8bc3b2037289b8577740cea9321c37c52a49a2 (patch)
treeeb73b737abc04c27ce7e878f621e1a49deb09857 /dev-python/aesara
parentc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (diff)
gentoo auto-resync : 26:10:2023 - 08:43:59
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest2
-rw-r--r--dev-python/aesara/aesara-2.9.3.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index ea73ec9ece46..c2e71c9875e2 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,5 +1,7 @@
AUX aesara-2.6.5-compiledir-tid.patch 1707 BLAKE2B 77f8fa3618f930dddad8e864dee3e73fc0b965018d508be5877d5bcae4430024c4e4f90e905ac912da22a4d4934d6fc71acf4ebd49b7e8efb12c90dfaa072ed2 SHA512 9b6bbd8bc56f61c89dfd85cb18251ff8d73d717d91178efa9309e6b897dbda28937dea84f1d7d1a917c285219d51c0adcee1233112f2dcdb9f8c7b714a6c6c12
AUX aesara-2.8.10-fix-tuple.patch 649 BLAKE2B bfc2b2971fdaa452c5d14d75f68af5931b979dcb2951baf8bb1cf759058b4c0f341233b33d907722302ea8374cbd965e4d09e87f069ee2b1a558bf4e9a7309c9 SHA512 2c5846c723f214a8f623593f518194edb113f0d7c64ab1d69d6e4c5278125910f1c775cffdb46871d23ddf5332bbd84f252ed58e2560663c0c36520f1fb72372
DIST aesara-2.9.2.tar.gz 4424417 BLAKE2B d5e40ecdba51d32ee160efe287d11ee96cf00fbea2882a5bfbba08099edf12e449f56eb3af636cb50b675d6aacc4270ee57c30d3c6848abd9a925285a91df7ae SHA512 91cf78fe4ee107895f91365adce6b4446c0a6908e36ebba407a9ad896af9dd38d035c0cd08515ca7789a052ad1c1f34930b46e8196768ebbcf27e8f37c1053a3
+DIST aesara-2.9.3.tar.gz 4424476 BLAKE2B 3b1a1f2644267171a04a73d09a20fa29e0cf1eae3a86f5ee9ab72084185080b94cd1855fe8957b5f08aac4d059b047839524218526df37ea711bc3a8871c7e98 SHA512 28a6aedc7e6095a9a4e96eeac453282a0d6e247bd01248c219a5c161bc52ce4ccfb998238b45120b92581d1d0168c87c472aa0a8bb3314d8eb7ce90868e045b5
EBUILD aesara-2.9.2.ebuild 3386 BLAKE2B eaccb85889d3c7fcf5e0ecbfc333bef692bc556af0735f83ea833811e372ba5d80f42aa975cc72c999f648d39066acf8a14296805132ae355636f21d3348dbdb SHA512 3ceeef6003edc79603971a1efca5d55968829f33f8493de6ac2a45bcd0abdcbe27da78a1581826745f9e9a4124501fe908a5fbbe91a9037cffc089c161e2c30f
+EBUILD aesara-2.9.3.ebuild 3388 BLAKE2B 3fc4868d49508494221d4bddda5f587601784b1e30a0e002a8cbc395c3a991d5d905941f87ebaf57b40de9bd7d61e22cd7b5678fa85ddc43177dad23609cbcca SHA512 2d5becc8413e8cbbb7a29dd0914211aa26f6d1eaff1161e1f73e0495eea8e0b119abe68a50f7d1f873bb54bff884ad415d2ebc660a96f54ea30c29f6b8ae119d
MISC metadata.xml 506 BLAKE2B be65b6be62282fa47152985d79892fd04105a47e00a427ee8341d27aeff21b144bee7e7d0f16b2f4b617c941bdf5ebd9de37a42c39d117cdfd579c3035d35a74 SHA512 a207ec3db85a8e6f03feabd14da588f0b9ca9a88ab2495ade0f40b516b3bbd20fe78b14698d28da7ceed238737a9f4d63f587156ef609e846b485132d598c6bb
diff --git a/dev-python/aesara/aesara-2.9.3.ebuild b/dev-python/aesara/aesara-2.9.3.ebuild
new file mode 100644
index 000000000000..48e4fe94d96f
--- /dev/null
+++ b/dev-python/aesara/aesara-2.9.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing optfeature pypi
+
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="
+ https://github.com/aesara-devs/aesara/
+ https://pypi.org/project/aesara/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/minikanren[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
+ "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not claim "bin" package (sic!)
+ rm bin/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+
+ # Deprecation warning causes unexpected additional output
+ tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
+
+ # dunno
+ tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
+ tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
+
+ # TODO
+ tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
+ tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
+ tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
+
+ # TODO: Package pytest-benchmark
+ tests/scan/test_basic.py::TestExamples::test_reordering
+ tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
+ tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
+ tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
+ tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
+ tests/scan/test_basic.py::test_cython_performance
+
+ # new numpy?
+ tests/tensor/nnet/test_blocksparse.py::TestBlockSparseGemvAndOuter
+ )
+ local EPYTEST_IGNORE=(
+ # we do not package jax or numba
+ tests/link/jax
+ tests/link/numba
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x AESARA_FLAGS="cxx=${CXX}"
+ AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
+ AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
+
+ epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
+ # clean up the compiledir, as it can grow pretty large
+ rm -r "${HOME}"/.aesara || die
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}