summaryrefslogtreecommitdiff
path: root/dev-python/adblock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 15:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 15:22:56 +0100
commit564f8bfdb74759f8e95ec50a16419425e8ba8f25 (patch)
tree2738b2fbae70ae5b251665eb6da25467f5db050d /dev-python/adblock
parent9b81b8a93760fc1c7d79561adbd7a62c82f334db (diff)
gentoo auto-resync : 06:08:2023 - 15:22:56
Diffstat (limited to 'dev-python/adblock')
-rw-r--r--dev-python/adblock/Manifest2
-rw-r--r--dev-python/adblock/adblock-0.6.0.ebuild33
2 files changed, 20 insertions, 15 deletions
diff --git a/dev-python/adblock/Manifest b/dev-python/adblock/Manifest
index ea0298217118..e848ade3dd46 100644
--- a/dev-python/adblock/Manifest
+++ b/dev-python/adblock/Manifest
@@ -64,5 +64,5 @@ DIST windows_i686_gnu-0.36.1.crate 818115 BLAKE2B fdb78cf88e1049d1ed6c474f870dfd
DIST windows_i686_msvc-0.36.1.crate 724575 BLAKE2B cf964bec007d8432e2009644cf7f89ea7d910ccf9512c067b7bf5c6c825208ce4a36e9864c0cbca137f523983eb46e58e4bd01054cecd7ac7126d2ba9f67ac0c SHA512 02bb1507981229422498ce29f6c777d5e412358040128f84b09d948ccddf0461b078a0a20cc7f6ab7da8595121bb369453ae9ea1f0506aab715662e8c631e737
DIST windows_x86_64_gnu-0.36.1.crate 790934 BLAKE2B 9dec5d966bdc89efbc81989acca242d519f51676ec37487df2bfacd6bfbc5a8de2871be72c5b96a073a899c666e3a39aa60d493e7df39fa90efe869fb744a332 SHA512 598b69e4f2cd3d68f910d526a66dadb465ff30a8c261c9a4455aa1c5b952d23c04f8edaa063cd16fb43564c116a13f06d607f3a0a9c7495054b8bfe1c04d1865
DIST windows_x86_64_msvc-0.36.1.crate 661999 BLAKE2B 4cf967f10d4ce148bac967598168752d1996b4ddf5278a8fca53360566c37c1a014bfb4dfdc0ae2d96e01196c42eb4906ea80d8e9dd23b9e9f3163631c9e253e SHA512 89c22ed51a74f531662d80ae0fa5e0215728db1e6caf3c13eaeba95a93548b43c00b8474f52553ac866ac83c203b6c22dc44fbc870e882a4c9c97ba54b87c631
-EBUILD adblock-0.6.0.ebuild 2368 BLAKE2B 9b7770ec0cb9be336f10ec23ff68a2f05f39e2bc43025d1db8877c03cc68f6c50d01d5900b71bb6730a00821150f618dffecb2c917457368d730bf85f3cf945b SHA512 6f8a9b92ff3dc93df19309922ce2d035f8f9e87f95ab1b3f8a01bd8e2b61b99ba5678aa4f6fcf84b5c4e0c1f7a35e349e130cc1a7103bcd72d5d15434365336e
+EBUILD adblock-0.6.0.ebuild 2453 BLAKE2B db1cda4a5f7fe035432c45c752328da448ecb484389c87ba46ead7062d511ce2d8ff80eccb9157168b2bb2ebe64b9c560592dde5a54d629ae2850a3c64fc08fa SHA512 86b6823295c2910b70ab3942506941a30eed753d3e653089612414f84f367aa63cce44acfa1044a16431cfdf1830ee42f463b5628da53c774f31421479c9226d
MISC metadata.xml 488 BLAKE2B 8c58b29bbc160b2139fc54058c48da79ae48963e2cfbf97b6eb6c78678b6c57d7ff63c32d65dd082b3ceaffc383c0b03b27467e331738b086bfd6c5ee45c6cc0 SHA512 1a5fb02550400b8a25118982cd9b3651b2ac236208b8f933438786ca18cd8dabc17fe98a447379a0067004f8429439e1af9567e7e04c6ed13100bbe6c6321b04
diff --git a/dev-python/adblock/adblock-0.6.0.ebuild b/dev-python/adblock/adblock-0.6.0.ebuild
index b25860323125..720f90e60bfc 100644
--- a/dev-python/adblock/adblock-0.6.0.ebuild
+++ b/dev-python/adblock/adblock-0.6.0.ebuild
@@ -67,7 +67,8 @@ CRATES="
windows_i686_gnu@0.36.1
windows_i686_msvc@0.36.1
windows_x86_64_gnu@0.36.1
- windows_x86_64_msvc@0.36.1"
+ windows_x86_64_msvc@0.36.1
+"
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=maturin
PYTHON_COMPAT=( python3_{10..12} )
@@ -78,13 +79,15 @@ HOMEPAGE="https://github.com/ArniDagur/python-adblock"
SRC_URI="
https://github.com/ArniDagur/python-adblock/archive/refs/tags/${PV}.tar.gz
-> ${P}.gh.tar.gz
- ${CARGO_CRATE_URIS}"
+ ${CARGO_CRATE_URIS}
+"
S="${WORKDIR}/python-${P}"
LICENSE="|| ( MIT Apache-2.0 )"
LICENSE+="
Apache-2.0 Apache-2.0-with-LLVM-exceptions MIT MPL-2.0
- Unicode-DFS-2016" # crates
+ Unicode-DFS-2016
+" # crates
SLOT="0"
KEYWORDS="amd64 ~arm64 ~x86"
@@ -98,16 +101,18 @@ PATCHES=(
"${FILESDIR}"/${P}-maturin-0.14.13.patch
)
-EPYTEST_IGNORE=(
- # not very meaningful here (e.g. validates changelog),
- # and needs the deprecated dev-python/toml
- tests/test_metadata.py
-)
-
-src_compile() {
- distutils-r1_src_compile
+python_test() {
+ local EPYTEST_DESELECT=(
+ # unimportant (for us) test that uses the dir that we delete below
+ # so pytest does not try to load it while lacking extensions
+ tests/test_typestubs.py::test_functions_and_methods_exist_in_rust
+ )
+ local EPYTEST_IGNORE=(
+ # not very meaningful here (e.g. validates changelog),
+ # and needs the deprecated dev-python/toml
+ tests/test_metadata.py
+ )
- # prevent pytest from using ./adblock that lack the built module
- # but the keep directory given tests check ./adblock/adblock.pyi
- rm adblock/__init__.py || die
+ rm -rf adblock || die
+ epytest
}