summaryrefslogtreecommitdiff
path: root/dev-python/absl-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-19 20:37:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-19 20:37:19 +0100
commit343082998723d09c7b354eb21ff4793c6d4fda3e (patch)
tree1ac116f7e87117a78651da3a40230efefd5bf847 /dev-python/absl-py
parentb1f2cdf56e5eea363adc4c1ea1bd418f65733a7a (diff)
gentoo auto-resync : 19:08:2022 - 20:37:18
Diffstat (limited to 'dev-python/absl-py')
-rw-r--r--dev-python/absl-py/Manifest4
-rw-r--r--dev-python/absl-py/absl-py-1.1.0.ebuild79
-rw-r--r--dev-python/absl-py/absl-py-1.2.0.ebuild2
3 files changed, 2 insertions, 83 deletions
diff --git a/dev-python/absl-py/Manifest b/dev-python/absl-py/Manifest
index ba6735863a2c..9911092710e0 100644
--- a/dev-python/absl-py/Manifest
+++ b/dev-python/absl-py/Manifest
@@ -1,5 +1,3 @@
-DIST abseil-py-1.1.0.gh.tar.gz 219274 BLAKE2B 96848e3a738c295b3396b2eb45a6a2428f02ca7d325f24629d7ef8b87bdb19c8c2a33c95dcd716e286034f24d669bea27dc5470b92fcb3df437266e98a08ae6c SHA512 75e017399d28e38a5229b95b6372ad05b9d6067c3fef1cf7a64b5123399377025654dafaf6a1debc5664440efa8d26b76610629ad440e472faefd4f99b3bc685
DIST abseil-py-1.2.0.gh.tar.gz 219456 BLAKE2B ec7d878692dcf0cbe879cd7df51bc1b8ceeae945b053419b4a024a637e726064128af69fe077a26413f8562dd4a35830b340d000a6c9d520c7674b81a7e417ae SHA512 f363814ed65a68ae4bfd833dc095491349349e70327c0a87ad68ddc3b8429dacc78aaa16d2ff0d733487a12a2ab09094d4ccd1c1133981f65c12d3715cee410d
-EBUILD absl-py-1.1.0.ebuild 2536 BLAKE2B 3fd768fb4b4f8433319cb2d267b45e5da25f09f364aaa0294a71375611fc369d8ea41b0ff30d7c3f40526c54d65480fd298c0faf6184371501ec5537b1b3d1e0 SHA512 90de813f8ad07d3e52f97154d2711320a70f3475d74d0826b39b9f4a3070ca4a994e30af89d8cf65878c97594dac7d1ce3b7d47fa573c52b26e0e5e967d0cb4e
-EBUILD absl-py-1.2.0.ebuild 2538 BLAKE2B 07e79c2e65e728df1c81972b505975127d9086fe5f9cf7ea5a2283a71d7149d70470d714704f5f8c9f2fd95fff42a668c545e80d3113d9274e48ef4dc3bcbe93 SHA512 141ed49a0170e908159684339c22fa7a439e248fd5c87fc9a1172e16a5cce4ba61aeab38262adb5c21820b822af15497fd1587b84d9e51bab3957d22c98974d7
+EBUILD absl-py-1.2.0.ebuild 2536 BLAKE2B ff9ab15c76803b9e8d3cb9430ef9cc997a53ece91f5c7d5450539c3f5dd944a4dcb74912366b97d9ba7c58ac5254f85af877cd4f2c82835af2d01ed2fc72068f SHA512 123344240820b4130be23f8097a89dbb80952ad003c39d7c7c58e05abac2300d7ee7f55002a6396c7fe20f6fab3acada974af4b41addd82d8cf21689b600cd15
MISC metadata.xml 577 BLAKE2B dd0e02b24bdb42f24bd675cadf13e99f861a6dc9be2879f671b9bc4e9e078ef81759909e81e3063cb54c71ff71d6609624f0cf2645bf6ec055c643fbb0f3ab5c SHA512 7cfa86cac5d38b10aedacdb4bafc7acbd11cf4a98a873a2435ef5761d5186c5128171eb286b2d2568a1a353eb4de815303eae225cf5823a5292ac362633b67c7
diff --git a/dev-python/absl-py/absl-py-1.1.0.ebuild b/dev-python/absl-py/absl-py-1.1.0.ebuild
deleted file mode 100644
index 815933daf1d7..000000000000
--- a/dev-python/absl-py/absl-py-1.1.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_P=abseil-py-${PV}
-DESCRIPTION="Abseil Python Common Libraries"
-HOMEPAGE="
- https://github.com/abseil/abseil-py/
- https://pypi.org/project/absl-py/
-"
-SRC_URI="
- https://github.com/abseil/abseil-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- # what a nightmare... well, we could have called bazel but that would
- # even worse
- local helpers=(
- absl/flags/tests/argparse_flags_test_helper.py:absl/flags/tests/argparse_flags_test_helper
- absl/logging/tests/logging_functional_test_helper.py:absl/logging/tests/logging_functional_test_helper
- absl/testing/tests/absltest_fail_fast_test_helper.py:absl/testing/tests/absltest_fail_fast_test_helper
- absl/testing/tests/absltest_filtering_test_helper.py:absl/testing/tests/absltest_filtering_test_helper
- absl/testing/tests/absltest_randomization_testcase.py:absl/testing/tests/absltest_randomization_testcase
- absl/testing/tests/absltest_sharding_test_helper.py:absl/testing/tests/absltest_sharding_test_helper
- absl/testing/tests/absltest_test_helper.py:absl/testing/tests/absltest_test_helper
- absl/testing/tests/xml_reporter_helper_test.py:absl/testing/tests/xml_reporter_helper_test
- absl/tests/app_test_helper.py:absl/tests/app_test_helper_pure_python
- )
-
- local x
- for x in "${helpers[@]}"; do
- local script=${x%:*}
- local sym=${x#*:}
- sed -i -e "1i#!/usr/bin/env python" "${script}" || die
- chmod +x "${script}" || die
- ln -s "${script##*/}" "${sym}" || die
- done
-
- # i don't wanna know how these pass for upstream with wrong helper names
- sed -i -e 's:\(app_test_helper\)\.py:\1_pure_python:' \
- absl/tests/app_test.py || die
- sed -i -e 's:\(logging_functional_test_helper\)\.py:\1:' \
- absl/logging/tests/logging_functional_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTHONPATH=.
- local fails=0
- while read -r -d '' x; do
- ebegin "${x}"
- "${EPYTHON}" "${x}"
- eend ${?} || : "$(( fails += 1 ))"
- done < <(find -name '*_test.py' -print0)
-
- [[ ${fails} -ne 0 ]] && die "${fails} tests failed on ${EPYTHON}"
-
- # we actually need to clean this up manually before running the test
- # suite again...
- chmod -R u+rwX "${T}"/absl_testing || die
- rm -rf "${T}"/absl_testing || die
-}
diff --git a/dev-python/absl-py/absl-py-1.2.0.ebuild b/dev-python/absl-py/absl-py-1.2.0.ebuild
index fb3119e6e3ba..a3f82b27933d 100644
--- a/dev-python/absl-py/absl-py-1.2.0.ebuild
+++ b/dev-python/absl-py/absl-py-1.2.0.ebuild
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]