summaryrefslogtreecommitdiff
path: root/dev-python/a2wsgi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-23 04:04:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-23 04:04:37 +0100
commitfd93fe10d9e6c855fed8e1524b2d2d64d2085570 (patch)
treeef70885add7d9276bc4f5e8b56c784bc974b3e0b /dev-python/a2wsgi
parenta15e8dc7444560123d7d4be1bccb19afd5b611d0 (diff)
gentoo auto-resync : 23:10:2024 - 04:04:36
Diffstat (limited to 'dev-python/a2wsgi')
-rw-r--r--dev-python/a2wsgi/Manifest1
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.7-r1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index b716d1b5026a..337cd10fb9d3 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1,3 +1,4 @@
DIST a2wsgi-1.10.7.tar.gz 18669 BLAKE2B a29f294cd3d31ad3859d190a2e187bbb0b667fe6d29068793163aa0cf6429ff03fc408613c772c5efcbb1c961820664304c118f1036e4c9c567fc3e06ce55214 SHA512 49075f6cac08f1a5ae3e4ac1d1510a33394912e7e973771b8db2643792e7d875daa1db9e87a69062697cd3001533ddb7e13388edf4d963cd23f5bb84db141095
+EBUILD a2wsgi-1.10.7-r1.ebuild 1073 BLAKE2B 19a1819b1315fcdc973d1ca91bc30626a7c467d6e4c0eae79658faf6011abbdf0418aec32860568795ce76aec408bb9ef807b6cd7548b1c40098366600316640 SHA512 1209e0a6a22dcb5272648636d883c52e29d14b3039e30ebdd0a8a0ee177b1a2bc69ca374e0ae0cbb34b4731b84933a4327d6acf5be65ea3f3b5e30825664e2d1
EBUILD a2wsgi-1.10.7.ebuild 1171 BLAKE2B 695915b6d46f8d3364cdf4afbdb93afa479c35c0518ee74f64034d88994fe5b056fc97a46516c2a8fb96bfd9f3d0bc1894436b562e65031f4e102a3fa359204c SHA512 aed63553342757c59b3fd2f3ef5d88297f7e36b75b9292b6d4827f5a8a04d6665bc18d43fe4bda3d66c00300281180376210a6aba8791bdaa2dcb46e102945e5
MISC metadata.xml 392 BLAKE2B 17f9cfa46eeac0752f6e27d004a04173528f5033dee30ba31bb9b0d86231b3311937e0765cba3cae0fcc8b9653654c9b53bbc009f15140db0b38496856b9c27e SHA512 828436206a1e9b01df9da1546ffc8e6bc614e71708ad8a806dda9ab2dad80c86e539c37496a0c2525f0370e9ead3131bbde69f235da83331cd5097985981006e
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.7-r1.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.7-r1.ebuild
new file mode 100644
index 000000000000..aadf61bc4776
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.7-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/starlette[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires baize
+ tests/test_asgi.py::test_baize_stream_response
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}