summaryrefslogtreecommitdiff
path: root/dev-python/a2wsgi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
commitd69399c7befdd98cda62d6a1788ae2aa7f104c5e (patch)
treeeac7184f4cfe7d67580c1d0a0d9942a91e6cb4ee /dev-python/a2wsgi
parente4d9d6796d5018e338f0b27a3bc97716195bf0b8 (diff)
gentoo auto-resync : 07:01:2025 - 06:41:06
Diffstat (limited to 'dev-python/a2wsgi')
-rw-r--r--dev-python/a2wsgi/Manifest2
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.8.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index 87217fe1d638..c35772aa0c04 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1,3 +1,5 @@
DIST a2wsgi-1.10.7.tar.gz 18669 BLAKE2B a29f294cd3d31ad3859d190a2e187bbb0b667fe6d29068793163aa0cf6429ff03fc408613c772c5efcbb1c961820664304c118f1036e4c9c567fc3e06ce55214 SHA512 49075f6cac08f1a5ae3e4ac1d1510a33394912e7e973771b8db2643792e7d875daa1db9e87a69062697cd3001533ddb7e13388edf4d963cd23f5bb84db141095
+DIST a2wsgi-1.10.8.tar.gz 18729 BLAKE2B d36614cdf66680240c49f142208d9cbad660117bfd160f37606bf67ecc7dd7178f63bf7685669b1207bcfb417568807449b49e8ef85d3b8642da0c199211686a SHA512 b8ed1d1370af6ba13339fa408e4da575cbb3229346a67a8c270207038b739daee341d1755c5db0e7b690f4a8654f54113e0c6f9a99ff359634c663e6df86e0ae
EBUILD a2wsgi-1.10.7-r1.ebuild 1078 BLAKE2B d5a4c146c88b5038bb08634bcd39bf1d66685d632427c639c52f232c5b89b47c020a599483821bb17dcb231b95abc7b768f75ccae50469b6314cd98190573a49 SHA512 ecd97a0acad13a9c49e3c64f8c5b77cddb680dfa835ed54a36331d03474b34381469684d11d3dbc0a9f64f957a102c20da004fd65d6c6b3d65ee94010f45aad2
+EBUILD a2wsgi-1.10.8.ebuild 997 BLAKE2B ee1092af6a339db6a7ea835b5861204ab010e9a6c26549c0fc2a62de488fc14f7a8efaaa0eb64703eb319d9d906db0d83cee12086257322382e6741e83b1290e SHA512 a84cd6cb200b991dabd0654aa0b2bcf249fe4766a5979de1b778d9a8d689c77e6b992d5fb8e6ba9f7f20951deea4935f0c8681ed4d25341264905d397816b9bb
MISC metadata.xml 392 BLAKE2B 17f9cfa46eeac0752f6e27d004a04173528f5033dee30ba31bb9b0d86231b3311937e0765cba3cae0fcc8b9653654c9b53bbc009f15140db0b38496856b9c27e SHA512 828436206a1e9b01df9da1546ffc8e6bc614e71708ad8a806dda9ab2dad80c86e539c37496a0c2525f0370e9ead3131bbde69f235da83331cd5097985981006e
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.8.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.8.ebuild
new file mode 100644
index 000000000000..6fd945ac9a2e
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/starlette[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires baize
+ tests/test_asgi.py::test_baize_stream_response
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}