summaryrefslogtreecommitdiff
path: root/dev-python/Rx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/Rx
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/Rx')
-rw-r--r--dev-python/Rx/Manifest2
-rw-r--r--dev-python/Rx/Rx-3.1.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/Rx/Manifest b/dev-python/Rx/Manifest
index 26c5f45787d6..19e9923aacf3 100644
--- a/dev-python/Rx/Manifest
+++ b/dev-python/Rx/Manifest
@@ -1,3 +1,5 @@
DIST Rx-1.6.1.tar.gz 89543 BLAKE2B ee0b6c30c794febdd045231ff61a330a512c86a9dd3c56a6afa900c31ca774725d7bf5b589d46b60f79cd1f0bc967b5ab5bc87a58f6d3dbebbdb1b6618db875d SHA512 8602b5175c058e855ac4b67d8feed435f93632da2f4033fe0db54fcbb012a702786b29f97fe3fd641f054c3a61478dccac21c614b5708f7bfb0b986c9951e6a9
+DIST Rx-3.1.0.tar.gz 890293 BLAKE2B 268f6df5450d1235d50f9aee5cd43fe6e229acf7b2ddab5f1f97e80594aeff7beaa280fe272ac9cc8b80dc6874f4bb76e438e94c09712f2c37e72d8d40f9f283 SHA512 1d9f6639ef08dc991326b95fcbf0978adea55b35acab653fc16bd94ccf2ad3a1515e8cb4e8d2ff38d7a506306e310394339a8651a2a02fa22bfb7f17d86297f1
EBUILD Rx-1.6.1.ebuild 347 BLAKE2B 8e84f4c7daa13436e5c9ecb3deb22f41e37ba448f1c830836f931d08c0e7852c8a70e19ea56ae0baefe9188d0541eb3f69f072843e8956310c1639fac6d1cbbf SHA512 9355868035c59f3c253f3c580a357dcb08fab50778b17defa0aff712879be908eac6d2c2d50f801586aa2429ba23ee7cfbba95fbf920b89c491e1522b019f368
+EBUILD Rx-3.1.0.ebuild 605 BLAKE2B bfebdb964ca3a47f98a54bd5a4d9190c58e89631a423da327f974b5eea94450fab0e0c8bf87ee0ef05a9dfaa86496e9ebc60baabe0e2f1d27d3c68e120e75fe0 SHA512 34ae9fcdc055fa742ebe7157523bceb38a76ea155337639166da2fab4d5e49d52deca5acf85f3361d23e2a3457e4342b50d24423d1d8dc05ca359809749a77bb
MISC metadata.xml 327 BLAKE2B c9349fc7bf783920d0f8469ea19b8cf475c4705d3499364ab79a6960e19c3458b7d2a18aa90a470b033003fe461f06d34d25206b702c835e5a311d698d4c2e95 SHA512 382a7e9dd6cf734155229b3acc48060b4d11f2e68b2fe906ad8508ea5de95b1adcd5d23d58b6ff4881f7d5c9f103e64b60787eaebbeff2db8f9b24188dab6395
diff --git a/dev-python/Rx/Rx-3.1.0.ebuild b/dev-python/Rx/Rx-3.1.0.ebuild
new file mode 100644
index 000000000000..dca57f5969d9
--- /dev/null
+++ b/dev-python/Rx/Rx-3.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 python3_9 )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="https://github.com/ReactiveX/${MY_P}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}