summaryrefslogtreecommitdiff
path: root/dev-python/PythonQt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/PythonQt
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/PythonQt')
-rw-r--r--dev-python/PythonQt/Manifest5
-rw-r--r--dev-python/PythonQt/PythonQt-3.2-r1.ebuild96
-rw-r--r--dev-python/PythonQt/PythonQt-9999.ebuild46
-rw-r--r--dev-python/PythonQt/metadata.xml14
4 files changed, 133 insertions, 28 deletions
diff --git a/dev-python/PythonQt/Manifest b/dev-python/PythonQt/Manifest
index 6b842b2cd81e..914dd6acb0a8 100644
--- a/dev-python/PythonQt/Manifest
+++ b/dev-python/PythonQt/Manifest
@@ -1,4 +1,5 @@
DIST PythonQt3.2.zip 4539058 BLAKE2B c50b8333b71b6cbce6f372a0292a0ccfe791dc7eae5c660d4e6d1f5f2b3355644e3fd8cce9a514f0500e935f96c46976d0046ddd716465adb35d225e3c4cfeca SHA512 1ee0f50f5035568b38e945108f5496ba64355c6357c1ea8dfc17ad90fa360540769f94e0b3e0e398176e8a21c8afe139607f0b5a2e82c63f1cbd40201a25e0f0
+EBUILD PythonQt-3.2-r1.ebuild 2224 BLAKE2B 0b590d63fcb92ca4e548f28fbd37f275152b9c6c331c05de7953f74a5d71771992b808313eade75aa79c05b85c0dc60b92610aae046a82bc46d292c14756c9ab SHA512 9bb755b617465bab02aa08e93345c5f33bff4767a56d4ab377ef7302518e1b8adaeaf1ec5e2072db93e30781f386a694248f81c4dd7e9ce38c5122908e4ac113
EBUILD PythonQt-3.2.ebuild 1830 BLAKE2B 60fddae8406ff05b2133d6b7828ac1159203af906f4f10adf0ae7541ef21271be9874384e3b400f3d8973e8597833eeffd6d6f64f1067ccc51f1b4591f9150fc SHA512 6081de0ba1fc3f5584406133138e079644f741b3f43faa5ee61a2ac056ad6ef72936a1580bae0f4294659cb853a376d650d647c02b870da306615278086b34c7
-EBUILD PythonQt-9999.ebuild 1851 BLAKE2B ca5b5040a0948ebd8709eac0b520eed10458c35e9d40b8e7cbf376eb099dba42d6a94a710d0308ce5a74540700e6ef7b5c5a027132e3ce3092c216aa2cd3c9f8 SHA512 5a27f443daa1e773aac1a2805c35369b9fe8a27b956a31da449daa67a2ed876b22bf8fe458ba0e79f85e063f0fef98bf050e21667fb85d97d4351d1e9c090f2c
-MISC metadata.xml 971 BLAKE2B 4a9f0fd3832f83eb46ef65a18774c998daeb9544b1ac6a23a189b909c7e4168031a68d56952d9ed2b7b76fb8fc3a912e77d162cb94e73405f285bd834644fb98 SHA512 565d8517faba162fa855acef4dc659af22954796a25da9479d7ec530afee16606904b6bfba9a568e6caa8c47f3195401eefc3a9048077e73582cf7357cafce5e
+EBUILD PythonQt-9999.ebuild 2194 BLAKE2B 7f941f9c401c4a5df689ea5e3145d64ecae92a46df48f5a9332e5e2eea5613360924fd96ad9ab7cbda4aa490f0a51cdb8804de23a6be16531802c485d1b121b4 SHA512 79fb1ca958f29ad8ec9a43d8fa14e50291cc7a153a585e9b95e88f4baa689bfb88ee4d17313d3b23e70402f54b2d77e330e97621caa8bafe2bd7483784aac2e3
+MISC metadata.xml 921 BLAKE2B a9b1a1daef268107c78f143e9ffeaace6c6305575eaf5fe4894cdaaa2fd0f6551d16a3ae8a0e70fc5b19ca1817e71ab56ec2134259703e28df9d1b6e0f004f30 SHA512 237e70d7b8535adbbcf1a2e5f44e1b6053ef930ec2122ee56ae2e9f702d741e5630862d2143562e8a8562e0f9af38f4fac47981d9be79b689f3b515c63a634ac
diff --git a/dev-python/PythonQt/PythonQt-3.2-r1.ebuild b/dev-python/PythonQt/PythonQt-3.2-r1.ebuild
new file mode 100644
index 000000000000..39deaa6db272
--- /dev/null
+++ b/dev-python/PythonQt/PythonQt-3.2-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+MY_P=${PN}${PV}
+
+inherit qmake-utils python-single-r1 virtualx
+
+DESCRIPTION="A dynamic Python binding for the Qt framework"
+HOMEPAGE="https://mevislab.github.io/pythonqt"
+SRC_URI="mirror://sourceforge/pythonqt/pythonqt/${P}/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples +extensions test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ extensions? (
+ dev-qt/designer:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtxml:5
+ dev-qt/qtxmlpatterns:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/qtxml:5
+ test? ( dev-qt/qttest:5 )"
+BDEPEND="app-arch/unzip
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ if ! use examples ; then
+ sed -i '/SUBDIRS/s/examples//' PythonQt.pro || die "sed for examples"
+ fi
+ if ! use extensions ; then
+ sed -i '/SUBDIRS/s/extensions//' PythonQt.pro || die "sed for extensions"
+ fi
+ if ! use test ; then
+ sed -i '/SUBDIRS/s/tests//' PythonQt.pro || die "sed for test"
+ fi
+
+ # Remove webkit support
+ sed -i '/qtHaveModule(webkit):CONFIG += PythonQtWebKit/d' \
+ extensions/PythonQt_QtAll/PythonQt_QtAll.pro \
+ || die "sed for webkit"
+
+ # Unset python version to use python-config
+ sed -i "/unix:PYTHON_VERSION=/s/2.7//" build/python.prf \
+ || die "sed for python version"
+}
+
+src_configure() {
+ eqmake5 CONFIG+="$(usex debug debug release '' '')" PREFIX="${ED}"/usr
+}
+
+src_test() {
+ LD_PRELOAD="${S}"/lib/libPythonQt-Qt5-Python"$(usex debug _d '' '' '')".so.3 \
+ virtx ./lib/PythonQtTest"$(usex debug _d '' '' '')"
+}
+
+src_install() {
+ einstalldocs
+
+ # Includes
+ insinto /usr/include/PythonQt
+ doins -r src/*.h
+ insinto /usr/include/PythonQt/gui
+ doins -r src/gui/*.h
+
+ if use extensions ; then
+ insinto /usr/include/PythonQt/extensions/PythonQt_QtAll
+ doins -r extensions/PythonQt_QtAll/*.h
+ fi
+
+ # Libraries
+ dolib.so lib/libPythonQt*
+}
diff --git a/dev-python/PythonQt/PythonQt-9999.ebuild b/dev-python/PythonQt/PythonQt-9999.ebuild
index e142455bfc08..01939249e831 100644
--- a/dev-python/PythonQt/PythonQt-9999.ebuild
+++ b/dev-python/PythonQt/PythonQt-9999.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
+EGIT_REPO_URI="https://github.com/MeVisLab/pythonqt.git"
-MY_P=${PN}${PV}
-
-inherit qmake-utils python-single-r1 subversion
+inherit git-r3 qmake-utils python-single-r1 virtualx
DESCRIPTION="A dynamic Python binding for the Qt framework"
-HOMEPAGE="http://pythonqt.sourceforge.net/"
+HOMEPAGE="https://mevislab.github.io/pythonqt"
SRC_URI=""
-ESVN_REPO_URI="https://pythonqt.svn.sourceforge.net/svnroot/pythonqt/trunk"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
-IUSE="doc +extensions webkit"
+IUSE="debug doc examples +extensions test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
dev-qt/qtcore:5
@@ -34,37 +35,44 @@ RDEPEND="${PYTHON_DEPS}
dev-qt/qtsvg:5
dev-qt/qtxml:5
dev-qt/qtxmlpatterns:5
- webkit? ( dev-qt/qtwebkit:5 )
)"
DEPEND="${RDEPEND}
dev-qt/qtxml:5
+ test? ( dev-qt/qttest:5 )"
+BDEPEND="app-arch/unzip
virtual/pkgconfig
doc? ( app-doc/doxygen )"
-S="${WORKDIR}/${MY_P}"
-
-REQUIRED_USE="webkit? ( extensions ) ${PYTHON_REQUIRED_USE}"
-
src_prepare() {
default
+ if ! use examples ; then
+ sed -i '/SUBDIRS/s/examples//' PythonQt.pro || die "sed for examples"
+ fi
if ! use extensions ; then
sed -i '/SUBDIRS/s/extensions//' PythonQt.pro || die "sed for extensions"
fi
- if ! use webkit ; then
- # Remove webkit support if not used
- sed -i '/qtHaveModule(webkit):CONFIG += PythonQtWebKit/d' \
- extensions/PythonQt_QtAll/PythonQt_QtAll.pro \
- || die "sed for webkit"
+ if ! use test ; then
+ sed -i '/SUBDIRS/s/tests//' PythonQt.pro || die "sed for test"
fi
+ # Remove webkit support if not used
+ sed -i '/qtHaveModule(webkit):CONFIG += PythonQtWebKit/d' \
+ extensions/PythonQt_QtAll/PythonQt_QtAll.pro \
+ || die "sed for webkit"
+
# Unset python version to use python-config
sed -i "/unix:PYTHON_VERSION=/s/2.7//" build/python.prf \
|| die "sed for python version"
}
src_configure() {
- eqmake5 PREFIX="${ED%/}"/usr
+ eqmake5 CONFIG+="$(usex debug debug release '' '')" PREFIX="${ED}"/usr
+}
+
+src_test() {
+ LD_PRELOAD="${S}"/lib/libPythonQt-Qt5-Python"$(usex debug _d '' '' '')".so.3 \
+ virtx ./lib/PythonQtTest"$(usex debug _d '' '' '')"
}
src_install() {
diff --git a/dev-python/PythonQt/metadata.xml b/dev-python/PythonQt/metadata.xml
index 1b4473ec0080..32c82921dccc 100644
--- a/dev-python/PythonQt/metadata.xml
+++ b/dev-python/PythonQt/metadata.xml
@@ -9,18 +9,18 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
- <longdescription>
-PythonQt is a dynamic Python binding for the Qt framework.
-It offers an easy way to embed the Python scripting language into your C++ Qt applications.
-The focus of PythonQt is on embedding Python into an existing C++ application,
-not on writing the whole application completely in Python.
+ <longdescription lang="en">
+ PythonQt is a dynamic Python binding for the Qt framework.
+ It offers an easy way to embed the Python scripting language into
+ your C++ Qt applications. The focus of PythonQt is on embedding Python
+ into an existing C++ application, not on writing the whole application
+ completely in Python.
</longdescription>
<use>
<flag name="extensions">Install extensions</flag>
</use>
<upstream>
- <changelog>https://sourceforge.net/p/pythonqt/news/</changelog>
- <doc>http://pythonqt.sourceforge.net/index.html</doc>
+ <remote-id type="github">MeVisLab/pythonqt</remote-id>
<remote-id type="sourceforge">pythonqt</remote-id>
</upstream>
</pkgmetadata>