summaryrefslogtreecommitdiff
path: root/dev-python/Pyro4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/Pyro4
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/Pyro4')
-rw-r--r--dev-python/Pyro4/Manifest5
-rw-r--r--dev-python/Pyro4/Pyro4-4.80.ebuild59
-rw-r--r--dev-python/Pyro4/Pyro4-4.81.ebuild55
-rw-r--r--dev-python/Pyro4/metadata.xml13
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-python/Pyro4/Manifest b/dev-python/Pyro4/Manifest
new file mode 100644
index 000000000000..9cf9adfec318
--- /dev/null
+++ b/dev-python/Pyro4/Manifest
@@ -0,0 +1,5 @@
+DIST Pyro4-4.80.tar.gz 515103 BLAKE2B 5d2b69ba020117947a36c9c75f884434a3452167fa2e586e3a5b0e6deb1d0c8c54dd06a20b9568b53a0a6c42a847d880636e3abe37090246d5f34ca84e915b36 SHA512 8e41285674edbe5c8d5ac63e33406c5ff7b6366d5dd251a1755eff81611193278a473ed8b15f995bc0ba2775dc5d316eb6a3cafd63626b95820591ea3a0a92e3
+DIST Pyro4-4.81.tar.gz 514678 BLAKE2B ffe9edcb947203b37cf1b13b2380f2b7d76357a5bca36e454fe67f6bd0d34574f5df429dd784ba2c2bc69c0188edd14e4572f12f5c137d87d2898f01ea3e855c SHA512 3848d473acd624ae1356ad3470c669eb0bc30287691ff8b9fc27fb0591ba305812c6be1946d6a2a91377e222a9e114f05ed18170d1b035dec24e436ab8dadc59
+EBUILD Pyro4-4.80.ebuild 1312 BLAKE2B 0dbb9d51095a1f921f23ee0baf4fe00661366f4a6de6c204053b43fa8fc38ecac25364809f175b3c619bb0e62b223e437c02d6d4bb70e4481f3b325986caf925 SHA512 1983aac0919d20cc10228324398f5073f81c08c30377b5cc9067330509c07702b1e01cf38e6a9d3e7adeb8b1ebf26060075bf15b4305e3183ccf683ab4c3d8ad
+EBUILD Pyro4-4.81.ebuild 1245 BLAKE2B ac655f8b73375c262ebf413aeebe199f4dc2829cab3e9c8889062fe839d026cba67b78894386be078c0529bd1b22a4c6869a5b1cfd47947981f90e8c74302445 SHA512 f8c68196e1e156fa122ba4a789d01d3a0dfffa70a1eee2a55e8d9af60275121dc6cd461e1c85328f4458754f0ae2ada55fdd85c7cd6ca680ba3e9ee789a7073a
+MISC metadata.xml 384 BLAKE2B e0dcf58b7db6287f6912e1ce549f52fb269eeac53def37ff75b8c30957c02eaef506a44bc15c3fdfdf01c2607e803b8706cc3be6b50585383f30edcd8c3cebf6 SHA512 9f4ed623a9e07d84fd61b3eccf65d80c883265b3de24d79b888c5d880498325dd268e4e5390f60ed67b19101e072276b1d7eb80724bf7a0cd6713fc20d374e33
diff --git a/dev-python/Pyro4/Pyro4-4.80.ebuild b/dev-python/Pyro4/Pyro4-4.80.ebuild
new file mode 100644
index 000000000000..58699ab81c52
--- /dev/null
+++ b/dev-python/Pyro4/Pyro4-4.80.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_PN="Pyro4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="https://pypi.org/project/Pyro4/
+ https://github.com/irmen/Pyro4"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
+ dev-python/dill[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Pyro4/Pyro4-4.81.ebuild b/dev-python/Pyro4/Pyro4-4.81.ebuild
new file mode 100644
index 000000000000..8027e01d7312
--- /dev/null
+++ b/dev-python/Pyro4/Pyro4-4.81.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="https://pypi.org/project/Pyro4/
+ https://github.com/irmen/Pyro4"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
+ dev-python/dill[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Pyro4/metadata.xml b/dev-python/Pyro4/metadata.xml
new file mode 100644
index 000000000000..30fa539c40df
--- /dev/null
+++ b/dev-python/Pyro4/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">irmen/Pyro4</remote-id>
+ <remote-id type="pypi">Pyro4</remote-id>
+ </upstream>
+</pkgmetadata>