summaryrefslogtreecommitdiff
path: root/dev-python/PySocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-python/PySocks
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-python/PySocks')
-rw-r--r--dev-python/PySocks/Manifest2
-rw-r--r--dev-python/PySocks/PySocks-1.6.8.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/PySocks/Manifest b/dev-python/PySocks/Manifest
index a47bd32c3e46..db92c6c151f1 100644
--- a/dev-python/PySocks/Manifest
+++ b/dev-python/PySocks/Manifest
@@ -1,3 +1,5 @@
DIST PySocks-1.6.7.tar.gz 282874 BLAKE2B 9e4ecf57f6cb9b7690ba68e21b3e52a535a08490b78ad5d8bd90384acf26f16e6a08018eaa7e91763b94182119217404b235425fce146af7e989c5e39e5e07dc SHA512 e49ce2f4ce23fd84ce30a62a5585af3c63980db46e7d427571d8fb8f6b85f4b6aeb37066863491496dd322555a5ce261123d613b8e5819dbdcef8a4e17e5dca0
+DIST PySocks-1.6.8.tar.gz 283450 BLAKE2B 72b52fcdb9f3dc3bd71ca75cdbaa159c0b35a81fd4ed9476ab043819dad3efac76615bc751fc6014e1358a13a3a735023bae7f502e2863b5e733982c16758db1 SHA512 9b544cf11464142a5f347cd5688b48422249363a425ccf3887117152f2f1969713674c4bba714242432ae85f3d62e03edeb9cb7b73ebd225ed3b47b3da6896d5
EBUILD PySocks-1.6.7.ebuild 595 BLAKE2B d1711b9c461adef19579c7a729656e652c7d415d4c847524637e765955c2f6878e78b5f9c937a191d61186f5813c1942f61a6dcc1e94968203fabd01ee72845b SHA512 a6ec0cdea0c35ade4a355317cf0caa47eaa41261360d64467c6708dde852b6ae6f1537e61aa5e45a7f4cfb0656371b71f086d8557fd17d02f4b42e788eaed646
+EBUILD PySocks-1.6.8.ebuild 878 BLAKE2B 15ab2de6a450c93b14b35f3b1365cf464041510aea040900a64e9156f15a23fb10da0c3559f3c9af0e62ae8862728fc556d945a58b5cf34f4053ff332e5ee9bd SHA512 9362647b4cbdaed5ced07aeb220ad0e1a0751f60a585910f8d04b0066c6bd5b0214326f12465d2ded6896ba2e98b7edae957806cfb809c35349aab3bfaec73c2
MISC metadata.xml 499 BLAKE2B 6eeb0c4905d8f0d6c2d276b36a74ac9e1aaf3f5066ba79ea3b821fa31440a46c4ba49f88be096850032cf8598f6abee09182d84a35345fa53e1001a05137dbe0 SHA512 ec9cc3e4f9a050f78cb0c073efd3698b47aee2ce14d438163b5037509a5d8076509b4954bec0afc7f1e05bc790f26a6a520bb671b1c8590db966456dcf53b9aa
diff --git a/dev-python/PySocks/PySocks-1.6.8.ebuild b/dev-python/PySocks/PySocks-1.6.8.ebuild
new file mode 100644
index 000000000000..1353c596278b
--- /dev/null
+++ b/dev-python/PySocks/PySocks-1.6.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Required module test-server isn't in the tree yet and once that's added
+# psutil will need keywords added as well since it's used too.
+RESTRICT=test
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}