summaryrefslogtreecommitdiff
path: root/dev-python/PySocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/PySocks
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/PySocks')
-rw-r--r--dev-python/PySocks/Manifest5
-rw-r--r--dev-python/PySocks/PySocks-1.6.7.ebuild19
-rw-r--r--dev-python/PySocks/PySocks-1.6.8.ebuild30
-rw-r--r--dev-python/PySocks/metadata.xml16
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/PySocks/Manifest b/dev-python/PySocks/Manifest
new file mode 100644
index 000000000000..417a0d567173
--- /dev/null
+++ b/dev-python/PySocks/Manifest
@@ -0,0 +1,5 @@
+DIST PySocks-1.6.7.tar.gz 282874 BLAKE2B 9e4ecf57f6cb9b7690ba68e21b3e52a535a08490b78ad5d8bd90384acf26f16e6a08018eaa7e91763b94182119217404b235425fce146af7e989c5e39e5e07dc SHA512 e49ce2f4ce23fd84ce30a62a5585af3c63980db46e7d427571d8fb8f6b85f4b6aeb37066863491496dd322555a5ce261123d613b8e5819dbdcef8a4e17e5dca0
+DIST PySocks-1.6.8.tar.gz 283450 BLAKE2B 72b52fcdb9f3dc3bd71ca75cdbaa159c0b35a81fd4ed9476ab043819dad3efac76615bc751fc6014e1358a13a3a735023bae7f502e2863b5e733982c16758db1 SHA512 9b544cf11464142a5f347cd5688b48422249363a425ccf3887117152f2f1969713674c4bba714242432ae85f3d62e03edeb9cb7b73ebd225ed3b47b3da6896d5
+EBUILD PySocks-1.6.7.ebuild 594 BLAKE2B 661b2dc419e6a329f8d05ef90fd455237dd523a02edbf808ce68bd65fb1be3793351b9e8ef46a4a81e6876ce923d9e5a06f1005e45938dcccff71cf270e955f1 SHA512 e401376bccc8ebf59c6736bd552ad95a6c1e6d21bb6316230432ed79b1cb2016689cad85f45ff83677a653b4bd33528ff21ef0b688da2aed6ec34b92515ee563
+EBUILD PySocks-1.6.8.ebuild 889 BLAKE2B 4304c14d6afa8b8e56a43e8837734073141207525d5b947405a7b6ef958aec5f33c656fe17d70ffee7d4f9b2c3a5f32a11a3cf266d5508e0175fde5f31d8fdd2 SHA512 309fc780fbedf51f2ab5a300ca7232b5bde9ecf59337769470ccaca3cae6354ca6d8972a181df83b1eb1a34f9c6822e1bc3b82a841066332527cdd17e48221e1
+MISC metadata.xml 499 BLAKE2B 6eeb0c4905d8f0d6c2d276b36a74ac9e1aaf3f5066ba79ea3b821fa31440a46c4ba49f88be096850032cf8598f6abee09182d84a35345fa53e1001a05137dbe0 SHA512 ec9cc3e4f9a050f78cb0c073efd3698b47aee2ce14d438163b5037509a5d8076509b4954bec0afc7f1e05bc790f26a6a520bb671b1c8590db966456dcf53b9aa
diff --git a/dev-python/PySocks/PySocks-1.6.7.ebuild b/dev-python/PySocks/PySocks-1.6.7.ebuild
new file mode 100644
index 000000000000..376e1aecacdd
--- /dev/null
+++ b/dev-python/PySocks/PySocks-1.6.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/PySocks/PySocks-1.6.8.ebuild b/dev-python/PySocks/PySocks-1.6.8.ebuild
new file mode 100644
index 000000000000..95d6ac757db0
--- /dev/null
+++ b/dev-python/PySocks/PySocks-1.6.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS client module"
+HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Required module test-server isn't in the tree yet and once that's added
+# psutil will need keywords added as well since it's used too.
+RESTRICT=test
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/PySocks/metadata.xml b/dev-python/PySocks/metadata.xml
new file mode 100644
index 000000000000..ecba000b419e
--- /dev/null
+++ b/dev-python/PySocks/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">PySocks</remote-id>
+ <maintainer status="unknown">
+ <email>anorov.vorona@gmail.com</email>
+ <name>Anorov</name>
+ </maintainer>
+ <remote-id type="github">Anorov/PySocks</remote-id>
+ </upstream>
+</pkgmetadata>