summaryrefslogtreecommitdiff
path: root/dev-python/PySensors/PySensors-0.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/PySensors/PySensors-0.0.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/PySensors/PySensors-0.0.3.ebuild')
-rw-r--r--dev-python/PySensors/PySensors-0.0.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/PySensors/PySensors-0.0.3.ebuild b/dev-python/PySensors/PySensors-0.0.3.ebuild
new file mode 100644
index 000000000000..a2de3813d903
--- /dev/null
+++ b/dev-python/PySensors/PySensors-0.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to libsensors (via ctypes)"
+HOMEPAGE="https://pypi.org/project/PySensors/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=sys-apps/lm_sensors-3"