summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-29 08:00:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-29 08:00:25 +0100
commitd855918b46ba8714cf1320fe63b55fd0ed1748a6 (patch)
tree4d7d0e86122a07796a660310d507f93e1b7747b9 /dev-python/PyQt6
parentb8325835c82367d22428eb41afa0f2d375338d3c (diff)
gentoo auto-resync : 29:06:2024 - 08:00:25
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/Manifest5
-rw-r--r--dev-python/PyQt6/PyQt6-6.6.1.ebuild182
-rw-r--r--dev-python/PyQt6/PyQt6-6.7.0.ebuild4
-rw-r--r--dev-python/PyQt6/files/PyQt6-6.6.1-qt670.patch77
4 files changed, 3 insertions, 265 deletions
diff --git a/dev-python/PyQt6/Manifest b/dev-python/PyQt6/Manifest
index aecc735ad603..317a5e5a0f53 100644
--- a/dev-python/PyQt6/Manifest
+++ b/dev-python/PyQt6/Manifest
@@ -1,6 +1,3 @@
-AUX PyQt6-6.6.1-qt670.patch 2528 BLAKE2B 3157c4e4e063747db56e92b011147dfb3a57474b6e80f052372d4b83b91bf36bb18ba256f4e2b4466c140744b075ac47217915ad5d744900754c8f4af7ab8f61 SHA512 5894b371cfa9b22de2300cc75b7ab486944ecd7c8f2aed6bdd03355c9952ebd550ec2383ff057d629b54d91f92ef67cd566a39d7e38696d6ba2b09622b9900e8
-DIST PyQt6-6.6.1.tar.gz 1043203 BLAKE2B dd2b6988ebeabaae47fe57c5c0d17fbe4b62c377262b4bb360adb7fd6724ccb6a67ba5c2bd7498df98db3ce6b00978f936b11a43b464c3c7af169f25b30ee1a6 SHA512 c2ff8c47c9b0e43c009d0c90f565a54344e6f384c67dd30c2d422465d0702c07713acc0095c8b67827d1146675611c07d548ba282a26e41bb60a0a21977a7a64
DIST PyQt6-6.7.0.tar.gz 1050408 BLAKE2B 30dc8a2762cb5a149c401d497af714bb9209bc46847c0699522ee60080c46f0b1d4da854e70151a508c90820a2aa32da422bfd20c4320bcc9b5d5f92fd9e8677 SHA512 619210d2de3e149b55e2d45cbd8ec2113b3effcaccd25eef6067ea99b82e250f1ce288b38136604536053690071f8c843339b934b5ce5e539a5dfdecc26f44d2
-EBUILD PyQt6-6.6.1.ebuild 5589 BLAKE2B eabdfd5f38f4e6a6891d6cd6a231411e449c657a61243c62423cdc47112af400e8329b0e00ef3b502633e1680c867ed29ba6ae5e6e217d748af9b78c5deb8b15 SHA512 61fc05cea708f11a08ec1f0481143348bb05ba679fac2f7b278aa3e959d44aa1cd40f3f9949c9f1e7563559412b5c39db0c97abab061dfcf435c76441c363fc0
-EBUILD PyQt6-6.7.0.ebuild 5534 BLAKE2B f36c72a796e5b35a777145d33474ca01235823de956e47148d60c36358b880f7d13b66c66debf33f060d685f68ca09dc4fbfb21ef5d6a182f89390af0aa51cb5 SHA512 a6ee73c54cb4d8cfcb51d2645e59c57b69384c77f2a9e6ca3867ee91dfa359bca0588971d39d4a7a0b8aeef5930afc9397f126ce51733e240fe88ac9d504aa19
+EBUILD PyQt6-6.7.0.ebuild 5546 BLAKE2B 2ff201ce56e20b2880b7c6515d41edf0ca138259b64a0099472f2245fb7bdeddd0262a612205531b86a7bf019cd435014000b87aa353cffc1e8a62586bc250c4 SHA512 2de9ca22a344c9f5ded108fc540b8b382b63e21e16fa1b7c787a97456e69dcba69e9d91c22e612539ea85f1620bb6b7154148c1d2fbd672d77595024a09ef66c
MISC metadata.xml 2391 BLAKE2B 16eecbd105ced07699632a4b294f7da74b59ff931e39afb8a21f67f073bfc90ff613d753a67bcd303ea9f2bf35d7b91c1c7a56ece044c421c4e45b5951f5efe3 SHA512 1d595e07e201891c8c7d5635d39db36ccb65c7333cb27c1cd5384a76029b987959df05795283a4474a41a997bf951e577570b7d3a52a9a2975d563767651efae
diff --git a/dev-python/PyQt6/PyQt6-6.6.1.ebuild b/dev-python/PyQt6/PyQt6-6.6.1.ebuild
deleted file mode 100644
index 804dd5543081..000000000000
--- a/dev-python/PyQt6/PyQt6-6.6.1.ebuild
+++ /dev/null
@@ -1,182 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=sip
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 flag-o-matic multiprocessing pypi qmake-utils
-
-# 'can' work with older Qt depending on features, but keeping it simple
-QT_PV=$(ver_cut 1-2):6
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-# defaults match what is provided with qtbase by default (except testlib),
-# reduces the need to set flags but does increase build time a fair amount
-IUSE="
- bluetooth +dbus debug designer examples gles2-only +gui help
- multimedia +network nfc opengl pdfium positioning +printsupport
- qml quick quick3d serialport sensors spatialaudio speech +sql
- +ssl svg testlib webchannel websockets +widgets +xml
-"
-# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
-REQUIRED_USE="
- designer? ( gui widgets )
- help? ( gui widgets )
- multimedia? ( gui network )
- opengl? ( gui )
- pdfium? ( gui )
- printsupport? ( gui widgets )
- qml? ( network )
- quick3d? ( gui qml )
- quick? ( gui qml )
- spatialaudio? ( multimedia )
- sql? ( widgets )
- svg? ( gui )
- testlib? ( gui widgets )
- webchannel? ( network )
- websockets? ( network )
- widgets? ( gui )
-"
-
-# may use qt private symbols wrt qtbase's :=
-DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
- bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- sys-apps/dbus
- )
- designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
- help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- nfc? ( >=dev-qt/qtconnectivity-${QT_PV}[nfc] )
- opengl? (
- gles2-only? ( media-libs/libglvnd )
- )
- pdfium? ( >=dev-qt/qtwebengine-${QT_PV}[pdfium,widgets?] )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
- quick? ( >=dev-qt/qtdeclarative-${QT_PV}[opengl] )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- speech? (
- >=dev-qt/qtdeclarative-${QT_PV}
- >=dev-qt/qtspeech-${QT_PV}
- )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/PyQt6-sip-13.6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
- >=dev-python/sip-6.7.12[${PYTHON_USEDEP}]
- >=dev-qt/qtbase-${QT_PV}
- dbus? ( virtual/pkgconfig )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.6.1-qt670.patch
-)
-
-src_prepare() {
- default
-
- # hack: PyQt-builder runs qmake without our arguments and calls g++
- # or clang++ depending on what qtbase was built with, not used for
- # building but fails with -native-symlinks
- mkdir "${T}"/cxx || die
- local cxx
- ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
- ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
- PATH=${T}/cxx:${PATH}
-}
-
-python_configure_all() {
- append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
- append-cxxflags ${CPPFLAGS} # respect CPPFLAGS notably for DISTUTILS_EXT=1
-
- pyqt_use_enable() {
- local state=$(usex ${1} --enable= --disable=)
- shift
- echo ${*/#/${state}}
- }
-
- DISTUTILS_ARGS=(
- --jobs="$(makeopts_jobs)"
- --qmake="$(qt6_get_bindir)"/qmake
- --qmake-setting="$(qt6_get_qmake_args)"
- --verbose
- --confirm-license
-
- --enable=QtCore
-
- $(pyqt_use_enable bluetooth QtBluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable designer QtDesigner)
- $(pyqt_use_enable help QtHelp)
- $(pyqt_use_enable gui QtGui)
- #--disable=QtLocation # force-disabled in project.py
- $(pyqt_use_enable multimedia QtMultimedia \
- $(usev widgets QtMultimediaWidgets))
- $(pyqt_use_enable network QtNetwork)
- $(pyqt_use_enable nfc QtNfc)
- $(pyqt_use_enable opengl QtOpenGL \
- $(usev widgets QtOpenGLWidgets))
- $(pyqt_use_enable pdfium QtPdf \
- $(usev widgets QtPdfWidgets))
- $(pyqt_use_enable positioning QtPositioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable qml QtQml)
- $(pyqt_use_enable quick QtQuick \
- $(usev widgets QtQuickWidgets))
- $(pyqt_use_enable quick3d QtQuick3D)
- --disable=QtRemoteObjects # not packaged
- $(pyqt_use_enable sensors QtSensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable spatialaudio QtSpatialAudio)
- $(pyqt_use_enable sql QtSql)
- $(pyqt_use_enable svg QtSvg \
- $(usev widgets QtSvgWidgets))
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable speech QtTextToSpeech)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets QtWidgets)
- $(pyqt_use_enable xml QtXml)
-
- $(usev debug '--debug --qml-debug --tracing')
-
- $(usev !dbus --no-dbus-python)
- # note: upstream currently intentionally skips installing these two
- # plugins when using wheels w/ pep517 so, *if* something does need
- # them, it will need to be handled manually
- $(usev !designer --no-designer-plugin)
- $(usev !qml --no-qml-plugin)
-
- $(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
- $(usev !opengl --disabled-feature=PyQt_OpenGL)
- $(usev !ssl --disabled-feature=PyQt_SSL)
-
- # intended for Windows / Android or others
- --disable=QAxContainer
- --disabled-feature=PyQt_Permissions
- )
-}
-
-python_install_all() {
- einstalldocs
- use examples && dodoc -r examples
-}
diff --git a/dev-python/PyQt6/PyQt6-6.7.0.ebuild b/dev-python/PyQt6/PyQt6-6.7.0.ebuild
index 955fbff73395..b1bb97810cd0 100644
--- a/dev-python/PyQt6/PyQt6-6.7.0.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.7.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=sip
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 flag-o-matic multiprocessing pypi qmake-utils
# 'can' work with older Qt depending on features, but keeping it simple
@@ -17,7 +17,7 @@ HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~arm64"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
# defaults match what is provided with qtbase by default (except testlib),
# reduces the need to set flags but does increase build time a fair amount
IUSE="
diff --git a/dev-python/PyQt6/files/PyQt6-6.6.1-qt670.patch b/dev-python/PyQt6/files/PyQt6-6.6.1-qt670.patch
deleted file mode 100644
index 64c4aa303836..000000000000
--- a/dev-python/PyQt6/files/PyQt6-6.6.1-qt670.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-Early workarounds to fix build with upcoming Qt6.7.0 not to have
-to wait for the matching PyQt6-6.7.0. Not fully correct fixes,
-but should be better than failing. May need revision given 6.7
-apis are not finalized as of the writing of this.
-
-Caused by the following commits:
-https://github.com/qt/qtbase/commit/fd48ce0b73c (qdatastream+pyqtpyboject)
-> qsizetype is ssize_t and ends up more correct (e.g. for Py_ssize_t)
-https://github.com/qt/qtbase/commit/7a3fed3f209 (qtimezone)
-> removed, can just drop these if 6.7 and ignore the replacement
-https://github.com/qt/qtbase/commit/19bc5de296a (qfont)
-https://github.com/qt/qtbase/commit/bde443801fe (qfont)
-> these tag features are new'ish (and changing) and only available if
-> >=6.6 as-is, let's just drop them if 6.7 as no revdeps should need yet
---- a/qpy/QtCore/qpycore_pyqtpyobject.cpp
-+++ b/qpy/QtCore/qpycore_pyqtpyobject.cpp
-@@ -173,9 +173,13 @@
- {
- char *ser;
-+#if QT_VERSION >= QT_VERSION_CHECK(6, 7, 0)
-+ qsizetype len;
-+#else
- uint len;
-+#endif
-
- in.readBytes(ser, len);
-
-- if (len)
-+ if (len > 0)
- {
- static PyObject *loads = 0;
---- a/sip/QtCore/QtCoremod.sip
-+++ b/sip/QtCore/QtCoremod.sip
-@@ -23,5 +23,5 @@
- %Module(name=PyQt6.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt6, keyword_arguments="Optional", use_limited_api=True, py_ssize_t_clean=True)
-
--%Timeline {Qt_6_0_0 Qt_6_1_0 Qt_6_2_0 Qt_6_3_0 Qt_6_4_0 Qt_6_5_0 Qt_6_6_0}
-+%Timeline {Qt_6_0_0 Qt_6_1_0 Qt_6_2_0 Qt_6_3_0 Qt_6_4_0 Qt_6_5_0 Qt_6_6_0 Qt_6_7_0}
-
- %Platforms {Android iOS Linux macOS WebAssembly Windows}
---- a/sip/QtCore/qdatastream.sip
-+++ b/sip/QtCore/qdatastream.sip
-@@ -123,5 +123,9 @@
- %MethodCode
- char *s;
-+#if QT_VERSION >= QT_VERSION_CHECK(6, 7, 0)
-+ qsizetype l;
-+#else
- uint l;
-+#endif
-
- Py_BEGIN_ALLOW_THREADS
---- a/sip/QtCore/qtimezone.sip
-+++ b/sip/QtCore/qtimezone.sip
-@@ -72,6 +72,8 @@
- ~QTimeZone();
- void swap(QTimeZone &other /Constrained/);
-+%If (- Qt_6_7_0)
- bool operator==(const QTimeZone &other) const;
- bool operator!=(const QTimeZone &other) const;
-+%End
- bool isValid() const;
- QByteArray id() const;
---- a/sip/QtGui/qfont.sip
-+++ b/sip/QtGui/qfont.sip
-@@ -209,4 +209,5 @@
- QStringList families() const;
- void setFamilies(const QStringList &);
-+%If (- Qt_6_7_0)
- %If (Qt_6_6_0 -)
- void setFeature(quint32 tag, quint32 value);
-@@ -239,4 +240,5 @@
- static quint32 stringToTag(const char *tagString /Encoding="None"/);
- %End
-+%End
- };
-