summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 20:52:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 20:52:36 +0000
commitbdf6e70da7a28f45617c02a251bb6b3844202bc5 (patch)
treecf66e5dcf53b2ee6842fd3ff4d24d52aa30cfebc /dev-python/PyQt6
parentd414c993cafd9e31a370c4a5aae042c710df2419 (diff)
gentoo auto-resync : 28:01:2023 - 20:52:36
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/Manifest2
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.1.ebuild145
2 files changed, 147 insertions, 0 deletions
diff --git a/dev-python/PyQt6/Manifest b/dev-python/PyQt6/Manifest
index 1468963cc695..634c3d81a2f4 100644
--- a/dev-python/PyQt6/Manifest
+++ b/dev-python/PyQt6/Manifest
@@ -1,3 +1,5 @@
DIST PyQt6-6.4.0.tar.gz 1024037 BLAKE2B a55d2e33160b6bb713b5e32e6b3a3df942f373ce9c9697cad548325c35ee7ee73a57e93ebc8780480086b02d651fa848258f11f85bea0e54c61c8a0f99039c3d SHA512 836696cc708e140ff497fd915fac147265c58e5d44d54d7dcd1908bad54ed793b4c2c4f20b487d13c7a5f7eb6b2c47d7ab822d8ffc875657de7fd0f88ee6c53b
+DIST PyQt6-6.4.1.tar.gz 1025522 BLAKE2B 17a5f5f4dba5b06729d4a0f9b2964c5632be5bed1da67fe1a90a9d91ba63bc10a83012fc6e8ca5306238d1dc55a3d10ff08c84eed6b369d0c98ac7281e28d2b0 SHA512 860dea8878a81acdefee164f766ba850481b1f4258ebff95fc3cedcbcf15e832799cd2e62d3b2bf83a743879bcb7efdc70109229c83205b649357fdf918864cb
EBUILD PyQt6-6.4.0.ebuild 4551 BLAKE2B 58f950635da473447a45c039abda4e7ff6303adfb9bc0743ce696cf8db37878220b9bbc9086d6560f2af1aa857c44f56c35ce9f2b471b6483ca80355a2abbe1c SHA512 c1efb60f2c8dc51f3771ff377a24917ca23093c504e507a0cca31489632b5c9922b637f67681ae3a90756389db9532b34a33949aeed7f2dfe7804828add947f3
+EBUILD PyQt6-6.4.1.ebuild 4500 BLAKE2B 4a2daeb29d55775047883c50cfa909f39fb81c1edddddd58d68cfb7c2241f94487f99e001c722c74d3db83c97ffa1b402238363b6be4a640ef5865f85ead75c2 SHA512 7312160a028b3c99bd84fc65fb0553c67f041b677821c0e9eedae0ccb02a42d075f8032021cbd8b97a5fe19a7671419b4a910b3c2c80151604a1e8d2ce717059
MISC metadata.xml 1915 BLAKE2B b4ca171871165e02fbc54d7931a52da3a70415b4acf5f85b23459d6949c7a720b68fbddba1a5c22d4d8b90e16faa7f628cb088cc93eb9f1db05da15d33967b1b SHA512 32671e148db535c25b9bf1dd48f945d3ddd74e9df86014af2beb92dccb8d49289e778a1ba38c57cc61dabab88528057ab1aa57ee48b95b80aa1254b1c765772b
diff --git a/dev-python/PyQt6/PyQt6-6.4.1.ebuild b/dev-python/PyQt6/PyQt6-6.4.1.ebuild
new file mode 100644
index 000000000000..2e10cf119914
--- /dev/null
+++ b/dev-python/PyQt6/PyQt6-6.4.1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=sip
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 flag-o-matic multiprocessing qmake-utils
+
+# 'can' work with older Qt depending on features, but keeping it simple
+QT_PV="$(ver_cut 1-2):6"
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# defaults match what is provided with qtbase by default (except testlib),
+# reduces the need to set flags but does increase build time a fair amount
+IUSE="
+ +dbus debug qml designer examples gles2-only +gui help multimedia
+ +network opengl positioning +printsupport quick quick3d serialport
+ +sql +ssl svg testlib webchannel websockets +widgets +xml"
+# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
+REQUIRED_USE="
+ designer? ( gui widgets )
+ help? ( gui widgets )
+ multimedia? ( gui network )
+ opengl? ( gui )
+ printsupport? ( gui widgets )
+ qml? ( network )
+ quick3d? ( gui qml )
+ quick? ( gui qml )
+ sql? ( widgets )
+ svg? ( gui )
+ testlib? ( gui widgets )
+ webchannel? ( network )
+ websockets? ( network )
+ widgets? ( gui )"
+
+DEPEND="
+ >=dev-qt/qtbase-${QT_PV}[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ dbus? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ )
+ designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
+ help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
+ positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
+ qml? ( >=dev-qt/qtdeclarative-${QT_PV} )
+ quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
+ serialport? ( >=dev-qt/qtserialport-${QT_PV} )
+ svg? ( >=dev-qt/qtsvg-${QT_PV} )
+ webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
+ websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/PyQt6-sip-13.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/PyQt-builder-1.11[${PYTHON_USEDEP}]
+ >=dev-qt/qtbase-${QT_PV}
+ sys-devel/gcc
+ dbus? ( virtual/pkgconfig )"
+
+src_prepare() {
+ default
+
+ # hack: qmake queries g++ directly for info (not building) and that doesn't
+ # work with clang, this is to make it at least respect CHOST (bug #726112)
+ mkdir "${T}"/cxx || die
+ ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
+ PATH=${T}/cxx:${PATH}
+}
+
+src_configure() {
+ append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+
+ pyqt-use_enable() {
+ local state=$(usex ${1} --enable= --disable=)
+ shift
+ echo ${*/#/${state}}
+ }
+
+ DISTUTILS_ARGS=(
+ --jobs=$(makeopts_jobs)
+ --qmake="$(type -P qmake6 || die)"
+ --qmake-setting="$(qt5_get_qmake_args)"
+ --verbose
+ --confirm-license
+
+ # TODO: enable more as new qt6 packages get added
+ --disable=QAxContainer
+ --disable=QtBluetooth
+ --enable=QtCore
+ $(pyqt-use_enable dbus QtDBus)
+ $(pyqt-use_enable designer QtDesigner)
+ $(pyqt-use_enable help QtHelp)
+ $(pyqt-use_enable gui QtGui)
+ #--disable=QtLocation # force-disabled in project.py
+ $(pyqt-use_enable multimedia QtMultimedia \
+ $(usev widgets QtMultimediaWidgets))
+ $(pyqt-use_enable network QtNetwork)
+ --disable=QtNfc
+ $(pyqt-use_enable opengl QtOpenGL \
+ $(usev widgets QtOpenGLWidgets))
+ --disable=QtPdf #+QtPdfWidgets (QtPdf is disabled in qtwebengine:6)
+ $(pyqt-use_enable positioning QtPositioning)
+ $(pyqt-use_enable printsupport QtPrintSupport)
+ $(pyqt-use_enable qml QtQml)
+ $(pyqt-use_enable quick QtQuick \
+ $(usev widgets QtQuickWidgets))
+ $(pyqt-use_enable quick3d QtQuick3D)
+ --disable=QtRemoteObjects
+ --disable=QtSensors
+ $(pyqt-use_enable serialport QtSerialPort)
+ $(pyqt-use_enable sql QtSql)
+ $(pyqt-use_enable svg QtSvg \
+ $(usev widgets QtSvgWidgets))
+ $(pyqt-use_enable testlib QtTest)
+ --disable=QtTextToSpeech
+ $(pyqt-use_enable webchannel QtWebChannel)
+ $(pyqt-use_enable websockets QtWebSockets)
+ $(pyqt-use_enable widgets QtWidgets)
+ $(pyqt-use_enable xml QtXml)
+
+ $(usev debug '--debug --qml-debug --tracing')
+
+ $(usev !dbus --no-dbus-python)
+ # TODO?: plugins not in wheels by upstream, see project.py#L215
+ # (if needed by something, will need to be added to python_install)
+ $(usev !designer --no-designer-plugin)
+ $(usev !qml --no-qml-plugin)
+
+ $(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
+ $(usev !ssl --disabled-feature=PyQt_SSL)
+ )
+}
+
+python_install_all() {
+ einstalldocs
+ use examples && dodoc -r examples
+}