summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
commitb978efa000250668b2befa4e2cc96e0afa137611 (patch)
tree0c561efed9b15c17a9d3ef926443f35c58dfb48c /dev-python/PyQt6
parentfa5e8e92d94ea9de5d49a1f5ad19abf7272503d0 (diff)
gentoo auto-resync : 17:06:2023 - 07:43:56
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/Manifest4
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.0.ebuild152
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.1.ebuild10
3 files changed, 7 insertions, 159 deletions
diff --git a/dev-python/PyQt6/Manifest b/dev-python/PyQt6/Manifest
index 79cb8883957f..c58ac50eba6a 100644
--- a/dev-python/PyQt6/Manifest
+++ b/dev-python/PyQt6/Manifest
@@ -1,5 +1,3 @@
-DIST PyQt6-6.5.0.tar.gz 1033399 BLAKE2B a22ad07813c50d6b626b95aa168996ab51f9714fbf3bf3d6e41a233ec2edb8c8e2cb7edcf3b036bc4f69f0a8f1e6549cde512562a420c0809f84a0e04cfb9368 SHA512 c73d4c253245d2ccc776544bc651d47ea67067f57b49c3f820100701af4d79385ef4cabe9f65098f35daeba5f2921a566606be4f237e567f6f56360cc760f548
DIST PyQt6-6.5.1.tar.gz 1036776 BLAKE2B e8e9ac2222de1864386d1fddb75414cf600e380e584e274cfcffbdeb1451cde9e199a43ad4c66cfc8a006cabc833904fe177ccf9dda85ac683f9c8e4f6f87e53 SHA512 8c1135ec48906fe842f0cb50e253a0325b478dd43a7f313b925aaf1d3c148f5462a3e96142470ab0efc0f24fcc8b15704242401cab9f8ec9c3c424e922c49681
-EBUILD PyQt6-6.5.0.ebuild 4813 BLAKE2B c30ffdd14a34213429e338dde537f38ef3ca47110980d4d2c00d35dc2b72953ed7464dbbb9f45330ca2a044923a28969d377290c9264e417ee566dcd7cc36dc5 SHA512 dfac5353ae1882f2399c7ef44a891b0e785d2268fd45bda86fabea9b3fc20cf33e213a0ad82729f1b145505ecbdb34d89bc3be6ee8152122597e8518899d857c
-EBUILD PyQt6-6.5.1.ebuild 5041 BLAKE2B 128d32c70ce75d18a1b7a8f109c8fb92fc40405f8807d205b7eea597cddb821986079b69b07207f83554e5e5067683888ba1f75539ace0281369f333c60825b9 SHA512 79da1c1a6d1da1d838021975f6b70a74b50fe6ce480172970193b077fc5097e64f94e1d0b97d7ab333ed31313bb90197c2df29aec627cb5828bccb4df883d102
+EBUILD PyQt6-6.5.1.ebuild 5185 BLAKE2B b2e42fc505797133a976a7573878cba10f88c14b46b74e68e9e0e65ad1e2deabac1f169d4d2c350d998eb6a2f909b512aa5ecdf42d28ba4d89b2c3e0f97ba2ed SHA512 348a4c5d6d08dcaa91265d70fab6670a7a6a18582a58dfe0080a99d1147767134aca6ed1d6bec09d746ab5a1d2f717802c967429e10ba2b373cdb3066d303d42
MISC metadata.xml 1995 BLAKE2B 8fda7f9c4a21ad6264b77b4bb9dc76698082e3272647911c7a0afa138c48cde16d18c9d282caa49ce3ffa36b211c51e865af87fc9caf739de106fb3cb6ff6896 SHA512 2ab635404dd6b1be94cad9c5ee424939ded0f26a7415dc766d823ad5b0ede1beae09a90bb519ba82e0b2ffb638c5abc7841c4d1f0c7481a112cef5a56fc96e84
diff --git a/dev-python/PyQt6/PyQt6-6.5.0.ebuild b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
deleted file mode 100644
index e91c13b9dee8..000000000000
--- a/dev-python/PyQt6/PyQt6-6.5.0.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=sip
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 flag-o-matic multiprocessing pypi qmake-utils
-
-# 'can' work with older Qt depending on features, but keeping it simple
-QT_PV="$(ver_cut 1-2):6"
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-# defaults match what is provided with qtbase by default (except testlib),
-# reduces the need to set flags but does increase build time a fair amount
-IUSE="
- +dbus debug qml designer examples gles2-only +gui help multimedia
- +network opengl positioning +printsupport quick quick3d serialport
- spatialaudio +sql +ssl svg testlib webchannel websockets +widgets +xml"
-# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
-REQUIRED_USE="
- designer? ( gui widgets )
- help? ( gui widgets )
- multimedia? ( gui network )
- opengl? ( gui )
- printsupport? ( gui widgets )
- qml? ( network )
- quick3d? ( gui qml )
- quick? ( gui qml )
- spatialaudio? ( multimedia )
- sql? ( widgets )
- svg? ( gui )
- testlib? ( gui widgets )
- webchannel? ( network )
- websockets? ( network )
- widgets? ( gui )"
-
-# can use parts of the Qt private api and "sometimes" needs rebuilds wrt :=
-DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- sys-apps/dbus
- )
- designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
- help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- opengl? ( gles2-only? ( media-libs/libglvnd ) )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- qml? ( >=dev-qt/qtdeclarative-${QT_PV} )
- quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )"
-RDEPEND="
- ${DEPEND}
- >=dev-python/PyQt6-sip-13.4[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
- >=dev-qt/qtbase-${QT_PV}
- sys-devel/gcc
- dbus? ( virtual/pkgconfig )"
-
-src_prepare() {
- default
-
- # hack: qmake queries g++ directly for info (not building) and that doesn't
- # work with clang, this is to make it at least respect CHOST (bug #726112)
- mkdir "${T}"/cxx || die
- ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
- PATH=${T}/cxx:${PATH}
-}
-
-python_configure_all() {
- append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
- append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
-
- pyqt-use_enable() {
- local state=$(usex ${1} --enable= --disable=)
- shift
- echo ${*/#/${state}}
- }
-
- DISTUTILS_ARGS=(
- --jobs=$(makeopts_jobs)
- --qmake="$(type -P qmake6 || die)"
- --qmake-setting="$(qt5_get_qmake_args)"
- --verbose
- --confirm-license
-
- # TODO: enable more as new qt6 packages get added
- --disable=QAxContainer
- --disable=QtBluetooth
- --enable=QtCore
- $(pyqt-use_enable dbus QtDBus)
- $(pyqt-use_enable designer QtDesigner)
- $(pyqt-use_enable help QtHelp)
- $(pyqt-use_enable gui QtGui)
- #--disable=QtLocation # force-disabled in project.py
- $(pyqt-use_enable multimedia QtMultimedia \
- $(usev widgets QtMultimediaWidgets))
- $(pyqt-use_enable network QtNetwork)
- --disable=QtNfc
- $(pyqt-use_enable opengl QtOpenGL \
- $(usev widgets QtOpenGLWidgets))
- --disable=QtPdf #+QtPdfWidgets (QtPdf is disabled in qtwebengine:6)
- $(pyqt-use_enable positioning QtPositioning)
- $(pyqt-use_enable printsupport QtPrintSupport)
- $(pyqt-use_enable qml QtQml)
- $(pyqt-use_enable quick QtQuick \
- $(usev widgets QtQuickWidgets))
- $(pyqt-use_enable quick3d QtQuick3D)
- --disable=QtRemoteObjects
- --disable=QtSensors
- $(pyqt-use_enable serialport QtSerialPort)
- $(pyqt-use_enable spatialaudio QtSpatialAudio)
- $(pyqt-use_enable sql QtSql)
- $(pyqt-use_enable svg QtSvg \
- $(usev widgets QtSvgWidgets))
- $(pyqt-use_enable testlib QtTest)
- --disable=QtTextToSpeech
- $(pyqt-use_enable webchannel QtWebChannel)
- $(pyqt-use_enable websockets QtWebSockets)
- $(pyqt-use_enable widgets QtWidgets)
- $(pyqt-use_enable xml QtXml)
-
- $(usev debug '--debug --qml-debug --tracing')
-
- $(usev !dbus --no-dbus-python)
- # TODO?: plugins not in wheels by upstream, see project.py#L214
- # (if needed by something, will need to be added to python_install)
- $(usev !designer --no-designer-plugin)
- $(usev !qml --no-qml-plugin)
-
- $(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
- $(usev !opengl --disabled-feature=PyQt_OpenGL)
- $(usev !ssl --disabled-feature=PyQt_SSL)
- )
-}
-
-python_install_all() {
- einstalldocs
- use examples && dodoc -r examples
-}
diff --git a/dev-python/PyQt6/PyQt6-6.5.1.ebuild b/dev-python/PyQt6/PyQt6-6.5.1.ebuild
index dcf60aee78e0..29f6a8ef6fe2 100644
--- a/dev-python/PyQt6/PyQt6-6.5.1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.1.ebuild
@@ -66,16 +66,18 @@ RDEPEND="
BDEPEND="
>=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
>=dev-qt/qtbase-${QT_PV}
- sys-devel/gcc
dbus? ( virtual/pkgconfig )"
src_prepare() {
default
- # hack: qmake queries g++ directly for info (not building) and that doesn't
- # work with clang, this is to make it at least respect CHOST (bug #726112)
+ # hack: qmake queries g++ or clang++ for info depending on which qtbase was
+ # built with, but ignores CHOST failing with -native-symlinks (bug #726112)
+ # and potentially using wrong information when cross-compiling
mkdir "${T}"/cxx || die
- ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
+ local cxx
+ ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
+ ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
PATH=${T}/cxx:${PATH}
}