summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-python/PyQt6
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/Manifest5
-rw-r--r--dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild184
-rw-r--r--dev-python/PyQt6/PyQt6-6.8.0_pre2410211537.ebuild195
-rw-r--r--dev-python/PyQt6/metadata.xml42
4 files changed, 0 insertions, 426 deletions
diff --git a/dev-python/PyQt6/Manifest b/dev-python/PyQt6/Manifest
deleted file mode 100644
index 9bfe6974b03b..000000000000
--- a/dev-python/PyQt6/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST PyQt6-6.7.1.tar.gz 1051212 BLAKE2B 9c1c619b08cc14e0a92ea22812c14d5a3cb47e45eea917d50ab63918d8433d54b354f26b885f2567b9c6e2f0380e819972d055d1a1751f6646ebb5e6cf72b228 SHA512 1e0fec009e1823b06460fd96eddc00ed31388c20f6d832aa0ebaa130baf06d83514df43af7961c3cb2872570d27e539d6db7bf6143ccdfd61a19da7521be2c7e
-DIST PyQt6-6.8.0.dev2410211537.tar.gz 1062853 BLAKE2B 1838bc76a7a4b2d6787e8f2f5e2960ea8d1f48715dad16886da6121eb36e8ca573d888de733ecf4da61439303e0151747785d1e5a7325271e398866630cdd946 SHA512 3fdf464609da8a2194980b4d100531aa593de6c22027bf212c92e393629e329da8c8259e05dcda11a3c90eb9cdbc1c3c70696642d323822adb721e78b6270b40
-EBUILD PyQt6-6.7.1-r1.ebuild 5782 BLAKE2B cff60065866c67218f6b16dbc885de7c76496b4745b0454c8066a1b69868b7cd5582f7859563ccbd530e0d14a120098080157ccc47b6c90fa2870669771dab25 SHA512 addc5bd46c9c56aceba278fcf1929fd19440cbb7a860ae1189dd4e0e39d1539de48d43b87c79fe656202efbd3d5518065df05f57fc98d4bfac51ae4aaea7d76e
-EBUILD PyQt6-6.8.0_pre2410211537.ebuild 6136 BLAKE2B fb0d90a3d0a9556f37a1dbd2751ceaaf5a1c689b52cd874ae8baeb2ff5842986690b614ed4577a2d02accae82a6d23aea830f561cddf2d2540a1643f712b5f21 SHA512 2a1c36d160a13186ea95cf859f7ba2f260bf39941f896cff5d9d1c0988ea428220f905a29f392aef81b2ddcc8b326c620b4401fb07faf0bbbcdaf9a1e22ceb16
-MISC metadata.xml 2473 BLAKE2B a86705641a5b20eda9edb08d129e98e848586ff3d6ddc5adfb52c26269d84cf1ebbbcc1cfd967b31403fb12f5a3fb021785c9f3651087240344fa0eb5e403082 SHA512 d985e7e96b9263072165fb323e4efdf1e04f6decace4ea52228ed822d0be730596e8e4e46627e8111574b0703e86f27c82d9a2ec72661edba5583d3e49efc1f4
diff --git a/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild b/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
deleted file mode 100644
index abba8dd581d2..000000000000
--- a/dev-python/PyQt6/PyQt6-6.7.1-r1.ebuild
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=sip
-PYPI_NO_NORMALIZE=1
-PYPI_PN=PyQt6
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 flag-o-matic multiprocessing pypi qmake-utils
-
-# 'can' work with older Qt depending on features, but keeping it simple
-QT_PV=$(ver_cut 1-2):6
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
-# defaults match what is provided with qtbase by default (except testlib),
-# reduces the need to set flags but does increase build time a fair amount
-IUSE="
- bluetooth +dbus debug designer examples gles2-only +gui help
- multimedia +network nfc opengl pdfium positioning +printsupport
- qml quick quick3d remoteobjects serialport sensors spatialaudio
- speech +sql +ssl svg testlib webchannel websockets +widgets +xml
-"
-# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
-REQUIRED_USE="
- designer? ( gui widgets )
- help? ( gui widgets )
- multimedia? ( gui network )
- opengl? ( gui )
- pdfium? ( gui )
- printsupport? ( gui widgets )
- qml? ( network )
- quick3d? ( gui qml )
- quick? ( gui qml )
- remoteobjects? ( network )
- spatialaudio? ( multimedia )
- sql? ( widgets )
- svg? ( gui )
- testlib? ( gui widgets )
- webchannel? ( network )
- websockets? ( network )
- widgets? ( gui )
-"
-
-# may use qt private symbols wrt qtbase's :=
-# non-trivially broken with Qt6.8 wrt upper bound, waiting for PyQt6-6.8.0
-DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
- <dev-qt/qtbase-6.8
- bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- sys-apps/dbus
- )
- designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
- help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- nfc? ( >=dev-qt/qtconnectivity-${QT_PV}[nfc] )
- opengl? (
- gles2-only? ( media-libs/libglvnd )
- )
- pdfium? ( >=dev-qt/qtwebengine-${QT_PV}[pdfium,widgets?] )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
- quick? ( >=dev-qt/qtdeclarative-${QT_PV}[opengl] )
- remoteobjects? ( >=dev-qt/qtremoteobjects-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- speech? (
- >=dev-qt/qtdeclarative-${QT_PV}
- >=dev-qt/qtspeech-${QT_PV}
- )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/PyQt6-sip-13.8[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
- >=dev-python/sip-6.8.6[${PYTHON_USEDEP}]
- >=dev-qt/qtbase-${QT_PV}
- dbus? ( virtual/pkgconfig )
-"
-
-src_prepare() {
- default
-
- # hack: PyQt-builder runs qmake without our arguments and calls g++
- # or clang++ depending on what qtbase was built with, not used for
- # building but fails with -native-symlinks
- mkdir "${T}"/cxx || die
- local cxx
- ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
- ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
- PATH=${T}/cxx:${PATH}
-}
-
-python_configure_all() {
- append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
- append-cxxflags ${CPPFLAGS} # respect CPPFLAGS notably for DISTUTILS_EXT=1
-
- pyqt_use_enable() {
- local state=$(usex ${1} --enable= --disable=)
- shift
- echo ${*/#/${state}}
- }
-
- DISTUTILS_ARGS=(
- --jobs="$(makeopts_jobs)"
- --qmake="$(qt6_get_bindir)"/qmake
- --qmake-setting="$(qt6_get_qmake_args)"
- --verbose
- --confirm-license
-
- --enable=QtCore
-
- $(pyqt_use_enable bluetooth QtBluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable designer QtDesigner)
- $(pyqt_use_enable help QtHelp)
- $(pyqt_use_enable gui QtGui)
- #--disable=QtLocation # force-disabled in project.py
- $(pyqt_use_enable multimedia QtMultimedia \
- $(usev widgets QtMultimediaWidgets))
- $(pyqt_use_enable network QtNetwork)
- $(pyqt_use_enable nfc QtNfc)
- $(pyqt_use_enable opengl QtOpenGL \
- $(usev widgets QtOpenGLWidgets))
- $(pyqt_use_enable pdfium QtPdf \
- $(usev widgets QtPdfWidgets))
- $(pyqt_use_enable positioning QtPositioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable qml QtQml)
- $(pyqt_use_enable quick QtQuick \
- $(usev widgets QtQuickWidgets))
- $(pyqt_use_enable quick3d QtQuick3D)
- $(pyqt_use_enable remoteobjects QtRemoteObjects)
- $(pyqt_use_enable sensors QtSensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable spatialaudio QtSpatialAudio)
- $(pyqt_use_enable sql QtSql)
- $(pyqt_use_enable svg QtSvg \
- $(usev widgets QtSvgWidgets))
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable speech QtTextToSpeech)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets QtWidgets)
- $(pyqt_use_enable xml QtXml)
-
- $(usev debug '--debug --qml-debug --tracing')
-
- $(usev !dbus --no-dbus-python)
- # note: upstream currently intentionally skips installing these two
- # plugins when using wheels w/ pep517 so, *if* something does need
- # them, it will need to be handled manually
- $(usev !designer --no-designer-plugin)
- $(usev !qml --no-qml-plugin)
-
- $(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
- $(usev !opengl --disabled-feature=PyQt_OpenGL)
- $(usev !ssl --disabled-feature=PyQt_SSL)
-
- # intended for Windows / Android or others
- --disable=QAxContainer
- --disabled-feature=PyQt_Permissions
- )
-}
-
-python_install_all() {
- einstalldocs
- use examples && dodoc -r examples
-}
diff --git a/dev-python/PyQt6/PyQt6-6.8.0_pre2410211537.ebuild b/dev-python/PyQt6/PyQt6-6.8.0_pre2410211537.ebuild
deleted file mode 100644
index 2a3757e26187..000000000000
--- a/dev-python/PyQt6/PyQt6-6.8.0_pre2410211537.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=sip
-PYPI_NO_NORMALIZE=1
-PYPI_PN=PyQt6
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 flag-o-matic multiprocessing qmake-utils # pypi
-
-# 'can' work with older Qt depending on features, but keeping it simple
-QT_PV=$(ver_cut 1-2):6
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
-
-# TODO: drop this and uncomment 'pypi' on a proper bump
-MY_P=${PYPI_PN}-$(ver_cut 1-3).dev$(ver_cut 5)
-SRC_URI="https://www.riverbankcomputing.com/pypi/packages/PyQt6/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
-# defaults match what is provided with qtbase by default (except testlib),
-# reduces the need to set flags but does increase build time a fair amount
-IUSE="
- bluetooth +dbus debug designer examples gles2-only +gui help
- multimedia +network nfc opengl pdfium positioning +printsupport
- qml quick quick3d remoteobjects serialport sensors spatialaudio
- speech +sql +ssl svg testlib webchannel websockets vulkan
- +widgets +xml
-"
-# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
-REQUIRED_USE="
- designer? ( gui widgets )
- help? ( gui widgets )
- multimedia? ( gui network )
- opengl? ( gui )
- pdfium? ( gui )
- printsupport? ( gui widgets )
- qml? ( network )
- quick3d? ( gui qml )
- quick? ( gui qml )
- remoteobjects? ( network )
- spatialaudio? ( multimedia )
- sql? ( widgets )
- svg? ( gui )
- testlib? ( gui widgets )
- vulkan? ( gui )
- webchannel? ( network )
- websockets? ( network )
- widgets? ( gui )
-"
-
-# may use qt private symbols wrt qtbase's :=
-# non-trivially broken with Qt6.8 wrt upper bound, waiting for PyQt6-6.8.0
-COMMON_DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,vulkan?,widgets?,xml?]
- bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- sys-apps/dbus
- )
- designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
- help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- nfc? ( >=dev-qt/qtconnectivity-${QT_PV}[nfc] )
- opengl? (
- gles2-only? ( media-libs/libglvnd )
- )
- pdfium? ( >=dev-qt/qtwebengine-${QT_PV}[pdfium,widgets?] )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
- quick? ( >=dev-qt/qtdeclarative-${QT_PV}[opengl] )
- remoteobjects? ( >=dev-qt/qtremoteobjects-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- speech? (
- >=dev-qt/qtdeclarative-${QT_PV}
- >=dev-qt/qtspeech-${QT_PV}
- )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
-"
-RDEPEND="
- ${COMMON_DEPEND}
- >=dev-python/PyQt6-sip-13.8[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${COMMON_DEPEND}
- vulkan? ( dev-util/vulkan-headers )
-"
-BDEPEND="
- >=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
- >=dev-python/sip-6.8.6[${PYTHON_USEDEP}]
- >=dev-qt/qtbase-${QT_PV}
- dbus? ( virtual/pkgconfig )
-"
-
-src_prepare() {
- default
-
- # hack: PyQt-builder runs qmake without our arguments and calls g++
- # or clang++ depending on what qtbase was built with, not used for
- # building but fails with -native-symlinks
- mkdir "${T}"/cxx || die
- local cxx
- ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
- ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
- PATH=${T}/cxx:${PATH}
-}
-
-python_configure_all() {
- append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
- append-cxxflags ${CPPFLAGS} # respect CPPFLAGS notably for DISTUTILS_EXT=1
-
- pyqt_use_enable() {
- local state=$(usex ${1} --enable= --disable=)
- shift
- echo ${*/#/${state}}
- }
-
- DISTUTILS_ARGS=(
- --jobs="$(makeopts_jobs)"
- --qmake="$(qt6_get_bindir)"/qmake
- --qmake-setting="$(qt6_get_qmake_args)"
- --verbose
- --confirm-license
-
- --enable=QtCore
-
- $(pyqt_use_enable bluetooth QtBluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable designer QtDesigner)
- $(pyqt_use_enable help QtHelp)
- $(pyqt_use_enable gui QtGui)
- #--disable=QtLocation # force-disabled in project.py
- $(pyqt_use_enable multimedia QtMultimedia \
- $(usev widgets QtMultimediaWidgets))
- $(pyqt_use_enable network QtNetwork)
- $(pyqt_use_enable nfc QtNfc)
- $(pyqt_use_enable opengl QtOpenGL \
- $(usev widgets QtOpenGLWidgets))
- $(pyqt_use_enable pdfium QtPdf \
- $(usev widgets QtPdfWidgets))
- $(pyqt_use_enable positioning QtPositioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable qml QtQml)
- $(pyqt_use_enable quick QtQuick \
- $(usev widgets QtQuickWidgets))
- $(pyqt_use_enable quick3d QtQuick3D)
- $(pyqt_use_enable remoteobjects QtRemoteObjects)
- $(pyqt_use_enable sensors QtSensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable spatialaudio QtSpatialAudio)
- $(pyqt_use_enable sql QtSql)
- $(pyqt_use_enable svg QtSvg \
- $(usev widgets QtSvgWidgets))
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable speech QtTextToSpeech)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets QtWidgets)
- $(pyqt_use_enable xml QtXml)
-
- $(usev debug '--debug --qml-debug --tracing')
-
- $(usev !dbus --no-dbus-python)
- # note: upstream currently intentionally skips installing these two
- # plugins when using wheels w/ pep517 so, *if* something does need
- # them, it will need to be handled manually
- $(usev !designer --no-designer-plugin)
- $(usev !qml --no-qml-plugin)
-
- $(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
- $(usev !opengl --disabled-feature=PyQt_OpenGL)
- $(usev !ssl --disabled-feature=PyQt_SSL)
- $(usev !vulkan --disabled-feature=PyQt_Vulkan)
-
- # intended for Windows / Android or others
- --disable=QAxContainer
- --disabled-feature=PyQt_Permissions
- )
-}
-
-python_install_all() {
- einstalldocs
- use examples && dodoc -r examples
-}
diff --git a/dev-python/PyQt6/metadata.xml b/dev-python/PyQt6/metadata.xml
deleted file mode 100644
index 4672aed86173..000000000000
--- a/dev-python/PyQt6/metadata.xml
+++ /dev/null
@@ -1,42 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="bluetooth">Build bindings for the QtBluetooth module</flag>
- <flag name="dbus">Build bindings for the QtDBus module</flag>
- <flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
- <flag name="gui">Build bindings for the QtGui module</flag>
- <flag name="help">Build bindings for the QtHelp module</flag>
- <flag name="multimedia">Build bindings for the QtMultimedia module</flag>
- <flag name="network">Build bindings for the QtNetwork module</flag>
- <flag name="nfc">Build bindings for the QtNfc module</flag>
- <flag name="opengl">Build bindings for the QtOpenGL module</flag>
- <flag name="pdfium">Build bindings for the QtPdf module (uses pdfium from <pkg>dev-qt/qtwebengine</pkg>)</flag>
- <flag name="positioning">Build bindings for the QtPositioning module</flag>
- <flag name="printsupport">Build bindings for the QtPrintSupport module</flag>
- <flag name="qml">Build bindings for the QtQml module and enable the qml plugin</flag>
- <flag name="quick">Build bindings for the QtQuick module</flag>
- <flag name="quick3d">Build bindings for the QtQuick3D module</flag>
- <flag name="remoteobjects">Build bindings for the QtRemoteObjects module</flag>
- <flag name="sensors">Build bindings for the QtSensors module</flag>
- <flag name="serialport">Build bindings for the QtSerialPort module</flag>
- <flag name="spatialaudio">Build bindings for the QtSpatialAudio module</flag>
- <flag name="speech">Build bindings for the QtTextToSpeech module</flag>
- <flag name="sql">Build bindings for the QtSql module</flag>
- <flag name="svg">Build bindings for the QtSvg module</flag>
- <flag name="testlib">Build bindings for the QtTest module</flag>
- <flag name="webchannel">Build bindings for the QtWebChannel module</flag>
- <flag name="websockets">Build bindings for the QtWebSockets module</flag>
- <flag name="widgets">Build bindings for the QtWidgets module</flag>
- <flag name="xml">Build bindings for the QtXml module</flag>
- </use>
- <upstream>
- <bugs-to>https://www.riverbankcomputing.com/mailman/listinfo/pyqt/</bugs-to>
- <doc>https://www.riverbankcomputing.com/static/Docs/PyQt6/</doc>
- <remote-id type="pypi">PyQt6</remote-id>
- </upstream>
-</pkgmetadata>