summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
commit44a22ab89258383202cae3037c3a5685aa903251 (patch)
tree76789a8fb67642ae7635df789a9bb83125ec127d /dev-python/PyQt6
parent9aa62a2a35904a08cbf2e884d3abd89d893daf91 (diff)
gentoo auto-resync : 05:09:2023 - 16:23:54
Diffstat (limited to 'dev-python/PyQt6')
-rw-r--r--dev-python/PyQt6/Manifest4
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.2.ebuild33
-rw-r--r--dev-python/PyQt6/metadata.xml10
3 files changed, 28 insertions, 19 deletions
diff --git a/dev-python/PyQt6/Manifest b/dev-python/PyQt6/Manifest
index b4b7e727fd6b..0fc12b5d85d4 100644
--- a/dev-python/PyQt6/Manifest
+++ b/dev-python/PyQt6/Manifest
@@ -1,3 +1,3 @@
DIST PyQt6-6.5.2.tar.gz 1037215 BLAKE2B dae331dc27975f3ad4fca10cedf093fecabf819d1fd97b873f9a793ce12168af9a72e2b119a4fc3ecf263e1ba42103f48d5198554248743a6289efc8aa3b7d70 SHA512 11da50ff8b914794e8044e136a3c8a79d16aa63ab33045f2807985c2fe2235c1a7682f7e955c9e8852093c34a671ec09d84afaa9d3d59945461797e81911721f
-EBUILD PyQt6-6.5.2.ebuild 5267 BLAKE2B 04aa28c34e619197855c357cacb02dbb7d3ba6fd2fad5e712dae14b1a75014f90b1d07b1bcb63e2c246fea1eb146f69b4515611d04efc82f15af93ab5269b5e1 SHA512 2b534688d32b2d1bf81c190aab4bbca961593c4c0cfa5de95932c58eacd0ae1a8b6d4c2fa30578963432667eaa30fd5693c896845e34fbc37c18df6d0efdfa25
-MISC metadata.xml 1995 BLAKE2B 8fda7f9c4a21ad6264b77b4bb9dc76698082e3272647911c7a0afa138c48cde16d18c9d282caa49ce3ffa36b211c51e865af87fc9caf739de106fb3cb6ff6896 SHA512 2ab635404dd6b1be94cad9c5ee424939ded0f26a7415dc766d823ad5b0ede1beae09a90bb519ba82e0b2ffb638c5abc7841c4d1f0c7481a112cef5a56fc96e84
+EBUILD PyQt6-6.5.2.ebuild 5375 BLAKE2B 4fba0f8b473ad9ef5c6764402a6dc597ba1e75e540028d55082b333646599bb4a67f1c203bb7e8dca020990e3c0043d24f8f7d408e2f20b82b73dd3f31f288dc SHA512 397cf49d07f1d9c1baace1466eeb803556354abc3906866133f3c63168d035d1bbe3e60d3c6c46756d94b3b57fd5987c8643a09e1fd9edfbfd72072aa88775d6
+MISC metadata.xml 2277 BLAKE2B 22ee4e39000e75990db2f605303b3a4b8be0032cd82cbeaef4a0cf3730b7fbdc4dc45be9530373471c953e9fd767a54bfde705d67153dc24e70609bb830f37f1 SHA512 09e0c1fb5cae914501c2b8626ca89c7b03bb30d3efee1afe47fb3e938a3d4c1952dc21ad2ca3c6d95efd55fb918e60a21b3bf1b66e7737ae403e8e08d1f53e41
diff --git a/dev-python/PyQt6/PyQt6-6.5.2.ebuild b/dev-python/PyQt6/PyQt6-6.5.2.ebuild
index 16495698c205..311aa076e528 100644
--- a/dev-python/PyQt6/PyQt6-6.5.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.2.ebuild
@@ -21,9 +21,10 @@ KEYWORDS="~amd64"
# defaults match what is provided with qtbase by default (except testlib),
# reduces the need to set flags but does increase build time a fair amount
IUSE="
- +dbus debug qml designer examples gles2-only +gui help multimedia
- +network opengl positioning +printsupport quick quick3d serialport
- spatialaudio +sql +ssl svg testlib webchannel websockets +widgets +xml
+ bluetooth +dbus debug designer examples gles2-only +gui help
+ multimedia +network nfc opengl positioning +printsupport qml
+ quick quick3d serialport sensors spatialaudio speech +sql +ssl
+ svg testlib webchannel websockets +widgets +xml
"
# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
REQUIRED_USE="
@@ -47,6 +48,7 @@ REQUIRED_USE="
# can use parts of the Qt private api and "sometimes" needs rebuilds wrt :=
DEPEND="
>=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
+ bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
dbus? (
dev-python/dbus-python[${PYTHON_USEDEP}]
sys-apps/dbus
@@ -54,11 +56,16 @@ DEPEND="
designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- opengl? ( gles2-only? ( media-libs/libglvnd ) )
+ nfc? ( >=dev-qt/qtconnectivity-${QT_PV}[nfc] )
+ opengl? (
+ gles2-only? ( media-libs/libglvnd )
+ )
positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
qml? ( >=dev-qt/qtdeclarative-${QT_PV} )
quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
+ sensors? ( >=dev-qt/qtsensors-${QT_PV} )
serialport? ( >=dev-qt/qtserialport-${QT_PV} )
+ speech? ( >=dev-qt/qtspeech-${QT_PV} )
svg? ( >=dev-qt/qtsvg-${QT_PV} )
webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
@@ -103,10 +110,9 @@ python_configure_all() {
--verbose
--confirm-license
- # TODO: enable more as new qt6 packages get added
- --disable=QAxContainer
- --disable=QtBluetooth
--enable=QtCore
+
+ $(pyqt_use_enable bluetooth QtBluetooth)
$(pyqt_use_enable dbus QtDBus)
$(pyqt_use_enable designer QtDesigner)
$(pyqt_use_enable help QtHelp)
@@ -115,7 +121,7 @@ python_configure_all() {
$(pyqt_use_enable multimedia QtMultimedia \
$(usev widgets QtMultimediaWidgets))
$(pyqt_use_enable network QtNetwork)
- --disable=QtNfc
+ $(pyqt_use_enable nfc QtNfc)
$(pyqt_use_enable opengl QtOpenGL \
$(usev widgets QtOpenGLWidgets))
--disable=QtPdf #+QtPdfWidgets (QtPdf is disabled in qtwebengine:6)
@@ -125,15 +131,15 @@ python_configure_all() {
$(pyqt_use_enable quick QtQuick \
$(usev widgets QtQuickWidgets))
$(pyqt_use_enable quick3d QtQuick3D)
- --disable=QtRemoteObjects
- --disable=QtSensors
+ --disable=QtRemoteObjects # not packaged
+ $(pyqt_use_enable sensors QtSensors)
$(pyqt_use_enable serialport QtSerialPort)
$(pyqt_use_enable spatialaudio QtSpatialAudio)
$(pyqt_use_enable sql QtSql)
$(pyqt_use_enable svg QtSvg \
$(usev widgets QtSvgWidgets))
$(pyqt_use_enable testlib QtTest)
- --disable=QtTextToSpeech
+ $(pyqt_use_enable speech QtTextToSpeech)
$(pyqt_use_enable webchannel QtWebChannel)
$(pyqt_use_enable websockets QtWebSockets)
$(pyqt_use_enable widgets QtWidgets)
@@ -152,9 +158,8 @@ python_configure_all() {
$(usev !opengl --disabled-feature=PyQt_OpenGL)
$(usev !ssl --disabled-feature=PyQt_SSL)
- # TODO: drop this when depend on a >=qtbase-<ver> which enables
- # -DQT_FEATURE_permissions=ON (currently missing, and the feature
- # is furthermore broken with gcc-13 on qtbase's end)
+ # intended for Windows / Android or others
+ --disable=QAxContainer
--disabled-feature=PyQt_Permissions
)
}
diff --git a/dev-python/PyQt6/metadata.xml b/dev-python/PyQt6/metadata.xml
index e10a52de1e47..930d5440dcc5 100644
--- a/dev-python/PyQt6/metadata.xml
+++ b/dev-python/PyQt6/metadata.xml
@@ -1,25 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>ionen@gentoo.org</email>
- <name>Ionen Wolkens</name>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
</maintainer>
<use>
+ <flag name="bluetooth">Build bindings for the QtBluetooth module</flag>
<flag name="dbus">Build bindings for the QtDBus module</flag>
<flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
<flag name="gui">Build bindings for the QtGui module</flag>
<flag name="help">Build bindings for the QtHelp module</flag>
<flag name="multimedia">Build bindings for the QtMultimedia module</flag>
<flag name="network">Build bindings for the QtNetwork module</flag>
+ <flag name="nfc">Build bindings for the QtNfc module</flag>
<flag name="opengl">Build bindings for the QtOpenGL module</flag>
<flag name="positioning">Build bindings for the QtPositioning module</flag>
<flag name="printsupport">Build bindings for the QtPrintSupport module</flag>
<flag name="qml">Build bindings for the QtQml module and enable the qml plugin</flag>
<flag name="quick">Build bindings for the QtQuick module</flag>
<flag name="quick3d">Build bindings for the QtQuick3D module</flag>
+ <flag name="sensors">Build bindings for the QtSensors module</flag>
<flag name="serialport">Build bindings for the QtSerialPort module</flag>
<flag name="spatialaudio">Build bindings for the QtSpatialAudio module</flag>
+ <flag name="speech">Build bindings for the QtTextToSpeech module</flag>
<flag name="sql">Build bindings for the QtSql module</flag>
<flag name="svg">Build bindings for the QtSvg module</flag>
<flag name="testlib">Build bindings for the QtTest module</flag>