summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6/PyQt6-6.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 12:04:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 12:04:32 +0100
commit5b52b99ca475070991d8e8d1dff674ffe6ffdea9 (patch)
treecf4bb45c00280387facfe6360387dbb2f8526bf3 /dev-python/PyQt6/PyQt6-6.4.2.ebuild
parent2cf667d4c687ef89fe0fc530e2a5bc8518941728 (diff)
gentoo auto-resync : 22:04:2023 - 12:04:32
Diffstat (limited to 'dev-python/PyQt6/PyQt6-6.4.2.ebuild')
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.4.2.ebuild b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
index d1f60a1efb1b..4e892b399454 100644
--- a/dev-python/PyQt6/PyQt6-6.4.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=sip
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{9..11} )
@@ -76,8 +77,9 @@ src_prepare() {
PATH=${T}/cxx:${PATH}
}
-src_configure() {
+python_configure_all() {
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+ append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
pyqt-use_enable() {
local state=$(usex ${1} --enable= --disable=)