summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild')
-rw-r--r--dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild b/dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild
new file mode 100644
index 000000000000..91c98f7ad6e1
--- /dev/null
+++ b/dev-python/PyQt5-sip/PyQt5-sip-12.10.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="sip extension module for PyQt5"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/ https://pypi.org/project/PyQt5-sip/"
+
+MY_P=${PN/-/_}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"