summaryrefslogtreecommitdiff
path: root/dev-python/PyQt-builder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-python/PyQt-builder
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-python/PyQt-builder')
-rw-r--r--dev-python/PyQt-builder/Manifest3
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild22
-rw-r--r--dev-python/PyQt-builder/metadata.xml18
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/Manifest b/dev-python/PyQt-builder/Manifest
new file mode 100644
index 000000000000..ecd1805e9047
--- /dev/null
+++ b/dev-python/PyQt-builder/Manifest
@@ -0,0 +1,3 @@
+DIST PyQt-builder-1.10.1.tar.gz 5725429 BLAKE2B e7aaa0a3c1eb8aeea0aa5f2d5d7beda1edc46e90c0a21b608d2dffe205a67170daaa6615253706b5f9856a27d66715692ceffe81b9b45eafd4d608df79741d6f SHA512 2e48c1066bb12c1f50700933b0f489158f29f62a1239b570dc053cb042eca9bd4ee83f66b855b0596cfb6dc2e844434c15563abbb3846bf5960d03441f497b83
+EBUILD PyQt-builder-1.10.1.ebuild 697 BLAKE2B 051cc303748b9ac79b2beade93c91cf3dfccde5c859d1d3f9f92a4c5d7c06bc37b92cf4080fb46d0611fcc6f199b74808797fec220f9a4dacb53e7b161618cfe SHA512 e88d0310d1ab22d1cc47fc0c4d246ed53fa0a92f678c9e34e0254f46eec075f58a9ad51ed032a93fef89473bca2b8cb1f81c7c795b9a47884b8cdb5be4d23ca1
+MISC metadata.xml 665 BLAKE2B 156bcbd9a31940a4074d395521e71452f45fc725c88825e412a73751bb869621ba3ac8fa8a96cd269130468ca28d7fbf04525b6a2caf9b871f426040e6d6c9d1 SHA512 56505229aa14dd577033cd534a837fcc3584cb4d1b482e59d65ee439b49a42cd21e3ae1ca7a02227e6183e265506910e7993d52a8c4ec9e17e44273204aedfc6
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
new file mode 100644
index 000000000000..c7f4ec9ff355
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/ https://www.riverbankcomputing.com/static/Docs/PyQt-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+RDEPEND="dev-python/sip[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+}
diff --git a/dev-python/PyQt-builder/metadata.xml b/dev-python/PyQt-builder/metadata.xml
new file mode 100644
index 000000000000..0a0159870724
--- /dev/null
+++ b/dev-python/PyQt-builder/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>phil@riverbankcomputing.com</email>
+ <name>Phil Thompson</name>
+ </maintainer>
+ <changelog>https://www.riverbankcomputing.com/hg/PyQt-builder/file/tip/NEWS</changelog>
+ <doc>https://www.riverbankcomputing.com/static/Docs/PyQt-builder/</doc>
+ <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
+ <remote-id type="pypi">PyQt-builder</remote-id>
+ </upstream>
+</pkgmetadata>