summaryrefslogtreecommitdiff
path: root/dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-14 17:40:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-14 17:40:19 +0100
commitb23b1d43c4a10df85088f74d98a914917f114538 (patch)
tree6dc0ff9e7ed8d4efbb297e572d216fb9c85efbb7 /dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild
parent57aee2868b3c58313cc276d2871eacfb8c95c020 (diff)
gentoo auto-resync : 14:10:2023 - 17:40:19
Diffstat (limited to 'dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild')
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild
new file mode 100644
index 000000000000..5ef4f3ffc44d
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.15.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # don't install prebuilt DLLs
+ sed -i "s:'dlls/\*/\*',::" setup.py || die
+}