summaryrefslogtreecommitdiff
path: root/dev-python/PyECLib/PyECLib-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/PyECLib/PyECLib-1.6.0.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/PyECLib/PyECLib-1.6.0.ebuild')
-rw-r--r--dev-python/PyECLib/PyECLib-1.6.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/PyECLib/PyECLib-1.6.0.ebuild b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
new file mode 100644
index 000000000000..ab29e70bcb74
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
+HOMEPAGE="https://pypi.org/project/PyECLib/"
+SRC_URI="mirror://pypi/p/pyeclib/pyeclib-${PV}.tar.gz"
+S="${WORKDIR}/pyeclib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"