summaryrefslogtreecommitdiff
path: root/dev-python/PeachPy/PeachPy-2022.11.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
commit80c51284f0017d5765c7ae39207be9c58f4bfa17 (patch)
treef870412cb8771b0acdc3b28c70c09545bf034385 /dev-python/PeachPy/PeachPy-2022.11.13.ebuild
parentfd089c26c06476b291a5255011ee378561c2615d (diff)
gentoo auto-resync : 19:02:2023 - 14:14:15
Diffstat (limited to 'dev-python/PeachPy/PeachPy-2022.11.13.ebuild')
-rw-r--r--dev-python/PeachPy/PeachPy-2022.11.13.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/PeachPy/PeachPy-2022.11.13.ebuild b/dev-python/PeachPy/PeachPy-2022.11.13.ebuild
new file mode 100644
index 000000000000..493cd83fb3e1
--- /dev/null
+++ b/dev-python/PeachPy/PeachPy-2022.11.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+CommitId=349e8f836142b2ed0efeb6bb99b1b715d87202e9
+
+DESCRIPTION="Portable Efficient Assembly Code-generator in Higher-level Python"
+HOMEPAGE="https://pypi.org/project/PeachPy/"
+SRC_URI="https://github.com/Maratyszcza/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # depends on an old version of werkzeug
+
+RDEPEND="
+ dev-python/Opcodes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-${CommitId}