summaryrefslogtreecommitdiff
path: root/dev-python/OutputCheck
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
commit744892aecb5cdf9ca0bbe504f7bbcdfb87b518fc (patch)
tree0b99b178b866e693a85d013eb47de3d1236e35b8 /dev-python/OutputCheck
parent275074c50dca7b941cc7cd7966a2ace71c29ecae (diff)
gentoo auto-resync : 06:10:2022 - 19:22:30
Diffstat (limited to 'dev-python/OutputCheck')
-rw-r--r--dev-python/OutputCheck/Manifest3
-rw-r--r--dev-python/OutputCheck/OutputCheck-0.4.2.ebuild37
-rw-r--r--dev-python/OutputCheck/metadata.xml20
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/OutputCheck/Manifest b/dev-python/OutputCheck/Manifest
new file mode 100644
index 000000000000..7c34a5090540
--- /dev/null
+++ b/dev-python/OutputCheck/Manifest
@@ -0,0 +1,3 @@
+DIST OutputCheck-0.4.2.gh.tar.gz 16436 BLAKE2B 8c1678746b9fc11cf7b554da83a2e5a51c7095931894a543340e905ccff1e7240f1bb8ec12d348af9662ce7e515d70d6e8a93d1e6ab15629545aa5019a7fe648 SHA512 0abd1ca69c4ef683cc455c222979b313ed8b4906725cc534b80906cc4fb9a0acad855d4a6c39aa4777bbdc35309857082197a0cacdc191e4afb8a8a9a4bb2bed
+EBUILD OutputCheck-0.4.2.ebuild 904 BLAKE2B 7bbfc363a39c343abb7a06582668aa2ff7474bc67713f9aeeed195d87e5e5b321a8f96ab32c364f066a58f882891b0217c9ee4e84286f116c5c4fb65894de4a9 SHA512 2b2c5e8dc63eb17a0da8d803bd1186dea4cbdce9f903bfedbd245c70add408d7c67843ae97935fd9309d75299365d4eeb97ec9d206dca6d892d32d524fc04609
+MISC metadata.xml 792 BLAKE2B 0359b2057a0d04dfc5e6ac79036ed5456d6c54f94d040a67bdc6cea4d644a70e53c99e40d3030e65c64441ff4c2841a3cc7a5291352bcebba36b52b70e76ca74 SHA512 77ecfb6ca26cbaffaad7a36b321d2983c67b9d2b7ec83a90e9cf926d6819f8b4e256f65af5ebc166db0f91e7e9a05ca135bfdef7274706faa665f14505308cd4
diff --git a/dev-python/OutputCheck/OutputCheck-0.4.2.ebuild b/dev-python/OutputCheck/OutputCheck-0.4.2.ebuild
new file mode 100644
index 000000000000..d1ec3ff584ba
--- /dev/null
+++ b/dev-python/OutputCheck/OutputCheck-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for checking the output of console programs inspired by LLVM's FileCheck"
+HOMEPAGE="https://github.com/stp/OutputCheck/"
+SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/lit[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Remove bad tests.
+ rm "${S}"/tests/invalid-regex-syntax.smt2 ||
+ die "failed to remove bad tests"
+
+ # Create RELEASE-VERSION file.
+ echo ${PV} > "${S}"/RELEASE-VERSION ||
+ die "failed to write RELEASE-VERSION"
+}
+
+python_test() {
+ lit "${S}"/tests || die "running test with ${EPYTHON} failed"
+}
diff --git a/dev-python/OutputCheck/metadata.xml b/dev-python/OutputCheck/metadata.xml
new file mode 100644
index 000000000000..536c2285d052
--- /dev/null
+++ b/dev-python/OutputCheck/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ OutputCheck is a tool for checking the output of console programs that is
+ inspired by the FileCheck tool used by LLVM. It has its own small language
+ (Check Directives) for describing the expected output of a tool that is
+ considerably more convenient and more powerful than GNU grep.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/stp/OutputCheck/issues/</bugs-to>
+ <remote-id type="github">stp/OutputCheck</remote-id>
+ <remote-id type="pypi">OutputCheck</remote-id>
+ </upstream>
+</pkgmetadata>