summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 23:51:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 23:51:54 +0000
commitbf90f82fef4fc737c88b58cd31428ad4355c17fa (patch)
treefc72ac72a2f48adcbc9b83d64185c7747727566a /dev-python/Nuitka
parent027dc9b3977cd14e0c7ae52e7bf9370c3919afa1 (diff)
gentoo auto-resync : 31:12:2023 - 23:51:53
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-1.9.6.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index cc09df0259e5..fe7865d87c62 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,3 +1,5 @@
DIST Nuitka-1.9.5.tar.gz 3911838 BLAKE2B 064ad4aa48d94b4eb7c886d445e7228c72d03dcb22e75e82a7c43b42a20a32f1b11855017f72101e54c45b4591ffd2af0912191eb7f13367f16726208308a6de SHA512 8b8bc0ec0f4666ae63bd4cb3463c6321bd1cbde7a64ca37d500bd2e60d50f6a13aca5dc89a101d7b8e39622e21091b24232ecf8361b4ae9a9913c187742c7607
+DIST Nuitka-1.9.6.tar.gz 3914776 BLAKE2B 82a50f642f8b93caa725bbfffa6236d490ccb8d731ea917886d0cde03aa6c2237f6c8ff7687ad3140c985cc7c5b525e16aaf07bd604232e32b7fa0fb102a00f5 SHA512 005be29f72685677da1e037b36381765c1248bc2940eb92a46e8e5df990f0241af831b8cf28ab2957d3a7d3d0cb03c2b99ab5af4e900afba53b5ac60e95d1a24
EBUILD Nuitka-1.9.5.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
+EBUILD Nuitka-1.9.6.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-1.9.6.ebuild b/dev-python/Nuitka/Nuitka-1.9.6.ebuild
new file mode 100644
index 000000000000..f511685d5ce1
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.9.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}