summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-17 12:23:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-17 12:23:44 +0100
commit4d6e1311ded368813dc93f130293f64148e22c45 (patch)
tree966c774d10cd502da9a136e2d595f430efb0850d /dev-python/Nuitka
parent2ca31eebd5b7496656193e0aa6ae39200d69a017 (diff)
gentoo auto-resync : 17:08:2024 - 12:23:44
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-2.4.7.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index dae834fb662a..b6d4a98952eb 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,7 @@
DIST Nuitka-2.4.4.tar.gz 3719076 BLAKE2B 513a84e9b8ec222f14df253eab53c82edf2a663e97ac4b272481f2c3df306ad4d9c7b7785295718c68aadb02b04c8a31b0dc58f9ed0418ad2e530dbcff1f1cbf SHA512 9cdcb377d3e7c0a64e7bb76fa3b1ca7ef6b1590c91bae82e34638fd2bab8e1497a6683c4db243e51e4653b105af43dd86e071c5c33c3baf15e58ee81e1388ca0
DIST Nuitka-2.4.5.tar.gz 3718921 BLAKE2B 23549ef422c635c644ff65e2a7f63729d538b6d7149d31b31251cc84232d8069be616a2cdf6878f0c54876dce1296afecdc6b76b0046bdec3c62a24bd5145cf0 SHA512 f582c9b28e673fd152e9a2cc567457412d7d0da64be94d466933c68e50464346657ed107f4042060eb837a8b1d1f0b182c50bd3e665ffe47b636f467a81a5a82
+DIST Nuitka-2.4.7.tar.gz 3719215 BLAKE2B afe2aa119db21d36377f41cbd8a20bdfb732ca5dc111ebc4156c9f4e12f3828d8d17ceb5423e49829fa2554a0e8416822af7148efb1efa14b49628f03b9791fc SHA512 08ab175180ed21ae0341cc88c9644351137054476fba00ee0c857c3c30f1a1da6c240fc9af873a9bc92faee657af11bd4108613a9c721ff27c6d73a603021ad0
EBUILD Nuitka-2.4.4.ebuild 1110 BLAKE2B b092bfe4db9bebe649cd0b5c84a9b608d8c99511d4d73c94952b215fe09981e60e033f3e47ba5eaa7332914d6b47629f1584e00b95818d9c2e956ff1675ff410 SHA512 ce843edbc7c36c9a2603e39808862188d33ed93d4cafb5c5ace041da50282c312709cbf0806bb18a828344f241d69b8d5e331b9c24d78f6fa313769283161ebd
EBUILD Nuitka-2.4.5.ebuild 1110 BLAKE2B b092bfe4db9bebe649cd0b5c84a9b608d8c99511d4d73c94952b215fe09981e60e033f3e47ba5eaa7332914d6b47629f1584e00b95818d9c2e956ff1675ff410 SHA512 ce843edbc7c36c9a2603e39808862188d33ed93d4cafb5c5ace041da50282c312709cbf0806bb18a828344f241d69b8d5e331b9c24d78f6fa313769283161ebd
+EBUILD Nuitka-2.4.7.ebuild 1110 BLAKE2B b092bfe4db9bebe649cd0b5c84a9b608d8c99511d4d73c94952b215fe09981e60e033f3e47ba5eaa7332914d6b47629f1584e00b95818d9c2e956ff1675ff410 SHA512 ce843edbc7c36c9a2603e39808862188d33ed93d4cafb5c5ace041da50282c312709cbf0806bb18a828344f241d69b8d5e331b9c24d78f6fa313769283161ebd
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-2.4.7.ebuild b/dev-python/Nuitka/Nuitka-2.4.7.ebuild
new file mode 100644
index 000000000000..274aff9ae3b5
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.4.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}