summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-09 23:33:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-09 23:33:53 +0000
commit304c1973bececee173a9d6235a2c364466d309e1 (patch)
tree11acd7542e4ef6dd961bb3c64dae01ba417212e6 /dev-python/Nuitka
parent4d643b662f77ef9cc872089cad15cf5e7e1f70f2 (diff)
gentoo auto-resync : 09:02:2024 - 23:33:52
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-2.0.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 436e7769565e..571411a33722 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,7 @@
DIST Nuitka-2.0.1.tar.gz 3928704 BLAKE2B 404b1678b761abd2853baa9998fec3710d152a9affdf747d5ccea0d1dc16b861525379ab1999964f81948557484948f43da15614a397e7d85f2f98d4d09afb3e SHA512 70ca004c4207d176e5d504e185a7554a2df4fde8cb93cee440c14a7d785e6dafd587d205c277a681dcbba40e221c3fa46f240c97ecf08c15e2ca801cac4fcc68
+DIST Nuitka-2.0.2.tar.gz 3930125 BLAKE2B b588e57a216f81f02bc6b50355c3cebf37f94a95c320524ea26a772dfbdbb2c8005f3749c145021c400c921957ea666711ad2b67ab12710f9f9ecaa552aedff0 SHA512 722501f1de174c074a6c95c463888e481b3f9b74ccba7a5bd9cdddf74a23abd46473fe532f22b4c542893d942f009985a330588654852a8f7c2994b543538637
DIST Nuitka-2.0.tar.gz 3964226 BLAKE2B 76ace502390dcb9c10ae9a9dc624575453a0e9c440509b40e74162200d84942be565f07a0877f3bfeb8b82b4f1398f8d7c9150e19d8be58e3f67859f0656277d SHA512 93125344fa8556c0c185dabce14786f52f9db37ba1cbdb1d9fafc08d72be66bbb2bad4e55b12a92c84d85efef6d914fb6ae4e5ca7c4da0574f1892152b111ea0
EBUILD Nuitka-2.0.1.ebuild 1110 BLAKE2B b721d6365110c5765d599fd5044e3b9252dbe99a05187868f4a74ffb460e96dacd839e6a28b8ee727227c03d4b415186dfc40d9fa16aa03e5c093b65e8a30137 SHA512 03d2a302cc97b1c70bd5bcc4d9069e9a987d985c621832647a962137a6a480d6cc278a154c3e3e189ff63e6c93896b8ff5fbb5c5298b854c9bced7e4da0751d7
+EBUILD Nuitka-2.0.2.ebuild 1110 BLAKE2B b721d6365110c5765d599fd5044e3b9252dbe99a05187868f4a74ffb460e96dacd839e6a28b8ee727227c03d4b415186dfc40d9fa16aa03e5c093b65e8a30137 SHA512 03d2a302cc97b1c70bd5bcc4d9069e9a987d985c621832647a962137a6a480d6cc278a154c3e3e189ff63e6c93896b8ff5fbb5c5298b854c9bced7e4da0751d7
EBUILD Nuitka-2.0.ebuild 1116 BLAKE2B 705278b91c7a8e5e7cdce1f9d738fbc743e4c82eb8aad85dfbc4bd1ce8f00fba5b13eaef019c82b28c3e1c1f6f40ff04c20896d98b09fc2f56cac4d892bc30cd SHA512 2f286f299cddb0736a245786b36c1df800dde817eccc7b6b96213b3317e1b0d5aedc620319651780cfb12bfe60a74f22da647b713c07c9c4905b4de8959ebfba
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-2.0.2.ebuild b/dev-python/Nuitka/Nuitka-2.0.2.ebuild
new file mode 100644
index 000000000000..2df076ff3e01
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}