summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
commit1fbaf1314579f2155166bebd1ddfe6131d400807 (patch)
treeb034ac67fab73c50b138ed5a57e5823cda058299 /dev-python/Nuitka
parentf50726afc610727258a31ddfa8b3b32639b20a10 (diff)
gentoo auto-resync : 08:01:2024 - 06:56:53
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-1.9.7.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index fe7865d87c62..daa0a94b5123 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,7 @@
DIST Nuitka-1.9.5.tar.gz 3911838 BLAKE2B 064ad4aa48d94b4eb7c886d445e7228c72d03dcb22e75e82a7c43b42a20a32f1b11855017f72101e54c45b4591ffd2af0912191eb7f13367f16726208308a6de SHA512 8b8bc0ec0f4666ae63bd4cb3463c6321bd1cbde7a64ca37d500bd2e60d50f6a13aca5dc89a101d7b8e39622e21091b24232ecf8361b4ae9a9913c187742c7607
DIST Nuitka-1.9.6.tar.gz 3914776 BLAKE2B 82a50f642f8b93caa725bbfffa6236d490ccb8d731ea917886d0cde03aa6c2237f6c8ff7687ad3140c985cc7c5b525e16aaf07bd604232e32b7fa0fb102a00f5 SHA512 005be29f72685677da1e037b36381765c1248bc2940eb92a46e8e5df990f0241af831b8cf28ab2957d3a7d3d0cb03c2b99ab5af4e900afba53b5ac60e95d1a24
+DIST Nuitka-1.9.7.tar.gz 3916330 BLAKE2B df269672d0c7b860a0aebf0cd9f321442344c69e1ea8ccaad193a835b11ca6cfe048179d3ab03a616525aa022327e168c48406c733354ed13c07c49e26cb0bb8 SHA512 71ce5ef929489ce7a72a2b62b7106dee35380b0d185788e105044cab6448d9c3470e3d783c71a9796404038b8035019816553a360a62d868cfc870675b3bb384
EBUILD Nuitka-1.9.5.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
EBUILD Nuitka-1.9.6.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
+EBUILD Nuitka-1.9.7.ebuild 1115 BLAKE2B 3348a3c3ddb788d8bd8dd55fb63ccc72340cc63e4f1e3265e92abb2e84fc50dc36d34cb95bf0c143775ff27b3104f2a9b5fc06c712cc7b0a850d6b66f65d7c85 SHA512 8044ca9ef3dfb6b1ce9c49f08a75219263a5bad3766e9f11ef80aa71114124bf5ab04121e72f90acb9998dff866e54ef73aa0b1e43b0270dea804e84ae61d899
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-1.9.7.ebuild b/dev-python/Nuitka/Nuitka-1.9.7.ebuild
new file mode 100644
index 000000000000..55247b1bdeb0
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.9.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}