summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka/Nuitka-1.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
commit519f4aac6d5896fe0204e6429485f95240c7ff58 (patch)
tree467adac90d818b96465a433b66ef6bb65e369fef /dev-python/Nuitka/Nuitka-1.4.3.ebuild
parent8afe4133ba3d8586301516885427809020a3cafa (diff)
gentoo auto-resync : 05:02:2023 - 21:17:55
Diffstat (limited to 'dev-python/Nuitka/Nuitka-1.4.3.ebuild')
-rw-r--r--dev-python/Nuitka/Nuitka-1.4.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Nuitka-1.4.3.ebuild b/dev-python/Nuitka/Nuitka-1.4.3.ebuild
new file mode 100644
index 000000000000..3ad289dde538
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.4.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}