summaryrefslogtreecommitdiff
path: root/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild')
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
index 14b661fd6590..25a8f0174d72 100644
--- a/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
+++ b/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit distutils-r1
@@ -14,8 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
RDEPEND="
>=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]
@@ -25,26 +24,19 @@ RDEPEND="
"
BDEPEND="
test? (
- ${RDEPEND}
>=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
distutils_enable_sphinx docs
python_prepare_all() {
- # We don't need pytest-runner to run tests via pytest
- sed -i "s/'pytest-runner'//" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
# Override pytest options to skip coverage and flake8
- pytest -vv --override-ini="addopts=" \
- || die "tests failed with ${EPYTHON}"
+ sed -i -e '/^addopts =/d' setup.cfg || die
+ distutils-r1_python_prepare_all
}
python_install_all() {