summaryrefslogtreecommitdiff
path: root/dev-python/Levenshtein/Levenshtein-0.20.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 09:09:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 09:09:50 +0100
commit2be230a2a252e8e744f11a8b38e9a0097ddc9b25 (patch)
treec7c6cd81169223a110c28f74dfc1b82b3f52bcb1 /dev-python/Levenshtein/Levenshtein-0.20.4.ebuild
parent8d3ae5c288a62253ed3bc3d71336bf2061cfdb51 (diff)
gentoo auto-resync : 27:09:2022 - 09:09:50
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.20.4.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.20.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.20.4.ebuild b/dev-python/Levenshtein/Levenshtein-0.20.4.ebuild
new file mode 100644
index 000000000000..e6bbbc1a531a
--- /dev/null
+++ b/dev-python/Levenshtein/Levenshtein-0.20.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://pypi.org/project/Levenshtein/
+ https://github.com/maxbachmann/Levenshtein/
+"
+SRC_URI="
+ https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-cpp/rapidfuzz-cpp-1.7.0
+"
+RDEPEND="
+ <dev-python/rapidfuzz-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest