summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 14:19:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 14:19:51 +0000
commitea5bad4d0ba1eb937df22adb7f6cc57ea77f03d8 (patch)
tree444d798059985f0e993cb7582231243cd4c5d083 /dev-python/GitPython
parent6989a301768c924a6014fdce19b28de541ad557a (diff)
gentoo auto-resync : 31:12:2022 - 14:19:51
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.27.ebuild79
-rw-r--r--dev-python/GitPython/GitPython-3.1.30.ebuild2
-rw-r--r--dev-python/GitPython/Manifest6
3 files changed, 2 insertions, 85 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.27.ebuild b/dev-python/GitPython/GitPython-3.1.27.ebuild
deleted file mode 100644
index 091cf383e00d..000000000000
--- a/dev-python/GitPython/GitPython-3.1.27.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.9
-SMMAP_P=smmap-5.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream reverted the changes needing py3.10's typing module
- # but did not update the dep
- sed -i -e '/typing-extensions/d' requirements.txt || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- sed -i -e '/addopts/d' pyproject.toml || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # performance tests are unreliable by design
- test/performance
- # unimpoortant and problematic
- test/test_installation.py
- # Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
- # TODO
- test/test_submodule.py::TestSubmodule::test_base_rw
- test/test_submodule.py::TestSubmodule::test_root_module
- )
-
- epytest
-}
diff --git a/dev-python/GitPython/GitPython-3.1.30.ebuild b/dev-python/GitPython/GitPython-3.1.30.ebuild
index 8c785a54a687..1da171d9ce51 100644
--- a/dev-python/GitPython/GitPython-3.1.30.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.30.ebuild
@@ -29,7 +29,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-vcs/git
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 14fb1a59de76..380170c081ba 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,10 +1,6 @@
-DIST GitPython-3.1.27.gitbundle 9652508 BLAKE2B f81b6d94b302b1d4aec85096bb294df1a6a699eff4dd27a1d32083e73b031daf3ef58ec6aa6f98c7693ef187b21de9ea242fa37a88b1f51c0e17238dda978c5c SHA512 bf1011a765b51eb871f6b6a462c693e4e79bb0ba81103d4f268b780b86ab12112c44f74c1d68e93388d1f86c068f6c2336f33ea12dce2e0b2302c940ebb9c49f
-DIST GitPython-3.1.27.tar.gz 192188 BLAKE2B 3cab995a17d8eca8d4301367b1ee7a2c3c0a46a217f6e6d89e1bb4e62b733d21cd6d9210faac49c3c905343067e819f8c37ac9cc69d9fc33ce948b63fd53714e SHA512 6f855bcfc380c1a83a97807ca8ddcc4dfe8258f3aba0790142ef41f28befff44847aec925e523eaac47fd6c0078eb6296f52bb4b7d2be7d59ad95bbeb930fe28
DIST GitPython-3.1.30.gitbundle 9945082 BLAKE2B ac3e530509d459303c0c465668c92073d0532bb75c0635c9e5521857132c2d3c18f0e30b85830cf101fc0c79cde33a5eaf459cddbd66abeb6185453d90e4077d SHA512 e43275e8ffc3fb02e360503de3cd9d0b2c817f870361fe6bcfcd9dec30da077c4c685f57bce408ec670f2fb49d265abca34bf14d806a3ea54fd25f9eaf5019b3
DIST GitPython-3.1.30.tar.gz 195508 BLAKE2B ba3dcb7c7aba8ec42842e6240777b8823e641139e6704641a7236ea07b2a82966638fb074c8fe3ff47b66e23aa526cfc899d8c28359f260f62fd1962a6de66de SHA512 067e64c801ca3882d70aca7706b3a57a51597817f0a3f03290a17e3ebb0fa0fd04cd1d72a32eae3bb72b6c486ffd26d1ede9cee5b17d99ffceb0f8dcc83081b9
DIST gitdb-4.0.10.gitbundle 1485461 BLAKE2B 5a217c609a402cd7888da1502b25d217812503cd703cda8bce3c7159732c59d7f4bcd52688a5da457f43fde1645a6db79588a6fc8cc8dff5c58e9dcbaef79b9a SHA512 98dba48f75e28eaded791f91c611e07bef73c28a7f8ac58889b05d04f4b3699a85a5be1c829ea3e2f380507a9009f35bc552bb4260564127e2863807f9b4712a
-DIST gitdb-4.0.9.gitbundle 1461448 BLAKE2B dad9efdc4e9711361c851f4745df2e3fa3b2360ab58cffea971a854429cf3e11862a267efb5afa3d9ff7668dc6d1bb7f11aa033172238bea61a6252d0488b746 SHA512 eb71e6dd380e67a96a9dcd50a3a3c82aab8c7f85b1ca4258a92202a5e4cb5a1535363599c94ab26884b4cd755ce30694c1b193a95e5cd5199b5d4e2cf8e72818
DIST smmap-5.0.0.gitbundle 338621 BLAKE2B 58c151245a1353d482e06313beb1cfbe7aa23d30733b284b1745b562da1da4e6f9b8acd7d4b967987e8c29a0cfbe6d3b27790f4683f6cbd86fc22a1416bc1c24 SHA512 94b827cdcfaf31b726b48b7b0a9036e852683046b07430b79e59a1339079ca078129d5eb02d9009979ce86892748b700d6cd281e401ddf6b0048252e2181fe1f
-EBUILD GitPython-3.1.27.ebuild 2207 BLAKE2B 6592c43024b52a004909dc5d980e816a2be01d4dbfa4ecfba2365292781c84aa07b39e2f458413952fdb6adc5522417f737069552c166d9dfd45516618c8aa28 SHA512 c06de5bc0d32a7f3b50e4b4da04559903f8de4777bfbe5ddf7c451ed8224e924c9d57fafe9dcc05c0a8f995322550d16823a836d2ceca40b6323d46da3ed32d8
-EBUILD GitPython-3.1.30.ebuild 2277 BLAKE2B 4aeb45eb92b0c701ccd426b95318edc1d4a1b917775e06e2271da6418bfff64e7c8ae21d468996ae471799fe8a1e1f9dd9c4cf2f03b8578388f2f7d0ebc1342c SHA512 f0a177696446c0d36dbc5a8d36f7945bf41979b9284518fbcb632cf4e27193b75fdfbd7805debda7625bf6db87dd0b9c314b290406afd79a2662ae23e7c8e396
+EBUILD GitPython-3.1.30.ebuild 2269 BLAKE2B 8eaaaff0ccfd7e684a595e282d00514296029066e039fbcd5092dbef642ed89390152bb1ba518202675bad6ea010be0d42fd8b8d281192c4565e58d94c2854d2 SHA512 7d271a31a198f2632ccf5bc11e54b2a85e1918f6d237e2b8d09c4ca5886a0ddb6aa74c4ce83a5854fa4fc1d19c97ce9ff893a7841cff9580defa73f0af47563c
MISC metadata.xml 407 BLAKE2B 49fd8d520d575be1489c299f22595120fad882f055b9cf2d02b87382c6d8f0ff38af694e5584b4da579aa84b82c2f1032e4afb64cafd9f4fe9212a6d67b4a752 SHA512 1bebe1e134eb86a4745cf7e297d45118a2bdd3d8a71d0034294b5c799a9cee763c63b61b34c6707c52f61058f727f4b827dd020d285fc297712b29eb7c1129ef