summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-19 09:49:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-19 09:49:52 +0100
commitd99752d3d5e12a0fc38778cb734bc68bbe2ed3bb (patch)
tree5f37e3f56df65ede7caf11eb0bd1fbf0ee03ac3c /dev-python/GitPython
parenta643f0010255d34e6b8045aba39aef5174921a7d (diff)
gentoo auto-resync : 19:10:2023 - 09:49:52
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.40.ebuild84
-rw-r--r--dev-python/GitPython/Manifest4
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.40.ebuild b/dev-python/GitPython/GitPython-3.1.40.ebuild
new file mode 100644
index 000000000000..52f6a25ddaf6
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.40.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.10_p1
+SMMAP_P=smmap-5.0.0_p1
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="
+ https://github.com/gitpython-developers/GitPython/
+ https://pypi.org/project/GitPython/
+"
+SRC_URI+="
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ git rev-parse HEAD > .git/refs/remotes/origin/master || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance tests are unreliable by design
+ test/performance
+ # unimpoortant and problematic
+ test/test_installation.py
+ # Internet
+ test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
+ test/test_quick_doc.py::QuickDoc::test_cloned_repo_object
+ # requires which(1)
+ # https://github.com/gitpython-developers/GitPython/pull/1525
+ test/test_git.py::TestGit::test_refresh
+ # TODO
+ test/test_submodule.py::TestSubmodule::test_base_rw
+ test/test_submodule.py::TestSubmodule::test_git_submodules_and_add_sm_with_new_commit
+ test/test_submodule.py::TestSubmodule::test_list_only_valid_submodules
+ test/test_submodule.py::TestSubmodule::test_root_module
+ )
+
+ epytest -o addopts= test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 63ccd613af4f..08007d9dc619 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -2,8 +2,12 @@ DIST GitPython-3.1.37.gitbundle 9744035 BLAKE2B 57f16e0ebfdf6e2078c8a8fa220185ad
DIST GitPython-3.1.37.tar.gz 200076 BLAKE2B b5db83f6712a94464fec98229af739ca7eb71eb47bd03164e94bb680c03bd84e49c7956e3a58937464c6fd6e4254a24d5e89150f40a59c5d101d7e56daca8fba SHA512 c036b5a12b2839a152d21cc6163445c067d70b18984888e799b0900449bea0a5290f6520fae5cab83fb8553af9c6bb0150c9b28103311deecb3686de30dd35f1
DIST GitPython-3.1.38.gitbundle 9830368 BLAKE2B 4a0e5c9f7f859b49d36d8d8deef79aa59615698416586d2802d428d21b959bd80da78555588f51db4833f35e2cc63d56ef9188a59916693af484e6e6ccc4c6b9 SHA512 5fff695ac828bb0495fb8dd9bc75f57e44d721ad8010577d567c34638e75855d22ce6560649cebe26a84f1baa0f245b82b9369e19ce6e3af36eadcfd51049c23
DIST GitPython-3.1.38.tar.gz 200632 BLAKE2B 56c9b0f96c70e9f021d9830b220a43902de58271c38b25886c93d33706bd5a4dd081ca3cc3c126c7d5da24ed715a36b570b7a81f9d71aa3c1bfc77f2f7865730 SHA512 39bdf3dc3b1b1467a6f5426817977a353d54d4798451126f847911039de84d7d8030bc4d4263fd7584685a5a8113fc62d29f6c98c0bc95b646ee4f2f0ef60862
+DIST GitPython-3.1.40.gitbundle 9832215 BLAKE2B 2aa1dac889267bd0b81f9451bc347b842cc5ad542a490fcc6f951cc1ee40f807c7cb5a178772c8abf43893fd9815aa570d2e53a561a0c8bf431dc5fa6429cdfd SHA512 25ca1f1b620e72a1c58a7b609dc6e761afdb1502d35ad26411fde47d5d2099b6bf6160ce85288bf280e28b3c8f30471c9f791cfb66878bc1ef7d46f58f880e81
+DIST GitPython-3.1.40.tar.gz 200655 BLAKE2B c95cd864bfc664eb704ac3702f5a6c78fc0f2288af945001622cb78c2e855fdf3af068736c569392a29b201dc3952d0574c7f7c39c0531269b6efb55f5506344 SHA512 e8ade266002aa6fcd4b12e3828e7ec45b4dd894c897f31946dc29461b7e81b380ea832a9ea270533e7491e006c92948c62bbc21ab960467cf6287d0bac5228cf
DIST gitdb-4.0.10.gitbundle 1485461 BLAKE2B 5a217c609a402cd7888da1502b25d217812503cd703cda8bce3c7159732c59d7f4bcd52688a5da457f43fde1645a6db79588a6fc8cc8dff5c58e9dcbaef79b9a SHA512 98dba48f75e28eaded791f91c611e07bef73c28a7f8ac58889b05d04f4b3699a85a5be1c829ea3e2f380507a9009f35bc552bb4260564127e2863807f9b4712a
+DIST gitdb-4.0.10_p1.gitbundle 1612782 BLAKE2B 9a424df0afd174da722c4721a5a52db83dccc5a2d69dd186622e5e21c48a6fdb6f20d84ad959f2070d8ff4cfa1e9be8f99b97e2a6ce5aab1696737858429e018 SHA512 b52a978ffbda8fb048fa0920cc2cc597b077b468dd77ce1a8e784ca7c724760eee75b168ac98f1051b03d364ba88812e8cacd5a7f6fa658cf312e626d0b2ad0a
DIST smmap-5.0.0_p1.gitbundle 324544 BLAKE2B 69098c7644abaec7f32226cad7ff3008e49d94c9f7349d0b815223249c20bfd2b51a50474e51864821f30c98f5982e5c35ce9217145a1e5d11326492c41faecc SHA512 4f36ca2c94ddfeb949c880fb52c3b1905d144dd59b95f2f05c93ed7b694dcb128218a2800ca23b721fbeff9a1920e8c3326675098e2ef0361ff6e90c8c2850ba
EBUILD GitPython-3.1.37.ebuild 2329 BLAKE2B d1624385cbbb707a699a0cbdd0c79267f081ce759c01f8a2aecf998646ae4183d7e7e6d22b969d3926ffc62e2ee7956089c2a3a2f801f884d8ede62e22076990 SHA512 dced81b22474510b093621932d72b99c6447e84499d48f113f4dc7170b621cc8bbe0a6c46ac1f3ea5fc9451dfab0076f44e03e69e446c5a1ba89427cbe474a55
EBUILD GitPython-3.1.38.ebuild 2337 BLAKE2B c5065e57ccddaccdc1371f692705d0febced2c4ffa789436785e90f49b5267abb887f82a4d1659f3982eeac2c3cf514d1d0b2e7dab85e08acbbdffbc22f60e3b SHA512 8eecd47587b3c70221c0c9920b576f36688868825942eab369f64a88dccb9c0ff9c23a12111420ad3084b31d9c849bad4846804901c37ece50f6ab3b59d86a8e
+EBUILD GitPython-3.1.40.ebuild 2340 BLAKE2B 9eeccbd656de2d50f7ed597390e96080e7a5b16c2c58d00d80d83f18b043e9046209d471bb4e487a849dcb0a9fb2de7e487caca2e23f1c5bf487b50f4fbe48b9 SHA512 4a89cb7b5e83d1717d7bc3baf7f7f7acdc663bf6722f3f6a50ee072240db9d6b325bc731e65bcad4ef537b190f0e0a640e630e01cc54c9915c482033a73b1161
MISC metadata.xml 407 BLAKE2B 49fd8d520d575be1489c299f22595120fad882f055b9cf2d02b87382c6d8f0ff38af694e5584b4da579aa84b82c2f1032e4afb64cafd9f4fe9212a6d67b4a752 SHA512 1bebe1e134eb86a4745cf7e297d45118a2bdd3d8a71d0034294b5c799a9cee763c63b61b34c6707c52f61058f727f4b827dd020d285fc297712b29eb7c1129ef