summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
commit7ece7f3d3bcd0184dd8dfd6653464da80184963c (patch)
tree11ae8def15c0148aaf70c9bcfb86da05c82de6a1 /dev-python/GitPython
parent6a4408b9bbd9fe61dc0966f587db94081fa5f52b (diff)
gentoo auto-resync : 11:01:2024 - 01:05:34
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.41.ebuild79
-rw-r--r--dev-python/GitPython/Manifest5
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.41.ebuild b/dev-python/GitPython/GitPython-3.1.41.ebuild
new file mode 100644
index 000000000000..c4176c6f7556
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.41.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.11
+SMMAP_P=smmap-5.0.1
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="
+ https://github.com/gitpython-developers/GitPython/
+ https://pypi.org/project/GitPython/
+"
+SRC_URI+="
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/sumtypes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ git rev-parse HEAD > .git/refs/remotes/origin/master || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance tests are unreliable by design
+ test/performance
+ # unimportant and problematic
+ test/test_installation.py
+ # Internet
+ test/test_quick_doc.py::QuickDoc::test_cloned_repo_object
+ # TODO
+ test/test_submodule.py::TestSubmodule::test_base_rw
+ test/test_submodule.py::TestSubmodule::test_root_module
+ )
+
+ epytest -o addopts= test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 76534f3eb139..42f6d9e75187 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,6 +1,11 @@
DIST GitPython-3.1.40.gitbundle 9832215 BLAKE2B 2aa1dac889267bd0b81f9451bc347b842cc5ad542a490fcc6f951cc1ee40f807c7cb5a178772c8abf43893fd9815aa570d2e53a561a0c8bf431dc5fa6429cdfd SHA512 25ca1f1b620e72a1c58a7b609dc6e761afdb1502d35ad26411fde47d5d2099b6bf6160ce85288bf280e28b3c8f30471c9f791cfb66878bc1ef7d46f58f880e81
DIST GitPython-3.1.40.tar.gz 200655 BLAKE2B c95cd864bfc664eb704ac3702f5a6c78fc0f2288af945001622cb78c2e855fdf3af068736c569392a29b201dc3952d0574c7f7c39c0531269b6efb55f5506344 SHA512 e8ade266002aa6fcd4b12e3828e7ec45b4dd894c897f31946dc29461b7e81b380ea832a9ea270533e7491e006c92948c62bbc21ab960467cf6287d0bac5228cf
+DIST GitPython-3.1.41.gitbundle 10232969 BLAKE2B 8d831241a706c7e0729e81b177bbeb307ff40cc0cbc0a2693cf0f78478732368cee4b26d6621ae5948a3183258961cf841284e77ba6326de80ca8e2b9bb6ab72 SHA512 9ff45afabfd04ad1bc7bfc9a37b2c3ddf12e8d62d66f4efae07a60a19d6ab05e027e3fe8ad7a0019bfdf3e6d255c4f493987e9f3761f575976e34fabe16dc79d
+DIST GitPython-3.1.41.tar.gz 209029 BLAKE2B be7dfac9a6bc318c33b7cc8d1c6e801f6d0e0f46916a617cceba0f831684953c759ad7b8ed690cca92b07636418dea021dc38608194c7cb6c985ea401b669e47 SHA512 e6d113b4e45505481d46fce1b3b71e3dcfc0f3576ffb8bdd1b0ce3d3ec1625cfad4a8dce3d5126545d66ff72eb74421408f690a44d52e1513be59466721e4c45
DIST gitdb-4.0.10_p1.gitbundle 1612782 BLAKE2B 9a424df0afd174da722c4721a5a52db83dccc5a2d69dd186622e5e21c48a6fdb6f20d84ad959f2070d8ff4cfa1e9be8f99b97e2a6ce5aab1696737858429e018 SHA512 b52a978ffbda8fb048fa0920cc2cc597b077b468dd77ce1a8e784ca7c724760eee75b168ac98f1051b03d364ba88812e8cacd5a7f6fa658cf312e626d0b2ad0a
+DIST gitdb-4.0.11.gitbundle 1620355 BLAKE2B 8095193318d4262b8ebb04f35a0500eda8757057ed472dbaaece53e6afa6227e2b2c02a2be5daa5e4c0cc43dcbb5046555407d3d7c8dbed0bc5c415515032b8d SHA512 17e404b335a3c081f4058aeba5c57e5697a580f8ad7a280fde868968cf48f5a0852bfa45019eab730279582c0c536f8204e973d93af09da05908477329d73360
DIST smmap-5.0.0_p1.gitbundle 324544 BLAKE2B 69098c7644abaec7f32226cad7ff3008e49d94c9f7349d0b815223249c20bfd2b51a50474e51864821f30c98f5982e5c35ce9217145a1e5d11326492c41faecc SHA512 4f36ca2c94ddfeb949c880fb52c3b1905d144dd59b95f2f05c93ed7b694dcb128218a2800ca23b721fbeff9a1920e8c3326675098e2ef0361ff6e90c8c2850ba
+DIST smmap-5.0.1.gitbundle 362567 BLAKE2B 72c8b48ad3250a33b94218c145c02033dee84c1da5f1eea57983a58699262d51844be675330d95c7d64924b6aeaacd4b0a57e9a5acad3be184aaad62102202e7 SHA512 9ca8386bfec25d1562cdf1c2ee85f7edb15fd3f44ecd1abbef738979f12b82f0b0f39a06589203a39f89518d981d7129e35f64f2d855cd162cd964bdd87c8d18
EBUILD GitPython-3.1.40.ebuild 1975 BLAKE2B 2ed7715f36a75a96aa3363073336e7598fc4246fd469bd7a8b14707ae9422f8f6593f2d3fe5d347e154b0fcd36b737c474aa3c2789ff061bdb45fb5185750622 SHA512 9119a3d53a0b522ab4b055786b488f2264568dff031067868a72fbd3a51832ea07cb72fab35600b586d509e0f3a0e026971eaacb9a2f969672e36c53cbdc6bee
+EBUILD GitPython-3.1.41.ebuild 1913 BLAKE2B 53f7991cb9b2db1c4aea8e47f2b69c9969756671831bd94fb53c5c62a7eb443fa347e8fffd54afa824e112003f5f979d49393ff6a4c46525bab0667319ff616c SHA512 6c4feb3bd857c67ee9f194bd80de965c895a693c54443fedd7b57753d1e4936fe0e074324031cf27a6e7eaf5a5858e025c87a01ac6f5527a503de51886caa33e
MISC metadata.xml 407 BLAKE2B 49fd8d520d575be1489c299f22595120fad882f055b9cf2d02b87382c6d8f0ff38af694e5584b4da579aa84b82c2f1032e4afb64cafd9f4fe9212a6d67b4a752 SHA512 1bebe1e134eb86a4745cf7e297d45118a2bdd3d8a71d0034294b5c799a9cee763c63b61b34c6707c52f61058f727f4b827dd020d285fc297712b29eb7c1129ef