summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/GitPython
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-2.1.11.ebuild37
-rw-r--r--dev-python/GitPython/GitPython-3.1.0.ebuild56
-rw-r--r--dev-python/GitPython/Manifest8
-rw-r--r--dev-python/GitPython/metadata.xml12
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-2.1.11.ebuild b/dev-python/GitPython/GitPython-2.1.11.ebuild
new file mode 100644
index 000000000000..c995e67a79ea
--- /dev/null
+++ b/dev-python/GitPython/GitPython-2.1.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests only work with the GitPython repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/GitPython/GitPython-3.1.0.ebuild b/dev-python/GitPython/GitPython-3.1.0.ebuild
new file mode 100644
index 000000000000..8d0903d98997
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+GITDB_P=gitdb-4.0.2
+SMMAP_P=smmap-3.0.1
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ git clone "${DISTDIR}/${P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ # remove performance tests
+ rm -r git/test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' git/test/test_remote.py || die
+ # broken apparently
+ sed -i -e 's:test_rev_parse:_&:' git/test/test_repo.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
new file mode 100644
index 000000000000..a3e9a742f943
--- /dev/null
+++ b/dev-python/GitPython/Manifest
@@ -0,0 +1,8 @@
+DIST GitPython-2.1.11.tar.gz 428531 BLAKE2B 18b00f1e622c6588c14e1625f944d117348fb77e67161117510f42c8381db8cde8c6e16fa911edabfc4410239622fb845931b247bab4133585d2ec27969fea4c SHA512 5f964ee56c3f27c28f502150216af29b8463b19d9c0f773458dbabf17ba8587ee5c5e3fbcb31ad46c55e202d06bae447fd40007890a1bc116fe0370cdfc6401f
+DIST GitPython-3.1.0.gitbundle 8618276 BLAKE2B a1ecf49c47804b399453c6931fb54903309944b47a5a8ccd02d62f4b27943e60b4b58a9e67567008fa4d5bc791b1c86642659c045c885e2155e2c44bb1a4ea81 SHA512 a71463f861f840d3169a8351155665243d9f0f0a72e210940f9f7872cfd49b6ddfac827f0ec5bc61079d8066fc7ba210a03dd99f3bbd598e22ccbcacfe8e61b3
+DIST GitPython-3.1.0.tar.gz 430079 BLAKE2B eaf4d4bb2f589a96bcdcf28e7ac6c0b8eab691a1dee5fbbec6d4a93bab9f123b07073af8a1b85aa5547057e46e6c8c004215167790b559f3848bf20c3ec1697f SHA512 6dab8449cc1736d7f58f9788b56bf63cc2bf0f420104d6e010a9624d21f53f5b5d33135bad4d91b40d9543b454be839f8003828ffe512c35a6513c27a2dd4b53
+DIST gitdb-4.0.2.gitbundle 1474197 BLAKE2B 93dc8aeb3a43f0950bec1e8dc0c0156543a0a1ce1f20a7f0b2cd05c110338af05b6c6300c3f4b2c05e0f895496248e5fdca74eb599a4ea9aa983ed399d91f7c6 SHA512 8d4ebc93d6869a60b7717fc090000067e86a7e0373c281d0fb9939a6e2e283864256f827919eeb13be977254c0c71a4864d8e7c9b4b6dcc0af6275aa59681960
+DIST smmap-3.0.1.gitbundle 263781 BLAKE2B 6e06586010814ce0f59367c7f9289dad4891ee1debbc020b192af3945207da05b1e34907f1871f5b6b9638706b9e2fdacf390fcfff6bd06af84b9fd80f7e63a8 SHA512 c2b6c0b295c2997ed53727d3d1458ae7ec5ddbde9c83349286904726865fc026a70161955498b1a06371fb8d937e7386b80b4ea0c2e5d1c647718e6dbea93104
+EBUILD GitPython-2.1.11.ebuild 873 BLAKE2B d9ae7f3f9cada4731bb07ac4d2cf0770dafeed0645264975250f388304b240c487ff7d627726e263b54fcddfafdbbb768d863f7dbb459d8c637bb4393b6e730a SHA512 203cea364596aeb9492b58b576d33edfe460b03f91fa394acdf9532458ae28ace2492432075157b0f26be5bd03fcaedda05f839dde52c47098bc7b7ae4e2e88f
+EBUILD GitPython-3.1.0.ebuild 1535 BLAKE2B 28d5074ed17d3e54c6df663ef73d57a7fb700fc6e7cfac481ef0281333e6341c9c6de7501b91330bb26b1c6e13a6f5cb9ce4461f6c96e3bd8327a5c0ca79d1df SHA512 e4ea4cdb8811b0f4235edeb38916fc4df085e1489555b164c3f8daaa97a1c34f252ff66b3f4e7f7eb175a17184e4b1c258242dd7f96dd81eae729b1f56c6caeb
+MISC metadata.xml 382 BLAKE2B 9853412552202bb0134ea88f7eae6b36c5c17920cd2834bec4a487cd6e1e6a5421db13a5b5ca7de1bc366ca057c17e2d89f3ea0973023de76a0a0783065d6dc6 SHA512 3f31be6d8a7fc5622f56141778f1779ff092a7e50f6ee162edc7854eb84b896206382edacf678e3f53f513727ca67e3cce0b6b6f50be7cbc93533201533ebe85
diff --git a/dev-python/GitPython/metadata.xml b/dev-python/GitPython/metadata.xml
new file mode 100644
index 000000000000..7e626312fece
--- /dev/null
+++ b/dev-python/GitPython/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">GitPython</remote-id>
+ <remote-id type="github">gitpython-developers/GitPython</remote-id>
+ </upstream>
+</pkgmetadata>